]> git.pld-linux.org Git - packages/openr2.git/blob - openr2.spec
- added libdir patch (always honour libdir passed to configure; fixes x32 build)
[packages/openr2.git] / openr2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        OpenR2 - MFC/R2 signalling over E1 lines
6 Summary(pl.UTF-8):      OpenR2 - sygnały MFC/R2 po liniach E1
7 Name:           openr2
8 Version:        1.3.2
9 Release:        2
10 License:        LGPL v2+ (library), GPL v2+ (utilities)
11 Group:          Libraries
12 #Source0Download: https://github.com/moises-silva/openr2/releases
13 Source0:        https://github.com/moises-silva/openr2/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  5858020ad014c111f6f7a8c86758da6c
15 Patch0:         %{name}-nosvn.patch
16 Patch1:         %{name}-opt.patch
17 Patch2:         %{name}-libdir.patch
18 URL:            https://libopenr2.org/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  dahdi-linux-devel
22 BuildRequires:  libtool
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 OpenR2 is a library that implements the MFC/R2 signalling over E1
27 lines using the Zapata Telephony interface (or DAHDI).
28
29 %description -l pl.UTF-8
30 OpenR2 to biblioteka implementująca przesyłanie sygnałów MFC/R2 po
31 liniach E1 przy użyciu interfejsu Zapata Telephony (lub DAHDI).
32
33 %package devel
34 Summary:        Header files for OpenR2 library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenR2
36 License:        LGPL v2+
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Header files for OpenR2 library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki OpenR2.
45
46 %package static
47 Summary:        Static OpenR2 library
48 Summary(pl.UTF-8):      Statyczna biblioteka OpenR2
49 License:        LGPL v2+
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static OpenR2 library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka OpenR2.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p1
63 %patch2 -p1
64
65 %build
66 %{__libtoolize}
67 %{__aclocal}
68 %{__autoconf}
69 %{__autoheader}
70 %{__automake}
71 %configure \
72         %{!?with_static_libs:--disable-static}
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS CREDITS ChangeLog NEWS README TODO doc/README.asterisk doc/asterisk
90 %attr(755,root,root) %{_bindir}/r2dtmf_detect
91 %attr(755,root,root) %{_bindir}/r2test
92 %attr(755,root,root) %{_libdir}/libopenr2.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libopenr2.so.3
94 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/r2proto.conf
95 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/r2test.conf
96 %{_mandir}/man5/r2test.conf.5*
97 %{_mandir}/man8/r2test.8*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libopenr2.so
102 %{_libdir}/libopenr2.la
103 %{_includedir}/openr2
104 %{_includedir}/openr2.h
105
106 %if %{with static_libs}
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libopenr2.a
110 %endif
This page took 0.102353 seconds and 3 git commands to generate.