]> git.pld-linux.org Git - packages/ocaml-stew.git/blob - ocaml-stew.spec
f6e26539a4f1228225c2429ce10f9438f57a21aa
[packages/ocaml-stew.git] / ocaml-stew.spec
1 %define         ocaml_ver       1:3.09.2
2 Summary:        A stew of OCaml utility function
3 Summary(pl.UTF-8):      Zbiór funkcji narzędziowych dla OCamla
4 Name:           ocaml-stew
5 Version:        0.12.0
6 Release:        18
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://raevnos.pennmush.org/code/stew-%{version}.tar.gz
10 # Source0-md5:  7e822ca90a5265a2f1b94e81add6eb4c
11 URL:            http://raevnos.pennmush.org/code/ocaml.html
12 BuildRequires:  autoconf
13 BuildRequires:  ocaml >= %{ocaml_ver}
14 BuildRequires:  ocaml-findlib >= 0.7.2
15 BuildRequires:  ocaml-pcre-devel
16 %requires_eq    ocaml-pcre
17 %requires_eq    ocaml-runtime
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Stew is a general-purpose library of useful utility and extension
22 routines. Highlights include random number generators and
23 distributions, locale support, improved time printing, and character
24 classification routines that are locale-dependant.
25
26 This package contains files needed to run bytecode executables using
27 this library.
28
29 %description -l pl.UTF-8
30 Stew jest ogólnego użytku biblioteką użytecznych funkcji narzędziowych
31 i rozszerzeń. Zawiera generatory i dystrybucje liczb losowych,
32 wsparcie dla lokalizacji, ulepszone drukowanie czasu, oraz funkcje
33 klasyfikacji znaków (<ctype.h>), które są zależne od locale.
34
35 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
36 używających tej biblioteki.
37
38 %package devel
39 Summary:        A stew of OCaml utility function - development part
40 Summary(pl.UTF-8):      Zbiór funkcji narzędziowych dla OCamla - cześć programistyczna
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 %requires_eq    ocaml
44
45 %description devel
46 Stew is a general-purpose library of useful utility and extension
47 routines. Highlights include random number generators and
48 distributions, locale support, improved time printing, and character
49 classification routines that are locale-dependant.
50
51 This package contains files needed to develop OCaml programs using
52 this library.
53
54 %description devel -l pl.UTF-8
55 Stew jest ogólnego użytku biblioteką użytecznych funkcji narzędziowych
56 i rozszerzeń. Zawiera generatory i dystrybucje liczb losowych,
57 wsparcie dla lokalizacji, ulepszone drukowanie czasu, oraz funkcje
58 klasyfikacji znaków (<ctype.h>), które są zależne od locale.
59
60 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
61 tej biblioteki.
62
63 %prep
64 %setup -q -n stew-%{version}
65
66 %build
67 %{__autoconf}
68 %configure
69 %{__make} all opt
70 rm -f *.cma
71 %{__make} DLL='-cclib -lstew'
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{stublibs,site-lib/stew}
76
77 ln -s ../stublibs $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib
78
79 %{__make} install \
80         CAMLLIB=$RPM_BUILD_ROOT%{_libdir}/ocaml \
81         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
82
83 echo >> $RPM_BUILD_ROOT%{_libdir}/ocaml/stew/META
84 echo 'directory = "+stew"' >> $RPM_BUILD_ROOT%{_libdir}/ocaml/stew/META
85 mv -f $RPM_BUILD_ROOT%{_libdir}/ocaml/stew/META \
86         $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/stew
87 rm -f $RPM_BUILD_ROOT%{_libdir}/ocaml/stew/*.mli
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS README
95 %attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
96
97 %files devel
98 %defattr(644,root,root,755)
99 %doc html/*
100 %{_libdir}/ocaml/stew
101 %{_libdir}/ocaml/site-lib/stew
This page took 0.098679 seconds and 2 git commands to generate.