]> git.pld-linux.org Git - packages/ocaml-pxp.git/blob - ocaml-pxp.spec
fd6181a151985cafcfae2eb9dc5e7c45602bd6eb
[packages/ocaml-pxp.git] / ocaml-pxp.spec
1 %define         ocaml_ver       1:3.09.2
2 Summary:        Polimorphic XML Parser for OCaml
3 Summary(pl.UTF-8):      Polimorficzny analizator składniowy XML-a dla OCamla
4 Name:           ocaml-pxp
5 Version:        1.2.3
6 Release:        2
7 License:        distributable
8 Group:          Libraries
9 Source0:        http://download.camlcity.org/download/pxp-%{version}.tar.gz
10 # Source0-md5:  83347420dae0ee495bb0ac2fbab7b74b
11 URL:            http://projects.camlcity.org/projects/pxp.html
12 BuildRequires:  ocaml >= %{ocaml_devel}
13 BuildRequires:  ocaml-findlib
14 BuildRequires:  ocaml-ocamldoc-devel
15 BuildRequires:  ocaml-net-netstring-devel >= 3.6-2
16 BuildRequires:  ocaml-net-netsys-devel >= 3.6-2
17 BuildRequires:  ocaml-ulex
18 BuildRequires:  sed >= 4.0
19 %requires_eq    ocaml-ulex
20 %requires_eq    ocaml-runtime
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 PXP is a validating parser for XML 1.0 which has been written entirely
25 in Objective Caml.
26
27 PXP means "Polymorphic XML Parser" and emphasizes its most useful
28 property: that the API is polymorphic and can be configured such that
29 different objects are used to store different types of elements.
30
31 %description -l pl.UTF-8
32 PXP jest walidującym analizatorem składniowym XML-a 1.0, napisanym w
33 całości w OCamlu.
34
35 PXP oznacza "Polymorphic XML Parser" (polimorficzny analizator
36 składniowy XML-a), co podkreśla jego najbardziej użyteczną własność:
37 API jest polimorficzne i może być skonfigurowane tak, że różne obiekty
38 są używane do przechowywania różnych typów elementów.
39
40 %package devel
41 Summary:        Polimorphic XML Parser for OCaml - development part
42 Summary(pl.UTF-8):      Polimorficzny analizator składniowy XML-a dla OCamla - cześć programistyczna
43 Group:          Development/Libraries
44 %requires_eq    ocaml
45 %requires_eq    ocaml-net-netstring-devel
46 %requires_eq    ocaml-wlex-devel
47
48 %description devel
49 PXP is a validating parser for XML 1.0 which has been written entirely
50 in Objective Caml.
51
52 PXP means "Polymorphic XML parser" and emphasizes its most useful
53 property: that the API is polymorphic and can be configured such that
54 different objects are used to store different types of elements.
55
56 This package contains files needed to develop OCaml programs using the
57 PXP library.
58
59 %description devel -l pl.UTF-8
60 PXP jest walidującym analizatorem składniowym XML-a 1.0, napisanym w
61 całości w OCamlu.
62
63 PXP oznacza "Polymorphic XML Parser" (polimorficzny analizator
64 składniowy XML-a), co podkreśla jego najbardziej użyteczną własność:
65 API jest polimorficzne i może być skonfigurowane tak, że różne obiekty
66 są używane do przechowywania różnych typów elementów.
67
68 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
69 biblioteki PXP.
70
71 %prep
72 %setup -q -n pxp-%{version}
73
74 %build
75 ./configure \
76         -with-lex \
77         -with-ulex \
78         -without-wlex \
79         -with-pp
80
81 sed -i -e 's/-g//' Makefile.rules
82 %{__make} -j1 \
83         all opt
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{site-lib,pxp}
89 OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib %{__make} install
90 dir=`pwd`
91 cd $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib
92 for f in * ; do
93         echo 'directory = "+pxp"' >> $f/META
94         if [ "`echo $f/*.*`" != "$f/*.*" ]; then
95                 mv $f/*.* $RPM_BUILD_ROOT%{_libdir}/ocaml/pxp
96         fi
97 done
98 cd $dir
99 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/pxp/*.{o,mli}
100
101 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
102 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files devel
108 %defattr(644,root,root,755)
109 %doc doc/README doc/SPEC
110 %doc doc/design.txt doc/manual/html
111 %dir %{_libdir}/ocaml/pxp
112 %{_libdir}/ocaml/pxp/*
113 %{_examplesdir}/%{name}-%{version}
114 %{_libdir}/ocaml/site-lib/*
This page took 0.023926 seconds and 2 git commands to generate.