]> git.pld-linux.org Git - packages/nomacs.git/blob - nomacs.spec
- fix building with system quazip
[packages/nomacs.git] / nomacs.spec
1 # TODO: system qpsd (http://sourceforge.net/projects/libqpsd/)
2 #
3 Summary:        Lightweight image viewer
4 Summary(pl.UTF-8):      Lekka przeglądarka obrazków
5 Name:           nomacs
6 Version:        3.0.0
7 Release:        1
8 License:        GPL v3+
9 Group:          X11/Applications
10 Source0:        https://github.com/nomacs/nomacs/releases/download/%{version}/%{name}-%{version}-source.tar.bz2
11 # Source0-md5:  e1630a4371d0e0f8aba9358ab20d43e5
12 Source1:        %{name}.appdata.xml
13 Patch0:         cmake.patch
14 Patch1:         quazip-qt5.patch
15 URL:            http://nomacs.org/
16 BuildRequires:  cmake >= 2.6
17 BuildRequires:  desktop-file-utils
18 BuildRequires:  dos2unix
19 BuildRequires:  exiv2-devel >= 0.20
20 BuildRequires:  libraw-devel >= 0.12.0
21 BuildRequires:  libtiff-devel
22 BuildRequires:  libwebp-devel >= 0.3.1
23 BuildRequires:  opencv-devel >= 2.1.0
24 BuildRequires:  pkgconfig
25 BuildRequires:  Qt5Core-devel >= 5
26 BuildRequires:  Qt5Gui-devel >= 5
27 BuildRequires:  Qt5Network-devel >= 5
28 BuildRequires:  Qt5Concurrent-devel
29 BuildRequires:  qt5-build >= 5
30 BuildRequires:  qt5-linguist >= 5
31 BuildRequires:  qt5-qmake >= 5
32 BuildRequires:  quazip-qt5-devel >= 0.7
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 nomacs is image viewer based on Qt library.
37
38 nomacs is small, fast and able to handle the most common image
39 formats. Additionally it is possible to synchronize multiple viewers
40 running on the same computer or via LAN is possible. It allows to
41 compare images and spot the differences e.g. schemes of architects to
42 show the progress).
43
44 %description -l pl.UTF-8
45 nomacs to przeglądarka obrazków oparta na bibliotece Qt.
46
47 nomacs jest mała, szybka i potrafi obsłużyć większość popularnych
48 formatów obrazów. Ponadto możliwa jest synchronizacja wielu
49 przeglądarek działających na tym samym komputerze lub poprzez sieć
50 lokalną. Przeglądarka pozwala porównywać obrazki i wskazywać różnice,
51 np. projekty architektów w celu pokazania postępów.
52
53 %prep
54 %setup -q
55 %patch0 -p1
56 %patch1 -p1
57
58 dos2unix Readme/*
59
60 %{__rm} -r 3rdparty/libwebp
61 %{__rm} -r 3rdparty/quazip-0.7
62
63 %build
64 install -d build
65 cd build
66 %cmake \
67         -DENABLE_PLUGINS=ON \
68         -DENABLE_RAW=1 \
69         -DUSE_SYSTEM_WEBP=ON \
70         -DUSE_SYSTEM_QUAZIP=ON \
71         ..
72 # -DUSE_SYSTEM_LIBQPSD=ON
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} -C build install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 # translation to German "Vorarlbergerisch" dialect - should be de_AT@Vorarlberg?
82 # ("als" is wrong code - it's Tosk Albanian in iso-639-3)
83 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/nomacs_als.qm
84
85 desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
86
87 install -d $RPM_BUILD_ROOT%{_datadir}/appdata
88 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/appdata/%{name}.appdata.xml
89
90 %find_lang %{name} --with-qm --without-mo
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post
96 /sbin/ldconfig
97 %update_desktop_database
98
99 %postun
100 /sbin/ldconfig
101 %update_desktop_database
102
103 %files -f %{name}.lang
104 %defattr(644,root,root,755)
105 %doc Readme/{COPYRIGHT,LICENSE.OPENCV,README}
106 %attr(755,root,root) %{_bindir}/%{name}
107 %attr(755,root,root) %{_libdir}/libnomacslib.so
108 %{_mandir}/man1/%{name}.1*
109 %dir %{_datadir}/%{name}
110 %dir %{_datadir}/%{name}/translations
111 %{_datadir}/appdata/%{name}.appdata.xml
112 %{_desktopdir}/%{name}.desktop
113 %{_pixmapsdir}/%{name}.png
This page took 0.081498 seconds and 3 git commands to generate.