]> git.pld-linux.org Git - packages/neon.git/blob - neon.spec
1cbcc34f426177e319e8073097c3bc86ce69dc95
[packages/neon.git] / neon.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  kerberos5       # don't build Kerberos V support
6 %bcond_without  libproxy        # don't build libproxy support
7 %bcond_without  pakchois        # don't build pakchois-based PKCS#11 support
8
9 Summary:        An HTTP and WebDAV client library
10 Summary(pl.UTF-8):      Biblioteka kliencka HTTP i WebDAV
11 Name:           neon
12 Version:        0.30.1
13 Release:        3
14 License:        LGPL v2+
15 Group:          Libraries
16 Source0:        http://www.webdav.org/neon/%{name}-%{version}.tar.gz
17 # Source0-md5:  231adebe5c2f78fded3e3df6e958878e
18 URL:            http://www.webdav.org/neon/
19 BuildRequires:  autoconf >= 2.58
20 BuildRequires:  automake
21 %{?with_kerberos5:BuildRequires:        heimdal-devel}
22 %{?with_libproxy:BuildRequires: libproxy-devel}
23 BuildRequires:  libtool >= 2:2.2
24 BuildRequires:  libxml2-devel
25 BuildRequires:  openssl-devel >= 0.9.7d
26 %{?with_pakchois:BuildRequires: pakchois-devel}
27 BuildRequires:  pkgconfig
28 BuildRequires:  zlib-devel
29 %requires_eq_to openssl openssl-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 neon is an HTTP and WebDAV client library, with a C interface.
34 Featuring:
35  - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD
36    etc).
37  - Low-level interface to HTTP request handling, to allow implementing
38    new methods easily.
39  - HTTP/1.1 and HTTP/1.0 persistent connections.
40  - RFC2617 basic and digest authentication (including auth-int,
41    md5-sess).
42  - Proxy support (including basic/digest authentication).
43  - Generic WebDAV 207 XML response handling mechanism.
44  - XML parsing using the expat or libxml parsers.
45  - Easy generation of error messages from 207 error responses.
46  - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
47  - WebDAV metadata support: set and remove properties, query any set of
48    properties (PROPPATCH/PROPFIND).
49
50 %description -l pl.UTF-8
51 neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
52 Możliwości:
53  - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET,
54    HEAD...),
55  - niskopoziomowy interfejs do obsługi żądań HTTP pozwalający łatwo
56    implementować nowe metody,
57  - stałe połączenia HTTP/1.1 i HTTP/1.0,
58  - uwierzytelnianie podstawowe (basic) i skrótem RFC-2617 (auth-int,
59    md5-sess...),
60  - obsługa proxy (w tym uwierzytelnianie podstawowe i skrótem),
61  - mechanizm obsługi odpowiedzi WebDAV 207 XML,
62  - analiza składniowa XML przy pomocy expat lub libxml,
63  - proste generowanie komunikatów błędów dla odpowiedzi 207,
64  - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
65  - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
66    sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
67
68 %package devel
69 Summary:        Header files for neon
70 Summary(pl.UTF-8):      Pliki nagłówkowe neon
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 %{?with_kerberos5:Requires:     heimdal-devel}
74 %{?with_libproxy:Requires:      libproxy-devel}
75 %{?with_pakchois:Requires:      pakchois-devel}
76 Requires:       libxml2-devel
77 Requires:       openssl-devel >= 0.9.7c
78
79 %description devel
80 C header files for the neon library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe dla biblioteki neon.
84
85 %package static
86 Summary:        Static libraries for neon
87 Summary(pl.UTF-8):      Biblioteki statyczne neon
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static neon libraries.
93
94 %description static -l pl.UTF-8
95 Statyczne biblioteki neon.
96
97 %package apidocs
98 Summary:        neon API documentation
99 Summary(pl.UTF-8):      Dokumentacja API biblioteki neon
100 Group:          Documentation
101 %if "%{_rpmversion}" >= "5"
102 BuildArch:      noarch
103 %endif
104
105 %description apidocs
106 API and internal documentation for neon library.
107
108 %description apidocs -l pl.UTF-8
109 Dokumentacja API biblioteki neon.
110
111 %prep
112 %setup -q
113
114 %build
115 %{__libtoolize} --install
116 %{__aclocal} -I macros
117 %{__autoconf}
118 %configure \
119         --with-ssl=openssl \
120         --enable-threadsafe-ssl=posix \
121         --enable-shared \
122         --with-ca-bundle=/etc/certs/ca-certificates.crt \
123         --with%{!?with_pakchois:out}-pakchois \
124         %{!?with_static_libs:--disable-static} \
125         %{!?with_kerberos5:--without-gssapi} \
126         %{!?with_libproxy:--without-libproxy} \
127         --with-libxml2
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
139
140 %find_lang %{name}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
151 %attr(755,root,root) %{_libdir}/libneon.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libneon.so.27
153
154 %files devel
155 %defattr(644,root,root,755)
156 %doc doc/*.txt
157 %attr(755,root,root) %{_bindir}/neon-config
158 %attr(755,root,root) %{_libdir}/libneon.so
159 %{_includedir}/neon
160 %{_pkgconfigdir}/neon.pc
161 %{_mandir}/man1/neon-config.1*
162 %{_mandir}/man3/ne_*.3*
163 %{_mandir}/man3/neon.3*
164
165 %if %{with static_libs}
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/libneon.a
169 %endif
170
171 %if %{with apidocs}
172 %files apidocs
173 %defattr(644,root,root,755)
174 %doc doc/html/*
175 %endif
This page took 0.054519 seconds and 2 git commands to generate.