]> git.pld-linux.org Git - packages/mymediasystem.git/blob - mymediasystem.spec
- updated gettext BR
[packages/mymediasystem.git] / mymediasystem.spec
1 #
2 # Conditional build:
3 %bcond_without  lirc            # without lirc support
4 #
5 %define sname   mms
6 %define snap    2252
7 Summary:        My Media System
8 Name:           mymediasystem
9 Version:        1.1.0
10 Release:        0.%{snap}.1
11 License:        GPL v2+
12 Group:          Applications/Multimedia
13 #Source0:       http://mms.sunsite.dk/%{sname}-%{version}.tgz
14 Source0:        http://mms.mymediasystem.net/mms110/nightly-snapshot/%{sname}-%{version}-%{snap}.tgz
15 # Source0-md5:  f985b9d481b10684d708d2c02e0d4643
16 Patch0:         %{name}-build.patch
17 Patch1:         %{name}-epg.patch
18 Patch2:         %{name}-imdb.patch
19 Patch3:         %{name}-moviedb.patch
20 Patch4:         %{name}-dirlisting.patch
21 Patch5:         %{name}-po_pl.patch
22 URL:            http://mymediasystem.org/
23 BuildRequires:  OpenGL-GLU-devel
24 BuildRequires:  SDL-devel
25 BuildRequires:  binutils >= 2.19.51.0.4
26 BuildRequires:  boost-devel
27 BuildRequires:  commoncpp2-devel
28 BuildRequires:  ffmpeg-devel
29 BuildRequires:  gettext-tools
30 BuildRequires:  imlib2-devel
31 BuildRequires:  libtool
32 %{?with_lirc:BuildRequires:     lirc-devel}
33 BuildRequires:  ncurses-devel
34 BuildRequires:  pcre-cxx-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  python-devel
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  sqlite3-devel
39 BuildRequires:  taglib-devel
40 BuildRequires:  xine-lib-devel
41 BuildRequires:  xorg-lib-libX11-devel
42 BuildRequires:  xorg-lib-libXfixes-devel
43 Requires:       fonts-TTF-DejaVu
44 Requires:       iconv
45 Requires:       wget
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 My Media System is an application that manages, displays and plays
50 media content such as videos, music, pictures, and more. MMS runs
51 perfectly on anything from a Set-Top-Box connected to your TV-Set, to
52 your specially tailored multimedia PC and HD display.
53
54 %prep
55 %setup -q -n %{sname}-%{version}-%{snap}
56 %patch0 -p1
57 %patch1 -p1
58 %patch2 -p1
59 %patch3 -p1
60 %patch4 -p1
61 %patch5 -p1
62
63 %build
64 ./configure \
65         --prefix="%{_prefix}" \
66         --libdir="%{_libdir}" \
67         --enable-clock \
68         --enable-evdev \
69         %{?with_lirc:--enable-lirc} \
70         --enable-notify-area \
71         --enable-opengl \
72         --enable-python \
73         --enable-res-switch \
74         --enable-weather \
75         --disable-fancy-game \
76         --disable-inotify \
77         --disable-optimization
78
79 # lib64 fix
80 echo "PYTHON_INSTALL = %{py_sitedir}" >> config.mak
81
82 %{__make} \
83         CC="%{__cc} %{rpmcflags}" \
84         CXX="%{__cxx} %{rpmcxxflags}"
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         CC="%{__cc} %{rpmcflags}" \
91         CXX="%{__cxx} %{rpmcxxflags}" \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 cd $RPM_BUILD_ROOT%{_datadir}/mms/fonts
95 rm -f DejaVuSansCondensed*
96 ln -sf %{_datadir}/fonts/TTF/DejaVuSansCondensed.ttf .
97 ln -sf %{_datadir}/fonts/TTF/DejaVuSansCondensed-Bold.ttf .
98 cd -
99
100 %find_lang %{name} --all-name
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files -f %{name}.lang
106 %defattr(644,root,root,755)
107 %doc doc/plugins/python/*.pdf
108 %attr(755,root,root) %{_bindir}/mms*
109 %dir %{_sysconfdir}/mms
110 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms/*Config
111 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms/ClockAlarms
112 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms/genericplayer.ops
113 %dir %{_sysconfdir}/mms/input
114 %dir %{_sysconfdir}/mms/input/evdev
115 %dir %{_sysconfdir}/mms/input/keyboard
116 %dir %{_sysconfdir}/mms/input/lirc
117 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms/input/evdev/*
118 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms/input/keyboard/*
119 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms/input/lirc/*
120 %{_sysconfdir}/mms/scripts
121 %dir %{_libdir}/mms
122 %dir %{_libdir}/mms/plugins
123 %attr(755,root,root) %{_libdir}/mms/alarm.sh
124 %attr(755,root,root) %{_libdir}/mms/plugins/*
125 %attr(755,root,root) %{py_sitedir}/mmsv2*.so
126 %{_datadir}/mms
127 %attr(777,root,root) /var/cache/mms
128 %{_mandir}/man1/mms*.1*
129 %lang(de) %{_mandir}/de/man1/mms*.1*
This page took 0.080002 seconds and 3 git commands to generate.