]> git.pld-linux.org Git - packages/musl.git/blob - musl.spec
Up to 1.2.3.
[packages/musl.git] / musl.spec
1 Summary:        musl libc - new standard library to power a new generation of Linux-based devices
2 Summary(pl.UTF-8):      musl libc - nowa biblioteka standardowa dla urządzeń linuksowych nowej generacji
3 Name:           musl
4 Version:        1.2.3
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://www.musl-libc.org/releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  a507ae4f7f20bcfe566d8eb65c1af73e
10 Patch0:         %{name}-gcc.patch
11 URL:            http://www.musl-libc.org/
12 BuildRequires:  gcc >= 5:3.2
13 BuildRequires:  zlib-devel
14 Requires:       uname(release) >= 2.6.0
15 ExclusiveArch:  %{ix86} %{x8664} x32 arm mips microblaze ppc
16 ExcludeArch:    i386
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _libdir         %{_prefix}/%{_lib}/musl
20 %define         _includedir     %{_prefix}/include/musl
21 %define         _fortify_cflags %{nil}
22 %define         _ssp_cflags     %{nil}
23
24 # i386, x86_64, x32, arm, mips, microblaze, ppc
25 %ifarch x32
26 %define         musl_arch       x32
27 %else
28 %define         musl_arch       %{_target_base_arch}
29 %endif
30
31 %description
32 musl libc is a new standard library to power a new generation of
33 Linux-based devices. It is lightweight, fast, simple, free, and
34 strives to be correct in the sense of standards-conformance and
35 safety.
36
37 musl is an alternative to glibc, uClibc, dietlibc, and klibc.
38
39 %description -l pl.UTF-8
40 musl libc to nowa biblioteka standardowa, przeznaczona do zasilania
41 urządzeń linuksowych nowej generacji. Jest lekka, szybka, prosta,
42 wolnodostępna i stara się być poprawna w sensie zgodności ze
43 standardami i bezpieczeństwa.
44
45 musl jest alternatywą dla bibliotek glibc, uClibc, dietlibc i klibc.
46
47 %package devel
48 Summary:        Development files for musl libc
49 Summary(pl.UTF-8):      Pliki programistyczne biblioteki musl libc
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Development files for musl libc.
55
56 %description devel -l pl.UTF-8
57 Pliki programistyczne biblioteki musl libc.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 %build
64 %configure \
65         --syslibdir=/%{_lib}
66
67 # WRAPCC_GCC that will be used as $REALGCC fallback in musl-gcc script
68 # regardless what is value when this package is built (ccache, etc)
69 %{__make} \
70         WRAPCC_GCC="%{_target_platform}-gcc"
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 # move actual library to /lib to handle /usr mounts
78 mv $RPM_BUILD_ROOT{%{_libdir}/libc.so,/%{_lib}/ld-musl-%{musl_arch}.so.1}
79 ln -s /%{_lib}/ld-musl-%{musl_arch}.so.1 $RPM_BUILD_ROOT%{_libdir}/libc.so
80
81 install -d $RPM_BUILD_ROOT%{_sysconfdir}
82 echo '%{_libdir}' > $RPM_BUILD_ROOT%{_sysconfdir}/ld-musl-%{musl_arch}.path
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc COPYRIGHT INSTALL README WHATSNEW
90 %attr(755,root,root) /%{_lib}/ld-musl-%{musl_arch}.so.1
91 %dir %{_libdir}
92 %attr(755,root,root) %{_libdir}/libc.so
93 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld-musl-%{musl_arch}.path
94
95 %files devel
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_bindir}/musl-gcc
98 %{_libdir}/libc.a
99 # empty stubs
100 %{_libdir}/libcrypt.a
101 %{_libdir}/libdl.a
102 %{_libdir}/libm.a
103 %{_libdir}/libpthread.a
104 %{_libdir}/libresolv.a
105 %{_libdir}/librt.a
106 %{_libdir}/libutil.a
107 %{_libdir}/libxnet.a
108 # crts
109 %{_libdir}/Scrt1.o
110 %{_libdir}/crt*.o
111 %{_libdir}/rcrt1.o
112 %{_libdir}/musl-gcc.specs
113 %{_includedir}
This page took 0.110699 seconds and 4 git commands to generate.