]> git.pld-linux.org Git - packages/musescore.git/blob - musescore.spec
pass proper CXXFLAGS
[packages/musescore.git] / musescore.spec
1 #
2 Summary:        MuseScore - music notation software
3 Summary(pl.UTF-8):      MuseScore - oprogramowanie do notacji muzycznej
4 Name:           musescore
5 Version:        2.0.3
6 Release:        0.1
7 License:        GPL v2
8 Group:          Applications
9 Source0:        https://github.com/musescore/MuseScore/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  9f1a870302b27c25e8be729648af1c64
11 URL:            https://musescore.org/
12 BuildRequires:  Qt5Concurrent-devel
13 BuildRequires:  Qt5Core-devel
14 BuildRequires:  Qt5Designer-devel
15 BuildRequires:  Qt5Gui-devel
16 BuildRequires:  Qt5Help-devel
17 BuildRequires:  Qt5Network-devel
18 BuildRequires:  Qt5OpenGL-devel
19 BuildRequires:  Qt5PrintSupport-devel
20 BuildRequires:  Qt5Qml-devel
21 BuildRequires:  Qt5Quick-devel
22 BuildRequires:  Qt5Sql-devel
23 BuildRequires:  Qt5Svg-devel
24 BuildRequires:  Qt5Test-devel
25 BuildRequires:  Qt5UiTools-devel
26 BuildRequires:  Qt5WebKit-devel
27 BuildRequires:  Qt5Widgets-devel
28 BuildRequires:  Qt5Xml-devel
29 BuildRequires:  Qt5XmlPatterns-devel
30 BuildRequires:  alsa-lib-devel
31 BuildRequires:  cmake
32 BuildRequires:  doxygen
33 BuildRequires:  jack-audio-connection-kit-devel >= 0.98
34 BuildRequires:  lame-libs-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  portaudio-devel
37 BuildRequires:  pulseaudio-devel
38 BuildRequires:  qt5-assistant
39 BuildRequires:  qt5-build
40 BuildRequires:  qt5-linguist
41 BuildRequires:  texlive-latex
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 MuseScore is an open source and free music notation software.
46
47 Features:
48 - WYSIWYG design, notes are entered on a "virtual notepaper"
49 - TrueType font(s) for printing & display allows for high quality
50   scaling to all sizes
51 - easy & fast note entry
52 - many editing functions
53 - MusicXML import/export
54 - Midi (SMF) import/export
55 - MuseData import
56 - Midi input for note entry
57 - integrated sequencer and software synthesizer to play the score
58 - print or create pdf files
59
60 %prep
61 %setup -q -n MuseScore-%{version}
62
63 %build
64
65 # note: 'build' directory is already there, for something else
66 install -d build.release
67 cd build.release
68
69 # cmake flags taken from the main Makefile
70 CFLAGS="%{rpmcflags} -DNDEBUG -DQT_NO_DEBUG -fPIC" \
71 CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG -fPIC" \
72 %cmake  \
73         -DMSCORE_INSTALL_SUFFIX="" \
74         -DMUSESCORE_LABEL="" \
75         -DBUILD_LAME="TRUE" \
76         -DCMAKE_SKIP_RPATH="FALSE" \
77         ..
78
79 %{__make} lrelease
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 cd build.release
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 rm $RPM_BUILD_ROOT/%{_mandir}/man1/musescore.1.gz
90 echo ".so mscore.1" > $RPM_BUILD_ROOT/%{_mandir}/man1/musescore.1
91
92 %post
93 %update_desktop_database
94 %update_icon_cache hicolor
95 %update_mime_database
96
97 %postun
98 %update_desktop_database
99 %update_icon_cache hicolor
100 %update_mime_database
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %doc README.md Compatibility
108 %attr(755,root,root) %{_bindir}/mscore
109 %attr(755,root,root) %{_bindir}/musescore
110 %{_datadir}/mscore-2.0
111 %{_desktopdir}/mscore.desktop
112 %{_iconsdir}/*/*/apps/*
113 %{_iconsdir}/*/*/mimetypes/*
114 %{_mandir}/man1/mscore.1*
115 %{_mandir}/man1/musescore.1*
116 %{_datadir}/mime/packages/musescore.xml
This page took 0.075551 seconds and 3 git commands to generate.