]> git.pld-linux.org Git - packages/mpv.git/blob - mpv.spec
89b01ad6e27396a86dbe29b10d29279a5ba9c663
[packages/mpv.git] / mpv.spec
1 Summary:        Movie player based on MPlayer and mplayer2
2 Name:           mpv
3 Version:        0.15.0
4 Release:        1
5 License:        GPL v2+
6 Group:          Applications/Multimedia
7 Source0:        http://github.com/mpv-player/mpv/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
8 # Source0-md5:  9042bd3fbff2bc8ba0b7fadaa4a22101
9 Source1:        %{name}.conf
10 Patch0:         %{name}-lua.patch
11 URL:            http://mpv.io/
12 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0.0
13 BuildRequires:  OpenAL-devel >= 1.13
14 BuildRequires:  OpenGL-devel
15 BuildRequires:  SDL-devel
16 BuildRequires:  alsa-lib-devel
17 BuildRequires:  docutils
18 BuildRequires:  enca-devel
19 BuildRequires:  ffmpeg-devel >= 2.4.0
20 BuildRequires:  jack-audio-connection-kit-devel
21 BuildRequires:  lcms2-devel >= 2.6
22 BuildRequires:  libass-devel >= 0.12.1
23 %ifarch i386 i486
24 BuildRequires:  libatomic-devel
25 %endif
26 BuildRequires:  libbluray-devel >= 0.3.0
27 BuildRequires:  libcaca-devel >= 0.99
28 BuildRequires:  libcdio-paranoia-devel
29 BuildRequires:  libdvdnav-devel >= 4.2.0
30 BuildRequires:  libdvdread-devel >= 4.1.0
31 BuildRequires:  libguess-devel
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libsmbclient-devel
34 BuildRequires:  libv4l-devel
35 BuildRequires:  libva-devel >= 1.2.0
36 BuildRequires:  libva-glx-devel >= 1.2.0
37 BuildRequires:  libvdpau-devel >= 0.2
38 BuildRequires:  lua51-devel
39 BuildRequires:  pkgconfig
40 BuildRequires:  pulseaudio-devel >= 0.9
41 BuildRequires:  rpmbuild(macros) >= 1.336
42 BuildRequires:  waf >= 1.8.12
43 BuildRequires:  wayland-devel >= 1.3.0
44 BuildRequires:  xorg-lib-libX11-devel
45 BuildRequires:  xorg-lib-libXScrnSaver-devel
46 BuildRequires:  xorg-lib-libXdamage-devel
47 BuildRequires:  xorg-lib-libXext-devel
48 BuildRequires:  xorg-lib-libXinerama-devel
49 BuildRequires:  xorg-lib-libXv-devel
50 BuildRequires:  xorg-lib-libXxf86vm-devel
51 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
52 BuildRequires:  xorg-proto-xproto-devel
53 Requires:       Mesa-libwayland-egl >= 9.0.0
54 Requires:       OpenAL >= 1.13
55 Requires:       OpenGL
56 Requires:       ffmpeg-libs >= 2.4.0
57 Requires:       lcms2 >= 2.6
58 Requires:       libass >= 0.12.1
59 Requires:       libbluray >= 0.3.0
60 Requires:       libcaca >= 0.99
61 Requires:       libdvdnav >= 4.2.0
62 Requires:       libdvdread >= 4.1.0
63 Requires:       libva >= 1.2.0
64 Requires:       libva-glx >= 1.2.0
65 Requires:       libvdpau >= 0.2
66 Requires:       pulseaudio-libs >= 1.0
67 Requires:       wayland >= 1.6.0
68 Requires:       xorg-lib-libxkbcommon >= 0.3.0
69 Suggests:       youtube-dl >= 2:20150223
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
73
74 %define         zshdir %{_datadir}/zsh/site-functions
75
76 %description
77 Movie player based on MPlayer and mplayer2.
78
79 %package client-libs
80 Summary:        Client library for controlling mpv
81 Group:          Development/Libraries
82
83 %description client-libs
84 Client library for controlling mpv.
85
86 %package client-devel
87 Summary:        Development files for mpv client library
88 Group:          Development/Libraries
89 Requires:       %{name}-client-libs = %{version}-%{release}
90
91 %description client-devel
92 Development files for mpv client library.
93
94 %package -n zsh-completion-mpv
95 Summary:        zsh-completion for mpv
96 Group:          Applications/Shells
97 Requires:       %{name} = %{version}-%{release}
98
99 %description -n zsh-completion-mpv
100 zsh-completion for mpv.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105
106 %build
107 %waf configure \
108                 --prefix=%{_prefix} \
109                 --bindir=%{_bindir} \
110                 --confdir=%{_sysconfdir}/mpv \
111                 --libdir=%{_libdir} \
112                 --datadir=%{_datadir} \
113                 --mandir=%{_mandir} \
114                 --disable-debug-build \
115                 --enable-alsa \
116                 --enable-audio-input \
117                 --enable-caca \
118                 --enable-cdda \
119                 --enable-dvb \
120                 --enable-dvbin \
121                 --enable-dvdnav \
122                 --enable-dvdread \
123                 --enable-enca \
124                 --enable-encoding \
125                 --enable-gl-wayland \
126                 --enable-gl-x11 \
127                 --enable-iconv \
128                 --enable-jack \
129                 --enable-jpeg \
130                 --enable-lcms2 \
131                 --enable-libass \
132                 --enable-libass-osd \
133                 --enable-libavdevice \
134                 --enable-libavfilter \
135                 --enable-libbluray \
136                 --enable-libguess \
137                 --enable-libmpv-shared \
138                 --enable-libsmbclient \
139                 --enable-libswresample \
140                 --enable-libv4l2 \
141                 --enable-openal \
142                 --enable-oss-audio \
143                 --enable-pulse \
144                 --enable-sdl1 \
145                 --enable-shm \
146                 --enable-tv \
147                 --enable-tv-v4l2 \
148                 --enable-vaapi \
149                 --enable-vaapi-glx \
150                 --enable-vaapi-hwaccel \
151                 --enable-vdpau \
152                 --enable-vdpau-gl-x11 \
153                 --enable-vdpau-hwaccel \
154                 --enable-wayland \
155                 --enable-x11 \
156                 --enable-xext \
157                 --enable-xinerama \
158                 --enable-xss \
159                 --enable-xv \
160                 --enable-zsh-comp \
161                 --lua=51pld \
162                 --zshdir=%{zshdir}
163
164 %waf build -v
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168
169 %waf install --destdir=$RPM_BUILD_ROOT
170
171 install -d $RPM_BUILD_ROOT%{_sysconfdir}/mpv
172 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mpv
173
174 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   client-libs -p /sbin/ldconfig
180 %postun client-libs -p /sbin/ldconfig
181
182 %files
183 %defattr(644,root,root,755)
184 %doc README.md RELEASE_NOTES etc/input.conf etc/mplayer-input.conf etc/mpv.conf etc/restore-old-bindings.conf
185 %dir %{_sysconfdir}/mpv
186 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/encoding-profiles.conf
187 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/mpv.conf
188 %attr(755,root,root) %{_bindir}/%{name}
189 %{_desktopdir}/mpv.desktop
190 %{_iconsdir}/hicolor/*/apps/mpv.png
191 %{_iconsdir}/hicolor/scalable/apps/mpv.svg
192 %{_mandir}/man1/mpv.1*
193
194 %files client-libs
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libmpv.so.*.*.*
197 %attr(755,root,root) %ghost %{_libdir}/libmpv.so.1
198
199 %files client-devel
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/libmpv.so
202 %{_includedir}/mpv
203 %{_pkgconfigdir}/mpv.pc
204
205 %files -n zsh-completion-mpv
206 %defattr(644,root,root,755)
207 %{zshdir}/_mpv
This page took 0.040497 seconds and 2 git commands to generate.