]> git.pld-linux.org Git - packages/mozjs17.git/blob - mozjs17.spec
fdf558fbde3e75d3d0a63114a789497f1127db5f
[packages/mozjs17.git] / mozjs17.spec
1 # parallel-installable with js185, js or future mozjs < 17 or >= 18
2 Summary:        SpiderMonkey 17 - JavaScript 1.8.6 implementation
3 Summary(pl.UTF-8):      SpiderMonkey 17 - implementacja języka JavaScript 1.8.6
4 Name:           mozjs17
5 Version:        17.0.0
6 Release:        2
7 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
8 Group:          Libraries
9 Source0:        http://ftp.mozilla.org/pub/mozilla.org/js/mozjs%{version}.tar.gz
10 # Source0-md5:  20b6f8f1140ef6e47daa3b16965c9202
11 URL:            http://www.mozilla.org/js/
12 BuildRequires:  libffi-devel >= 5:3.0.9
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  nspr-devel >= 4.9.2
15 BuildRequires:  perl-base >= 1:5.6
16 BuildRequires:  pkgconfig
17 BuildRequires:  pkgconfig(libffi) >= 3.0.9
18 BuildRequires:  python >= 1:2.5
19 BuildRequires:  readline-devel
20 BuildRequires:  rpm-perlprov
21 BuildRequires:  rpmbuild(macros) >= 1.294
22 BuildRequires:  zlib-devel >= 1.2.3
23 Requires:       nspr >= 4.9.2
24 Requires:       zlib >= 1.2.3
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 JavaScript Reference Implementation (codename SpiderMonkey). The
29 package contains JavaScript runtime (compiler, interpreter,
30 decompiler, garbage collector, atom manager, standard classes) and
31 small "shell" program that can be used interactively and with .js
32 files to run scripts.
33
34 %description -l pl.UTF-8
35 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
36 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
37 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
38 która może być używana interaktywnie lub z plikami .js do uruchamiania
39 skryptów.
40
41 %package devel
42 Summary:        Header files for JavaScript reference library
43 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       libstdc++-devel
47 Requires:       nspr-devel >= 4.9.2
48
49 %description devel
50 Header files for JavaScript reference library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe do biblioteki JavaScript.
54
55 %package static
56 Summary:        Static JavaScript reference library
57 Summary(pl.UTF-8):      Statyczna biblioteka JavaScript
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static version of JavaScript reference library.
63
64 %description static -l pl.UTF-8
65 Statyczna wersja biblioteki JavaScript.
66
67 %prep
68 %setup -q -n mozjs%{version}
69
70 %build
71 cd js/src
72 %configure2_13 \
73         --enable-readline \
74         --enable-system-ffi \
75         --enable-threadsafe \
76         --with-system-nspr
77
78 %{__make} \
79         HOST_OPTIMIZE_FLAGS= \
80         MODULE_OPTIMIZE_FLAGS= \
81         MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
82         MOZ_PGO_OPTIMIZE_FLAGS= \
83         MOZILLA_VERSION=%{version}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} -C js/src install \
89         DESTDIR=$RPM_BUILD_ROOT \
90         MOZILLA_VERSION=%{version}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc js/src/README.html
101 %attr(755,root,root) %{_bindir}/js17
102 %attr(755,root,root) %{_libdir}/libmozjs-17.0.so
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_bindir}/js17-config
107 %{_includedir}/js-17.0
108 %{_pkgconfigdir}/mozjs-17.0.pc
109
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libmozjs-17.0.a
This page took 0.062487 seconds and 2 git commands to generate.