]> git.pld-linux.org Git - packages/mozjs17.git/blob - mozjs17.spec
- fix syntax in version extraction script
[packages/mozjs17.git] / mozjs17.spec
1 # parallel-installable with js185, js or future mozjs < 17 or >= 18
2 Summary:        SpiderMonkey 17 - JavaScript 1.8.6 implementation
3 Summary(pl.UTF-8):      SpiderMonkey 17 - implementacja języka JavaScript 1.8.6
4 Name:           mozjs17
5 Version:        17.0.0
6 Release:        3
7 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
8 Group:          Libraries
9 Source0:        http://ftp.mozilla.org/pub/mozilla.org/js/mozjs%{version}.tar.gz
10 # Source0-md5:  20b6f8f1140ef6e47daa3b16965c9202
11 Patch0:         perl.patch
12 URL:            http://www.mozilla.org/js/
13 BuildRequires:  libffi-devel >= 5:3.0.9
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  nspr-devel >= 4.9.2
16 BuildRequires:  perl-base >= 1:5.6
17 BuildRequires:  pkgconfig
18 BuildRequires:  pkgconfig(libffi) >= 3.0.9
19 BuildRequires:  python >= 1:2.5
20 BuildRequires:  readline-devel
21 BuildRequires:  rpm-perlprov
22 BuildRequires:  rpmbuild(macros) >= 1.294
23 BuildRequires:  zlib-devel >= 1.2.3
24 Requires:       nspr >= 4.9.2
25 Requires:       zlib >= 1.2.3
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 JavaScript Reference Implementation (codename SpiderMonkey). The
30 package contains JavaScript runtime (compiler, interpreter,
31 decompiler, garbage collector, atom manager, standard classes) and
32 small "shell" program that can be used interactively and with .js
33 files to run scripts.
34
35 %description -l pl.UTF-8
36 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
37 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
38 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
39 która może być używana interaktywnie lub z plikami .js do uruchamiania
40 skryptów.
41
42 %package devel
43 Summary:        Header files for JavaScript reference library
44 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       libstdc++-devel
48 Requires:       nspr-devel >= 4.9.2
49
50 %description devel
51 Header files for JavaScript reference library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe do biblioteki JavaScript.
55
56 %package static
57 Summary:        Static JavaScript reference library
58 Summary(pl.UTF-8):      Statyczna biblioteka JavaScript
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static version of JavaScript reference library.
64
65 %description static -l pl.UTF-8
66 Statyczna wersja biblioteki JavaScript.
67
68 %prep
69 %setup -q -n mozjs%{version}
70 %patch0 -p1
71
72 %build
73 cd js/src
74 %configure2_13 \
75         --enable-readline \
76         --enable-system-ffi \
77         --enable-threadsafe \
78         --with-system-nspr
79
80 %{__make} \
81         HOST_OPTIMIZE_FLAGS= \
82         MODULE_OPTIMIZE_FLAGS= \
83         MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
84         MOZ_PGO_OPTIMIZE_FLAGS= \
85         MOZILLA_VERSION=%{version}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} -C js/src install \
91         DESTDIR=$RPM_BUILD_ROOT \
92         MOZILLA_VERSION=%{version}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc js/src/README.html
103 %attr(755,root,root) %{_bindir}/js17
104 %attr(755,root,root) %{_libdir}/libmozjs-17.0.so
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_bindir}/js17-config
109 %{_includedir}/js-17.0
110 %{_pkgconfigdir}/mozjs-17.0.pc
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libmozjs-17.0.a
This page took 4.108423 seconds and 3 git commands to generate.