]> git.pld-linux.org Git - packages/mnogosearch.git/blob - mnogosearch.spec
- typos / formatting / etc.
[packages/mnogosearch.git] / mnogosearch.spec
1 #
2 # Conditional build:
3 %bcond_with     chasen          # use ChaSen Japanese morphological analisys system
4                                 # (not tested, maybe on by default?)
5 %bcond_without  expat           # without XML support (using expat library)
6 %bcond_without  ssl             # without SSL support (using OpenSSL)
7 # databases
8 %bcond_without  mysql           # support for MySQL
9 %bcond_without  pgsql           # support for PostgreSQL
10 # databases through ODBC
11 %bcond_with     iodbc           # with ODBC support through iODBC
12 %bcond_with     unixodbc        # with ODBC support through unixODBC
13 #
14 Summary:        Another one web indexing and searching system for a small domain or intranet
15 Summary(pl):    Kolejny system indeksowania i przeszukiwania WWW dla ma³ych domen i intranetu
16 Name:           mnogosearch
17 Version:        3.2.19
18 Release:        1
19 License:        GPL v2+
20 Group:          Networking/Utilities
21 #Source0Download: http://www.mnogosearch.ru/download.html
22 Source0:        http://www.mnogosearch.ru/Download/%{name}-%{version}.tar.gz
23 # Source0-md5:  5a6b9bc48a689d333ef2ba897cb301d5
24 Source1:        %{name}-dbgen
25 Patch0:         %{name}-acfixes.patch
26 URL:            http://www.mnogosearch.ru/
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 %{?with_chasen:BuildRequires:   chasen-devel}
30 %{?with_expat:BuildRequires:    expat-devel}
31 %{?with_iodbc:BuildRequires:    libiodbc-devel}
32 BuildRequires:  libtool
33 %{?with_mysql:BuildRequires:    mysql-devel}
34 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
35 %{?with_pgsql:BuildRequires:    postgresql-devel}
36 %{?with_unixodbc:BuildRequires: unixODBC-devel}
37 BuildRequires:  zlib-devel
38 PreReq:         webserver
39 #%{?with_pgsql:PreReq:          postgresql-clients}
40 Requires:       %{name}-lib = %{version}-%{release}
41 Obsoletes:      aspseek
42 Obsoletes:      mnogosearch-stored
43 Obsoletes:      udmsearch
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _sysconfdir     /etc/%{name}
47 %define         _localstatedir  /var/lib/mnogosearch
48 %define         _ourdatadir     %{_datadir}/%{name}
49 %define         htmldir         /home/services/httpd/html
50 %define         cgidir          /home/services/httpd/cgi-bin
51
52 %description
53 The mnogosearch system is a complete world wide web indexing and
54 searching system for a small domain or intranet. This system is not
55 meant to replace the need for powerful internet-wide search systems
56 like Lycos, Infoseek, Webcrawler and AltaVista. Instead it is meant to
57 cover the search needs for a single company, campus, or even a
58 particular sub section of a web site. Features:
59  - mp3 tag info
60  - news searching(?)
61  - http: (and ftp: - via proxy) URL schemaa
62  - charset guesser
63  - externel parsers
64  - support for ssl (https://)
65  - limiting queries to one hostname by sth like this: <INPUT
66    TYPE=HIDDEN NAME=ul VALUE=http://www.something.com/>
67  - it's posilble to run indexers on several diffrent (theoreticaly 128)
68    hosts, and gather information on one of them, reindexing proceses make
69    no harm to avalibility of search engine. See cachemode.txt
70
71 As opposed to some WAIS-based or web-server based search engines,
72 mnogsearch can span several web servers at a site. The type of these
73 different web servers doesn't matter as long as they understand the
74 HTTP 1.0 protocol. Mnogosearch supports also virtual domains.
75
76 %description -l pl
77 Mnogosearch jest kompletnym systemem indeksuj±cym i przeszukuj±cym WWW
78 dla ma³ych domen oraz intranetu. System nie zosta³ opracowany jako
79 wielki system typu Lycos, Infoseek WebCrawler i AltaVista. Natomiast
80 nadaje siê do zastosowania w pojedynczej firmie, kampusie lub
81 jakiejkolwiek stronie WWW. Zalety:
82  - przeszukiwanie tagów mp3,
83  - niusów (Server news://localhost/pl/),
84  - htdb czyli baz danych udostêpnianych przez WWW/CGI. (HTDBList SELECT
85    \ concat("http://search.mnogo.ru/board/message.php?id=",id) \ FROM
86    udm.messages LIMIT 2))
87  - zawarto¶ci serwerów ftp (rada za 2gr: "Index no" dla serwera ftp
88    spowoduje nie indeksowanie *zawarto¶ci* plików na nim siê znajduj±cych)
89  - wyszukiwanie w zwyk³ych URL-ach http://
90  - wsparcie dla SSL (https://)
91  - wyszukiwanie w mirrorach (równie¿ lokalnych) odleg³ych sieci
92  - zgadywanie zestawu znaków
93  - zewnêtrzne przetwarzacze dokumentów na potrzeby indeksowania
94  - ograniczanie zapytañ do jednej nazwy hosta: <INPUT TYPE=HIDDEN
95    NAME=ul VALUE=http://www.something.com/>
96  - kategoryzacja witryny (doc/categories.txt)
97  - mo¿liwe jest uruchomienie kilku procesów indeksuj±cych na kilku
98    (teoretycznie 128) hostach i trzymanie bazy na jednym z nich,
99    reindeksacja nie powoduje wtedy niedostêpno¶ci wyszukiwarki.
100    Przeczytaj cachemode.txt
101
102 W odró¿nieniu od innych systemów bazuj±cych na WAIS-ie lub serwerach
103 WWW, mnogosearch mo¿e ³±czyæ kilka serwerów WWW w jednym miejscu. Typ
104 serwera nie ma znaczenia, dopóki pracuje on zgodnie z protoko³em HTTP
105 1.0. Pakiet wspó³pracuje równie¿ z domenami wirtualnymi.
106
107 %package lib
108 Summary:        mnogosearch library
109 Summary(pl):    Biblioteka mnogosearch
110 Group:          Libraries
111
112 %description lib
113 This package contains mnogosearch library files.
114
115 %description lib -l pl
116 Ten pakiet zawiera pliki biblioteki mnogosearch.
117
118 %package devel
119 Summary:        Include files for mnogosearch
120 Summary(pl):    Pliki nag³ówkowe mnogosearch
121 Group:          Development/Libraries
122 Requires:       %{name}-lib = %{version}-%{release}
123 %{?with_expat:Requires: expat-devel}
124 %{?with_iodbc:Requires: libiodbc-devel}
125 %{?with_mysql:Requires: mysql-devel}
126 %{?with_ssl:Requires:   openssl-devel}
127 %{?with_pgsql:Requires: postgresql-devel}
128 %{?with_unixodbc:Requires:      unixODBC-devel}
129 Requires:       zlib-devel
130
131 %description devel
132 This package contains mnogosearch development files.
133
134 %description devel -l pl
135 Pliki dla programistów u¿ywaj±cych mnogosearch.
136
137 %package static
138 Summary:        mnogosearch static libraries
139 Summary(pl):    Biblioteki statyczne mnogosearch
140 Group:          Development/Libraries
141 Requires:       %{name}-devel = %{version}-%{release}
142
143 %description static
144 This package contains static libraries of mnogosearch.
145
146 %description static -l pl
147 Ten pakiet zawiera statyczne biblioteki mnogosearch.
148
149 %prep
150 %setup -q
151 %patch -p1
152
153 %build
154 find . -type d -name CVS | xargs rm -rf
155 %{__libtoolize}
156 %{__aclocal}
157 %{__autoconf}
158 %{__automake}
159 %configure \
160         --datadir=%{_ourdatadir} \
161         DOCBOOKSTYLE="/usr/share/sgml/docbook/dsssl-stylesheets" \
162         --enable-syslog=LOG_LOCAL6 \
163         --enable-charset-guesser \
164         %{?with_chasen:--enable-chasen} \
165         --enable-fast-cat \
166         --enable-fast-tag \
167         --enable-fast-site \
168         --enable-linux-pthreads \
169         --enable-news-extension \
170         --enable-phrase \
171         --enable-shared \
172         --with-built-in \
173         --with-cgi-bin-dir=%{cgidir} \
174         --with-config-dir=%{_sysconfdir}/http/%{name} \
175         %{?with_expat:--with-expat} \
176         --with-image-dir=%{htmldir}/%{name} \
177         %{?with_iodbc:--with-iodbc} \
178         %{?with_mysql:--with-mysql} \
179         %{?with_ssl:--with-openssl} \
180         %{?with_pgsql:--with-pgsql} \
181         --with-search-dir=%{htmldir} \
182         %{?with_unixodbc:--with-unixODBC} \
183         --with-zlib
184
185 # --with-readline (for SQL monitor) ?
186 # --wiht-extra-charsets=big5,gb2312,gbk,japanese,euc-kr,gujarati,tscii ?
187
188 %{__make}
189
190 #  enable automatic Russian charset guesser :-]
191 # wy uze www.linux.ru procitacli sewodnja?
192
193 #  --with-solid[=DIR]      Include Solid support.  DIR is the Solid base
194 #  --with-openlink[=DIR]   Include OpenLink ODBC support.
195 #  --with-easysoft[=DIR]   Include EasySoft ODBC support.
196 #  --with-sapdb[=DIR]      Include SAPDB support.  DIR is the SAPDB base
197 #  --with-ibase[=DIR]      Include InterBase support.  DIR is the InterBase
198 #  --with-ctlib[=DIR]      Include Ct-Lib support.
199 #  --with-freetds[=DIR]    Include FreeTDS Ct-Lib support.
200 #  --with-oracle7[=DIR]    Include Oracle 7.3 support.  DIR is the Oracle
201 #  --with-oracle8[=DIR]    Include Oracle8 support.  DIR is the Oracle
202 #  --with-oracle8i[=DIR]   Include Oracle8i support.  DIR is the Oracle
203 #
204 # FIXME: add selection of storage method, spliting into %{name}-common & %{name}-$DB_NAME
205
206 %install
207 rm -rf $RPM_BUILD_ROOT
208 install -d $RPM_BUILD_ROOT{%{_localstatedir},%{htmldir},%{cgidir},%{_sysconfdir}} \
209         $RPM_BUILD_ROOT{/etc/cron.daily,%{_infodir}}
210
211 %{__make} install \
212         DESTDIR=$RPM_BUILD_ROOT \
213         doc_FILES='$(HTML_ALL)'
214
215 ln -sf %{_defaultdocdir}/%{name}-%{version}/html \
216         $RPM_BUILD_ROOT%{htmldir}/mnogodoc
217
218 mv -f $RPM_BUILD_ROOT%{_bindir}/*.cgi \
219         $RPM_BUILD_ROOT%{cgidir}
220
221 install -d $RPM_BUILD_ROOT/usr/src/example/mnogosearch
222 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.daily/mnogosearch-dbgen
223
224 mkdir html
225 cp -af doc/*.{html,css} html
226
227 cd $RPM_BUILD_ROOT%{_sysconfdir}
228 touch locals
229 for f in *-dist ; do
230         mv -f $f `basename $f -dist`
231 done
232
233 rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
234
235 %clean
236 rm -rf $RPM_BUILD_ROOT
237
238 %post
239 cat << EOF
240 Please see docs (%{_defaultdocdir}/%{name}-%{version}),
241 then read how to setup db connection, and put line like this
242 "pgsql://user:password@/dbname/" into %{_sysconfdir}, then setup database
243 using "indexer -Ecreate" command.
244 EOF
245
246 %post   lib -p /sbin/ldconfig
247 %postun lib -p /sbin/ldconfig
248
249 %files
250 %defattr(644,root,root,755)
251 %doc ChangeLog README TODO html doc/samples
252 %attr(755,root,root) %{_sbindir}/*
253 %attr(755,root,root) %{_bindir}/*
254 %attr(755,root,root) %{cgidir}/*
255 %{_datadir}/%{name}
256 %{htmldir}/mnogodoc
257 %dir %{_localstatedir}
258 %attr(775,root,http) %{_localstatedir}/cache
259 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.conf
260 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.freq
261 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.htm
262 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/locals
263 %dir %{_sysconfdir}/langmap
264 %dir %{_sysconfdir}/stopwords
265 %dir %{_sysconfdir}/synonym
266 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*/*
267 %config(noreplace) %attr(750,root,root) /etc/cron.daily/*
268 %{_mandir}/man?/*
269
270 %files lib
271 %defattr(644,root,root,755)
272 %attr(755,root,root) %{_libdir}/lib*-*.so
273
274 %files devel
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_bindir}/udm-config
277 %attr(755,root,root) %{_libdir}/libmnogosearch.so
278 %attr(755,root,root) %{_libdir}/libmnogocharset.so
279 %{_libdir}/lib*.la
280 %{_includedir}/*
281
282 %files static
283 %defattr(644,root,root,755)
284 %{_libdir}/lib*.a
This page took 0.185926 seconds and 4 git commands to generate.