]> git.pld-linux.org Git - packages/mnogosearch.git/blob - mnogosearch.spec
- ac/am stuff is pretty b0rken here :/
[packages/mnogosearch.git] / mnogosearch.spec
1 # TODO: webapps?
2 #
3 # Conditional build:
4 %bcond_with     chasen          # use ChaSen Japanese morphological analysis system (not tested, maybe on by default?)
5 %bcond_without  ssl             # without SSL support (using OpenSSL)
6 %bcond_with     mecab           # use mecab Japanese morphological system
7 # databases
8 %bcond_without  mysql           # support for MySQL
9 %bcond_without  pgsql           # support for PostgreSQL
10 %bcond_with     sqlite          # support for SQLite 2.x
11 %bcond_without  sqlite3         # support for SQLite 3.x
12 %bcond_with     ibase           # support for InterBase/Firebird
13 # databases through ODBC
14 %bcond_with     iodbc           # with ODBC support through iODBC
15 %bcond_with     unixodbc        # with ODBC support through unixODBC
16 # databases through FreeTDS
17 %bcond_without  freetds         # support for Sybase/MS SQL through FreeTDS
18
19 Summary:        Another one web indexing and searching system for a small domain or intranet
20 Summary(pl.UTF-8):      Kolejny system indeksowania i przeszukiwania WWW dla małych domen i intranetu
21 Name:           mnogosearch
22 Version:        3.3.14
23 Release:        3
24 License:        GPL v2+
25 Group:          Networking/Utilities
26 # Source0Download: http://www.mnogosearch.org/download.html
27 Source0:        http://www.mnogosearch.org/Download/%{name}-%{version}.tar.gz
28 # Source0-md5:  caf042f31134ae1304f0963a9f4964a9
29 Source1:        %{name}-dbgen
30 Patch0:         %{name}-acfixes.patch
31 Patch1:         %{name}-as_needed-fix.patch
32 URL:            http://www.mnogosearch.org/
33 %{?with_ibase:BuildRequires:    Firebird-devel}
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 %{?with_chasen:BuildRequires:   chasen-devel}
37 %{?with_freetds:BuildRequires:  freetds-devel}
38 %{?with_iodbc:BuildRequires:    libiodbc-devel}
39 BuildRequires:  libtool
40 %{?with_mecab:BuildRequires:    mecab-devel}
41 %{?with_mysql:BuildRequires:    mysql-devel}
42 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
43 %{?with_pgsql:BuildRequires:    postgresql-devel}
44 %{?with_sqlite:BuildRequires:   sqlite-devel}
45 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
46 %{?with_unixodbc:BuildRequires: unixODBC-devel}
47 BuildRequires:  zlib-devel
48 Requires:       %{name}-lib = %{version}-%{release}
49 Requires:       webserver
50 Obsoletes:      aspseek
51 Obsoletes:      mnogosearch-stored
52 Obsoletes:      udmsearch
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %define         _sysconfdir     /etc/%{name}
56 %define         _localstatedir  /var/lib/mnogosearch
57 %define         cgidir          /usr/lib/cgi-bin
58
59 %description
60 The mnogosearch system is a complete world wide web indexing and
61 searching system for a small domain or intranet. This system is not
62 meant to replace the need for powerful internet-wide search systems
63 like Lycos, Infoseek, Webcrawler and AltaVista. Instead it is meant to
64 cover the search needs for a single company, campus, or even a
65 particular sub section of a web site. Features:
66 - MP3 tag info
67 - news searching(?)
68 - http: (and ftp: - via proxy) URL schemaa
69 - charset guesser
70 - externel parsers
71 - support for ssl (https://)
72 - limiting queries to one hostname by sth like this: <INPUT
73   TYPE=HIDDEN NAME=ul VALUE=http://www.something.com/>
74 - it's possilble to run indexers on several different (theoreticaly
75   128) hosts, and gather information on one of them, reindexing proceses
76   make no harm to avalibility of search engine. See cachemode.txt
77
78 As opposed to some WAIS-based or web-server based search engines,
79 mnogsearch can span several web servers at a site. The type of these
80 different web servers doesn't matter as long as they understand the
81 HTTP 1.0 protocol. Mnogosearch supports also virtual domains.
82
83 %description -l pl.UTF-8
84 Mnogosearch jest kompletnym systemem indeksującym i przeszukującym WWW
85 dla małych domen oraz intranetu. System nie został opracowany jako
86 wielki system typu Lycos, Infoseek WebCrawler i AltaVista. Natomiast
87 nadaje się do zastosowania w pojedynczej firmie, kampusie lub
88 jakiejkolwiek stronie WWW. Zalety:
89 - przeszukiwanie znaczników MP3,
90 - niusów (Server news://localhost/pl/),
91 - htdb czyli baz danych udostępnianych przez WWW/CGI. (HTDBList SELECT
92   \ concat("http://search.mnogo.ru/board/message.php?id=",id) \ FROM
93   udm.messages LIMIT 2))
94 - zawartości serwerów FTP (rada za 2gr: "Index no" dla serwera FTP
95   spowoduje nie indeksowanie *zawartości* plików na nim się
96   znajdujących)
97 - wyszukiwanie w zwykłych URL-ach http://
98 - wsparcie dla SSL (https://)
99 - wyszukiwanie w mirrorach (również lokalnych) odległych sieci
100 - zgadywanie zestawu znaków
101 - zewnętrzne przetwarzacze dokumentów na potrzeby indeksowania
102 - ograniczanie zapytań do jednej nazwy hosta: <INPUT TYPE=HIDDEN
103   NAME=ul VALUE=http://www.something.com/>
104 - kategoryzacja witryny (doc/categories.txt)
105 - możliwe jest uruchomienie kilku procesów indeksujących na kilku
106   (teoretycznie 128) hostach i trzymanie bazy na jednym z nich,
107   reindeksacja nie powoduje wtedy niedostępności wyszukiwarki.
108   Przeczytaj cachemode.txt
109
110 W odróżnieniu od innych systemów bazujących na WAIS-ie lub serwerach
111 WWW, mnogosearch może łączyć kilka serwerów WWW w jednym miejscu. Typ
112 serwera nie ma znaczenia, dopóki pracuje on zgodnie z protokołem HTTP
113 1.0. Pakiet współpracuje również z domenami wirtualnymi.
114
115 %package lib
116 Summary:        mnogosearch library
117 Summary(pl.UTF-8):      Biblioteka mnogosearch
118 Group:          Libraries
119
120 %description lib
121 This package contains mnogosearch library files.
122
123 %description lib -l pl.UTF-8
124 Ten pakiet zawiera pliki biblioteki mnogosearch.
125
126 %package devel
127 Summary:        Include files for mnogosearch
128 Summary(pl.UTF-8):      Pliki nagłówkowe mnogosearch
129 Group:          Development/Libraries
130 Requires:       %{name}-lib = %{version}-%{release}
131 %{?with_ibase:Requires: Firebird-devel}
132 %{?with_chasen:Requires:        chasen-devel}
133 %{?with_freetds:Requires:       freetds-devel}
134 %{?with_iodbc:Requires: libiodbc-devel}
135 %{?with_mecab:Requires: mecab-devel}
136 %{?with_mysql:Requires: mysql-devel}
137 %{?with_ssl:Requires:   openssl-devel}
138 %{?with_pgsql:Requires: postgresql-devel}
139 %{?with_sqlite:Requires:        sqlite-devel}
140 %{?with_sqlite3:Requires:       sqlite3-devel}
141 %{?with_unixodbc:Requires:      unixODBC-devel}
142 Requires:       zlib-devel
143
144 %description devel
145 This package contains mnogosearch development files.
146
147 %description devel -l pl.UTF-8
148 Pliki dla programistów używających mnogosearch.
149
150 %package static
151 Summary:        mnogosearch static libraries
152 Summary(pl.UTF-8):      Biblioteki statyczne mnogosearch
153 Group:          Development/Libraries
154 Requires:       %{name}-devel = %{version}-%{release}
155
156 %description static
157 This package contains static libraries of mnogosearch.
158
159 %description static -l pl.UTF-8
160 Ten pakiet zawiera statyczne biblioteki mnogosearch.
161
162 %prep
163 %setup -q
164 %patch0 -p1
165 %patch1 -p1
166
167 %build
168 find . -type d -name CVS | xargs rm -rf
169 %{__libtoolize}
170 %{__aclocal} -I build/m4
171 %{__autoconf}
172 %{__automake}
173 %configure \
174         DOCBOOKSTYLE="/usr/share/sgml/docbook/dsssl-stylesheets" \
175         --datadir=%{_datadir}/%{name} \
176         --enable-syslog=LOG_LOCAL6 \
177         %{?with_chasen:--with-chasen} \
178         %{?with_freetds:--with-freetds} \
179         %{?with_ibase:--with-ibase} \
180         %{?with_iodbc:--with-iodbc} \
181         %{?with_mecab:--with-mecab} \
182         %{?with_mysql:--with-mysql} \
183         %{?with_ssl:--with-openssl} \
184         %{?with_pgsql:--with-pgsql} \
185         %{?with_sqlite:--with-sqlite} \
186         %{?with_sqlite3:--with-sqlite3} \
187         %{?with_unixodbc:--with-unixODBC} \
188         --with-zlib
189
190 # --enable-mysql-fulltext-plugin ?
191 # --with-readline (for SQL monitor) ?
192 # --wiht-extra-charsets=big5,gb2312,gbk,japanese,euc-kr,gujarati,tscii ?
193
194 %{__make} -j1 -C src libmnogocharset.la
195 %{__make} -j1
196
197 #  --with-solid[=DIR]     Include Solid support.  DIR is the Solid base
198 #  --with-openlink[=DIR]   Include OpenLink ODBC support.
199 #  --with-easysoft[=DIR]   Include EasySoft ODBC support.
200 #  --with-sapdb[=DIR]     Include SAPDB support.  DIR is the SAPDB base
201 #  --with-ctlib[=DIR]     Include Ct-Lib support.
202 #  --with-oracle7[=DIR] Include Oracle 7.3 support.  DIR is the Oracle
203 #  --with-oracle8[=DIR] Include Oracle8 support.  DIR is the Oracle
204 #  --with-oracle8i[=DIR]   Include Oracle8i support.  DIR is the Oracle
205 #
206 # FIXME: add selection of storage method, spliting into %{name}-common & %{name}-$DB_NAME
207
208 %install
209 rm -rf $RPM_BUILD_ROOT
210 install -d $RPM_BUILD_ROOT{%{_localstatedir},%{cgidir},%{_sysconfdir}} \
211         $RPM_BUILD_ROOT{/etc/cron.daily,%{_infodir}}
212
213 %{__make} -j1 install \
214         DESTDIR=$RPM_BUILD_ROOT \
215         doc_FILES='$(HTML_ALL)'
216
217 mv -f $RPM_BUILD_ROOT%{_bindir}/search.cgi \
218         $RPM_BUILD_ROOT%{cgidir}/mnogosearch.cgi
219
220 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.daily/mnogosearch-dbgen
221
222 mkdir html
223 cp -af doc/*.{html,css} html
224
225 cd $RPM_BUILD_ROOT%{_sysconfdir}
226 touch locals
227 for f in *-dist ; do
228         mv -f $f `basename $f -dist`
229 done
230
231 # packaged as %doc
232 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/mnogosearch
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %post
238 cat << EOF
239 Please see docs (%{_docdir}/%{name}-%{version}),
240 then read how to setup db connection, and put line like this
241 "pgsql://user:password@/dbname/" into %{_sysconfdir}, then setup database
242 using "indexer -Ecreate" command.
243 EOF
244
245 %post   lib -p /sbin/ldconfig
246 %postun lib -p /sbin/ldconfig
247
248 %files
249 %defattr(644,root,root,755)
250 %doc ChangeLog README TODO html doc/samples
251 %attr(755,root,root) %{_sbindir}/indexer
252 %attr(755,root,root) %{_bindir}/mconv
253 %attr(755,root,root) %{_bindir}/mguesser
254 %attr(755,root,root) %{cgidir}/mnogosearch.cgi
255 %{_datadir}/%{name}
256 %attr(775,root,http) %dir %{_localstatedir}
257 %dir %{_sysconfdir}
258 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/indexer.conf
259 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/langmap.conf
260 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/stopwords.conf
261 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.freq
262 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/search.htm
263 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/node.xml
264 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locals
265 %dir %{_sysconfdir}/langmap
266 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/langmap/*.lm
267 %dir %{_sysconfdir}/stopwords
268 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/stopwords/*.sl
269 %dir %{_sysconfdir}/synonym
270 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/synonym/*.syn
271 %config(noreplace) %attr(750,root,root) /etc/cron.daily/mnogosearch-dbgen
272 %{_mandir}/man1/indexer.1*
273 %{_mandir}/man5/indexer.conf.5*
274
275 %files lib
276 %defattr(644,root,root,755)
277 %attr(755,root,root) %{_libdir}/libmnogocharset-3.3.so
278 %attr(755,root,root) %{_libdir}/libmnogosearch-3.3.so
279
280 %files devel
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_bindir}/udm-config
283 %attr(755,root,root) %{_libdir}/libmnogocharset.so
284 %attr(755,root,root) %{_libdir}/libmnogosearch.so
285 %{_libdir}/libmnogocharset.la
286 %{_libdir}/libmnogosearch.la
287 %{_includedir}/udmsearch.h
288 %{_includedir}/udm_*.h
289
290 %files static
291 %defattr(644,root,root,755)
292 %{_libdir}/libmnogocharset.a
293 %{_libdir}/libmnogosearch.a
This page took 0.121618 seconds and 3 git commands to generate.