]> git.pld-linux.org Git - packages/mlt.git/blob - mlt.spec
e4a5fa7e929ec94a03ef6c7b65d31b2656b3174e
[packages/mlt.git] / mlt.spec
1 #
2 # TODO:
3 #       - bconds
4 #       - more bindings
5 #       - movit library - http://libregraphicsworld.org/blog/entry/introducing-movit-free-library-for-gpu-side-video-processing
6 #
7 Summary:        MLT - open source multimedia framework
8 Summary(pl.UTF-8):      MLT - szkielet multimedialny o otwartych źródłach
9 Name:           mlt
10 Version:        0.9.8
11 Release:        1
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        http://downloads.sourceforge.net/mlt/%{name}-%{version}.tar.gz
15 # Source0-md5:  268e3551958e9fb98927a87315c16889
16 Patch0:         ffmpeg3.patch
17 URL:            http://www.mltframework.org/
18 BuildRequires:  QtGui-devel
19 BuildRequires:  QtSvg-devel
20 BuildRequires:  QtXml-devel
21 BuildRequires:  SDL-devel
22 BuildRequires:  SDL_image-devel
23 BuildRequires:  exiv2-devel
24 BuildRequires:  ffmpeg-devel
25 BuildRequires:  gtk+2-devel
26 #BuildRequires: ladspa-devel
27 #BuildRequires: lame-libs-devel
28 BuildRequires:  libdv-devel >= 0.102
29 #BuildRequires: libmad-devel
30 BuildRequires:  libquicktime-devel
31 BuildRequires:  libsamplerate-devel
32 BuildRequires:  libvorbis-devel >= 1:1.0.1
33 BuildRequires:  libxml2-devel >= 2.5
34 BuildRequires:  pkgconfig
35 BuildRequires:  python-devel
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  sox-devel
38 BuildRequires:  swfdec-devel
39 BuildRequires:  swig-python
40 BuildRequires:  which
41 Obsoletes:      mlt++ < %{version}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 MLT is an open source multimedia framework, designed and developed for
46 television broadcasting. It provides a toolkit for broadcasters, video
47 editors, media players, transcoders, web streamers and many more types
48 of applications. The functionality of the system is provided via an
49 assortment of ready to use tools, XML authoring components, and an
50 extendible plug-in based API.
51
52 %description -l pl.UTF-8
53 MLT to szkielet multimedialny o otwartych źródłach zaprojektowany i
54 rozwijany do nadawania telewizji. Udostępnia zestaw narzędzi dla
55 nadawców, edytory obrazu, odtwarzacze mediów, transkodery, narzędzia
56 do udostępniania strumieni przez WWW i wiele innych rodzajów
57 aplikacji. Funkcjonalność systemu jest zapewniona poprzez asortyment
58 gotowych do użycia narzędzi, komponentów do tworzenia XML-a i
59 rozszerzalne API oparte na wtyczkach.
60
61 %package -n python-mlt
62 Summary:        MLT Python bindings
63 Summary(pl.UTF-8):      Wiązania MLT dla Pythona
64 Group:          Development/Languages/Python
65 Requires:       %{name} = %{version}-%{release}
66
67 %description -n python-mlt
68 Python bindings for MLT - open source multimedia framework.
69
70 %package devel
71 Summary:        Header files for MLT
72 Summary(pl.UTF-8):      Pliki nagłówkowe dla MLT
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Obsoletes:      mlt++-devel < %{version}
76
77 %description devel
78 This package contains header files for MLT.
79
80 %description devel -l pl.UTF-8
81 Ten pakiet zawiera pliki nagłówkowe dla MLT.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 %configure \
89         --enable-gpl \
90         --enable-gpl3 \
91 %ifarch %{x8664}
92         --disable-motion-est \
93 %else
94         --enable-motion-est \
95 %endif
96         --disable-debug \
97 %ifarch i586 i686 %{x8664}
98         --enable-mmx \
99 %else
100         --disable-mmx \
101 %endif
102 %ifarch %{x8664}
103         --enable-sse \
104         --enable-sse2 \
105 %else
106         --disable-sse \
107         --disable-sse2 \
108 %endif
109         --avformat-swscale \
110         --qimage-includedir=%{_includedir}/qt4 \
111         --qimage-libdir=%{_libdir} \
112         --swig-languages=python
113
114 %{__make} \
115         CC="%{__cc}"
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT%{py_sitedir}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 cp -p src/swig/python/{*.py,*.so} $RPM_BUILD_ROOT%{py_sitedir}
125
126 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
127 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
128 %py_postclean
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc ChangeLog README
139 %attr(755,root,root) %{_bindir}/*
140 %attr(755,root,root) %ghost %{_libdir}/*.so.?
141 %attr(755,root,root) %{_libdir}/*.so.*.*
142 %dir %{_libdir}/%{name}
143 %attr(755,root,root) %{_libdir}/%{name}/*
144 %{_datadir}/mlt*
145
146 %files -n python-mlt
147 %defattr(644,root,root,755)
148 %{py_sitedir}/*.py[co]
149 %attr(755,root,root) %{py_sitedir}/*.so
150
151 %files devel
152 %defattr(644,root,root,755)
153 %{_pkgconfigdir}/*.pc
154 %{_includedir}/mlt*
155 %{_libdir}/*.so
This page took 0.054628 seconds and 2 git commands to generate.