]> git.pld-linux.org Git - packages/ming.git/blob - ming.spec
- release 9 (by relup.sh)
[packages/ming.git] / ming.spec
1 #
2 # Conditional build:
3 %bcond_without  php             # build PHP Binding
4
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Ming - an SWF output library
7 Summary(pl.UTF-8):      Ming - biblioteka do produkcji plików SWF
8 Name:           ming
9 Version:        0.4.5
10 Release:        9
11 License:        LGPL
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/ming/%{name}-%{version}.tar.gz
14 # Source0-md5:  a35735a1c4f51681b96bcbfba58db2a0
15 Patch0:         %{name}-perl-shared.patch
16 Patch1:         am.patch
17 Patch2:         %{name}-giflib.patch
18 Patch3:         tcl-libx32.patch
19 URL:            http://ming.sourceforge.net/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bison
23 BuildRequires:  flex
24 BuildRequires:  freetype-devel
25 BuildRequires:  giflib-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool
29 BuildRequires:  python-devel >= 1:2.4
30 BuildRequires:  rpm-perlprov >= 4.0.2-24
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  rpmbuild(macros) >= 1.344
33 BuildRequires:  swig
34 BuildRequires:  swig-tcl
35 BuildRequires:  tcl
36 BuildRequires:  tcl-devel
37 BuildRequires:  zlib-devel
38 %if %{with php}
39 BuildRequires:  %{php_name}-cli
40 BuildRequires:  %{php_name}-devel >= 4:5.3
41 %endif
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Ming is a C library for generating SWF ("Flash") format movies, plus a
46 set of wrappers for using the library from c++ and popular scripting
47 languages like PHP, Python, and Ruby.
48
49 %description -l pl.UTF-8
50 Ming jest biblioteką w C do generowania animacji w formacie SWF
51 ("Flash") wraz z zestawem wrapperów do używania jej z C++ i
52 popularnymi językami skryptowymi, takimi jak PHP, Python i Ruby.
53
54 %package devel
55 Summary:        Ming development files
56 Summary(pl.UTF-8):      Pliki dla programistów Ming
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       giflib-devel
60
61 %description devel
62 Header files for ming library (C and C++).
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe dla biblioteki ming (do C i C++).
66
67 %package static
68 Summary:        Ming static library
69 Summary(pl.UTF-8):      Statyczna biblioteka Ming
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static Ming library.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka Ming.
78
79 %package utils
80 Summary:        Ming utilities
81 Summary(pl.UTF-8):      Narzędzia Ming
82 Group:          Applications/File
83
84 %description utils
85 Ming utilities:
86 - listswf - swf format disassembler
87 - listfdb - show contents of fdb font file
88 - makefdb - rip fdb font definition files out of a generator template
89   file
90 - swftophp - attempt to make a php/ming script out of an swf file
91
92 %description utils -l pl.UTF-8
93 Narzędzia Ming:
94 - listswf - disasembler plików swf
95 - listfdb - pokazuje zawartość plików fontów fdb
96 - makefdb - wyciąga pliki definicji fontów fdb z pliku generatora
97 - swftophp - próbuje zrobić skrypt php/ming z pliku swf
98
99 %package -n perl-ming
100 Summary:        Ming Perl module
101 Summary(pl.UTF-8):      Moduł Perla Ming
102 Group:          Development/Languages/Perl
103 Requires:       %{name} = %{version}-%{release}
104 Obsoletes:      ming-perl
105
106 %description -n perl-ming
107 Ming perl module - perl wrapper for Ming library.
108
109 %description -n perl-ming -l pl.UTF-8
110 Moduł perla Ming - perlowy wrapper do biblioteki Ming.
111
112 %package -n %{php_name}-ming
113 Summary:        Ming module for PHP
114 Summary(pl.UTF-8):      Moduł Ming dla PHP
115 Group:          Development/Languages/PHP
116 Requires:       %{name} = %{version}-%{release}
117 %{?requires_php_extension}
118
119 %description -n %{php_name}-ming
120 PHP interface to Ming SWF generating library.
121
122 %description -n %{php_name}-ming -l pl.UTF-8
123 Interfejs PHP do biblioteki Ming generującej pliki SWF.
124
125 %package -n python-ming
126 Summary:        Ming Python module
127 Summary(pl.UTF-8):      Moduł biblioteki Ming dla języka Python
128 Group:          Development/Languages/Perl
129 Requires:       %{name} = %{version}-%{release}
130 Requires:       python-libs
131
132 %description -n python-ming
133 Ming Python module.
134
135 %description -n python-ming -l pl.UTF-8
136 Moduł biblioteki Ming dla języka Python.
137
138 %package -n tcl-ming
139 Summary:        Ming module for Tcl
140 Summary(pl.UTF-8):      Moduł Ming dla Tcl-a
141 Group:          Development/Languages/Tcl
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       tcl
144
145 %description -n tcl-ming
146 Tcl interface to Ming SWF generating library.
147
148 %description -n tcl-ming -l pl.UTF-8
149 Interfejs Tcl do biblioteki Ming generującej pliki SWF.
150
151 %prep
152 %setup -q
153 %patch0 -p1
154 %patch1 -p1
155 %patch2 -p1
156 %patch3 -p1
157
158 %build
159 %{__libtoolize}
160 %{__aclocal} -I macros
161 %{__autoconf}
162 %{__automake}
163 %configure \
164         --enable-perl \
165         %{?with_php:--enable-php} \
166         --enable-python \
167         --enable-tcl \
168         --disable-silent-rules
169
170 %{__make} -j1 \
171         mingc_ladir=%{_libdir}/tclming
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175 %{__make} install \
176         DESTDIR=$RPM_BUILD_ROOT \
177         mingc_ladir=%{_libdir}/tclming
178
179 %if %{with php}
180 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
181 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/ming.ini
182 ; Enable ming extension module
183 extension=ming.so
184 EOF
185 %endif
186
187 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/SWF/.packlist
188 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
189 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/ming*.py
190 %{__rm} $RPM_BUILD_ROOT%{_libdir}/tclming/*.{la,a}
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post   -p /sbin/ldconfig
196 %postun -p /sbin/ldconfig
197
198 %files
199 %defattr(644,root,root,755)
200 %doc README TODO
201 %attr(755,root,root) %{_libdir}/libming.so.*.*.*
202 %attr(755,root,root) %ghost %{_libdir}/libming.so.1
203
204 %files devel
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/libming.so
207 %{_libdir}/libming.la
208 %{_includedir}/ming.h
209 %{_includedir}/mingpp.h
210 %{_pkgconfigdir}/libming.pc
211
212 %files static
213 %defattr(644,root,root,755)
214 %{_libdir}/libming.a
215
216 %files utils
217 %defattr(644,root,root,755)
218 %doc util/{README,TODO}
219 %attr(755,root,root) %{_bindir}/dbl2png
220 %attr(755,root,root) %{_bindir}/gif2dbl
221 %attr(755,root,root) %{_bindir}/gif2mask
222 %attr(755,root,root) %{_bindir}/listaction
223 %attr(755,root,root) %{_bindir}/listaction_d
224 %attr(755,root,root) %{_bindir}/listfdb
225 %attr(755,root,root) %{_bindir}/listjpeg
226 %attr(755,root,root) %{_bindir}/listmp3
227 %attr(755,root,root) %{_bindir}/listswf
228 %attr(755,root,root) %{_bindir}/listswf_d
229 %attr(755,root,root) %{_bindir}/makefdb
230 %attr(755,root,root) %{_bindir}/makeswf
231 %attr(755,root,root) %{_bindir}/ming-config
232 %attr(755,root,root) %{_bindir}/png2dbl
233 %attr(755,root,root) %{_bindir}/raw2adpcm
234 %attr(755,root,root) %{_bindir}/swftocxx
235 %attr(755,root,root) %{_bindir}/swftoperl
236 %attr(755,root,root) %{_bindir}/swftophp
237 %attr(755,root,root) %{_bindir}/swftopython
238 %attr(755,root,root) %{_bindir}/swftotcl
239
240 %files -n perl-ming
241 %defattr(644,root,root,755)
242 %doc perl_ext/{README,TODO}
243 %{perl_vendorarch}/SWF.pm
244 %{perl_vendorarch}/SWF
245 %dir %{perl_vendorarch}/auto/SWF
246 %attr(755,root,root) %{perl_vendorarch}/auto/SWF/SWF.so
247 %{_mandir}/man3/SWF*
248
249 %if %{with php}
250 %files -n %{php_name}-ming
251 %defattr(644,root,root,755)
252 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/ming.ini
253 %attr(755,root,root) %{php_extensiondir}/ming.so
254 %endif
255
256 %files -n python-ming
257 %defattr(644,root,root,755)
258 %doc py_ext/{README,TODO}
259 %attr(755,root,root) %{py_sitedir}/_mingc.so
260 %{py_sitedir}/ming*.py[co]
261 %if "%{py_ver}" > "2.4"
262 %{py_sitedir}/mingc-*.egg-info
263 %endif
264
265 %files -n tcl-ming
266 %defattr(644,root,root,755)
267 %doc tcl_ext/README
268 %dir %{_libdir}/tclming
269 %attr(755,root,root) %{_libdir}/tclming/mingc.so
This page took 0.079544 seconds and 3 git commands to generate.