]> git.pld-linux.org Git - packages/mediastreamer.git/blob - mediastreamer.spec
- started update to 2.11.2 (note: new sonames)
[packages/mediastreamer.git] / mediastreamer.spec
1 # TODO:
2 # - libebml2, libmatroska2 (Matroska support)
3 # - libbzrtp >= 1.0.0 (ZRTP support)
4 # - dtls (polarssl/mbedtls >= 1.4 when released)
5 #
6 # Conditional build:
7 %bcond_without  bcg729          # support for G279AnnexB in RTC3389 implementation of Comfort Noise Payload
8 %bcond_without  opengl          # X11+OpenGL rendering support
9 %bcond_with     pcap            # audio playing from PCAP files
10 %bcond_without  srtp            # SRTP (secure RTP) support
11 # audio I/O
12 %bcond_without  alsa            # ALSA sound I/O support
13 %bcond_with     arts            # aRts sound I/O support
14 %bcond_with     portaudio       # PortAudio sound I/O support
15 %bcond_without  pulseaudio      # PulseAudio sound I/O support
16 #
17 Summary:        Audio/Video real-time streaming
18 Summary(pl.UTF-8):      Przesyłanie strumieni audio/video w czasie rzeczywistym 
19 Name:           mediastreamer
20 Version:        2.11.2
21 Release:        1
22 License:        GPL v2+
23 Group:          Libraries
24 Source0:        http://download-mirror.savannah.gnu.org/releases/linphone/mediastreamer/%{name}-%{version}.tar.gz
25 # Source0-md5:  8b654c3e8938d50df9e83d2e353888a6
26 Patch0:         %{name}-imagedir.patch
27 URL:            http://www.linphone.org/eng/documentation/dev/mediastreamer2.html
28 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
29 BuildRequires:  SDL-devel >= 1.2.0
30 %{?with_alsa:BuildRequires:     alsa-lib-devel}
31 %{?with_arts:BuildRequires:     artsc-devel}
32 BuildRequires:  autoconf >= 2.53
33 BuildRequires:  automake >= 1:1.9
34 %{?with_bcg729:BuildRequires:   bcg729-devel >= 1.0}
35 BuildRequires:  doxygen
36 # libavcodec >= 51.0.0, libswscale >= 0.7.0
37 BuildRequires:  ffmpeg-devel
38 BuildRequires:  gettext-tools
39 %{?with_opengl:BuildRequires:   glew-devel >= 1.5}
40 BuildRequires:  jack-audio-connection-kit-devel
41 BuildRequires:  intltool >= 0.40
42 BuildRequires:  libgsm-devel
43 %{?with_pcap:BuildRequires:     libpcap-devel}
44 BuildRequires:  libtheora-devel >= 1.0-0.alpha7
45 BuildRequires:  libtool >= 2:2
46 BuildRequires:  libupnp-devel >= 1.6
47 BuildRequires:  libupnp-devel < 1.7
48 BuildRequires:  libv4l-devel
49 BuildRequires:  libvpx-devel >= 0.9.6
50 BuildRequires:  opus-devel >= 0.9.0
51 BuildRequires:  ortp-devel >= 0.24.0
52 BuildRequires:  pkgconfig
53 BuildRequires:  polarssl-devel
54 %{?with_portaudio:BuildRequires:        portaudio-devel}
55 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.21}
56 BuildRequires:  sed >= 4.0
57 BuildRequires:  spandsp-devel >= 0.0.6
58 BuildRequires:  speex-devel >= 1:1.2-beta3
59 BuildRequires:  speexdsp-devel >= 1.2-beta3
60 %{?with_srtp:BuildRequires:     srtp-devel}
61 BuildRequires:  xorg-lib-libX11-devel
62 BuildRequires:  xorg-lib-libXv-devel
63 BuildRequires:  xxd
64 %{?with_bcg729:Requires:        bcg729 >= 1.0}
65 %{?with_opengl:Requires:        glew >= 1.5}
66 Requires:       libtheora >= 1.0-0.alpha7
67 Requires:       libupnp >= 1.6
68 Requires:       libvpx >= 0.9.6
69 Requires:       opus >= 0.9.0
70 Requires:       ortp >= 0.24.0
71 %{?with_pulseaudio:Requires:    pulseaudio-libs >= 0.9.21}
72 Requires:       spandsp >= 0.0.6
73 Requires:       speex >= 1:1.2-beta3
74 Requires:       speexdsp >= 1.2-beta3
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %description
78 Mediastreamer2 is a GPL licensed library to make audio and video
79 real-time streaming and processing. Written in pure C, it is based
80 upon the oRTP library.
81
82 %description -l pl.UTF-8
83 Mediastreamer2 to udostępniona na licencji GPL biblioteka do
84 przesyłania i przetwarzania strumieni audio/video w czasie
85 rzeczywistym. Jest napisana w czystym C, oparta na bibliotece oRTP.
86
87 %package devel
88 Summary:        Header files and development documentation for mediastreamer library
89 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki mediastreamer
90 Group:          Development/Libraries
91 Requires:       %{name} = %{version}-%{release}
92 %{?with_opengl:Requires:        OpenGL-devel}
93 %{?with_alsa:Requires:  alsa-lib-devel}
94 %{?with_bcg729:Requires:        bcg729-devel >= 1.0}
95 Requires:       ffmpeg-devel
96 %{?with_opengl:Requires:        glew-devel >= 1.5}
97 Requires:       libtheora-devel >= 1.0-0.alpha7
98 Requires:       libupnp-devel >= 1.6
99 Requires:       libupnp-devel < 1.7
100 Requires:       libv4l-devel
101 Requires:       libvpx-devel >= 0.9.6
102 Requires:       opus-devel >= 0.9.0
103 Requires:       ortp-devel >= 0.24.0
104 Requires:       polarssl-devel
105 %{?with_portaudio:Requires:     portaudio-devel}
106 %{?with_pulseaudio:Requires:    pulseaudio-devel >= 0.9.21}
107 Requires:       spandsp-devel >= 0.0.6
108 Requires:       speex-devel >= 1:1.2-beta3
109 Requires:       speexdsp-devel >= 1.2-beta3
110 %{?with_srtp:Requires:  srtp-devel}
111 Requires:       xorg-lib-libX11-devel
112 Requires:       xorg-lib-libXv-devel
113
114 %description devel
115 Header files and development documentation for mediastreamer library.
116
117 %description devel -l pl.UTF-8
118 Pliki nagłówkowe i dokumentacja do biblioteki mediastreamer.
119
120 %package static
121 Summary:        Static mediastreamer library
122 Summary(pl.UTF-8):      Statyczna biblioteka mediastreamer
123 Group:          Development/Libraries
124 Requires:       %{name}-devel = %{version}-%{release}
125
126 %description static
127 Static mediastreamer library.
128
129 %description static -l pl.UTF-8
130 Statyczna biblioteka mediastreamer.
131
132 %prep
133 %setup -q
134 %patch0 -p1
135
136 %build
137 %{__libtoolize}
138 %{__aclocal}
139 %{__autoconf}
140 %{__autoheader}
141 %{__automake}
142 %configure \
143         --enable-alsa%{!?with_alsa:=no} \
144         %{?with_arts:--enable-artsc} \
145         %{?with_bcg729:--enable-bcg729} \
146         --enable-external-ortp \
147         %{!?with_opengl:--disable-glx} \
148         %{?with_pcap:--enable-pcap} \
149         %{?with_portaudio:--enable-portaudio} \
150         --enable-pulseaudio%{!?with_pulseaudio:=no} \
151         --disable-silent-rules \
152         --enable-static \
153         %{!?with_srtp:--with-srtp=none}
154
155 %{__make}
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159
160 %{__make} install \
161         DESTDIR=$RPM_BUILD_ROOT
162
163 # for external plugins
164 install -d $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins
165
166 # Remove duplicated documentation
167 %{__rm} -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/html
168
169 %find_lang %{name}
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %files -f %{name}.lang
178 %defattr(644,root,root,755)
179 %doc AUTHORS ChangeLog NEWS README
180 %attr(755,root,root) %{_bindir}/mediastream
181 %attr(755,root,root) %{_bindir}/msaudiocmp
182 %{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
183 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_base.so.4
185 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_voip.so.4
187 %dir %{_libdir}/mediastreamer
188 %dir %{_libdir}/mediastreamer/plugins
189 %{_pixmapsdir}/%{name}
190
191 %files devel
192 %defattr(644,root,root,755)
193 %doc help/doc/html
194 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so
195 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so
196 %{_libdir}/libmediastreamer_base.la
197 %{_libdir}/libmediastreamer_voip.la
198 %{_includedir}/mediastreamer2
199 %{_pkgconfigdir}/mediastreamer.pc
200
201 %files static
202 %defattr(644,root,root,755)
203 %{_libdir}/libmediastreamer_base.a
204 %{_libdir}/libmediastreamer_voip.a
This page took 0.228404 seconds and 3 git commands to generate.