]> git.pld-linux.org Git - packages/mate-settings-daemon.git/commitdiff
adjust api changes for notify_notification_new >= 0.7 auto/th/mate-settings-daemon-1.5.5-2
authorElan Ruusamäe <glen@delfi.ee>
Mon, 18 Feb 2013 20:27:54 +0000 (22:27 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 18 Feb 2013 20:27:54 +0000 (22:27 +0200)
mate-settings-daemon.spec
use-libnotify.patch

index f95d893a19b200368d6253280b96c86525e0cb69..8805504fdeb95278467b6379c419662c4e6c187e 100644 (file)
@@ -5,7 +5,7 @@
 Summary:       MATE Desktop settings daemon
 Name:          mate-settings-daemon
 Version:       1.5.5
-Release:       1.1
+Release:       2
 License:       GPL v2+
 Group:         X11/Applications
 Source0:       http://pub.mate-desktop.org/releases/1.5/%{name}-%{version}.tar.xz
index ca3951d89ae5850804d39bb3b0cbf7bc84edc349..4eee5ddc06909da1542fd3e003d68f9a70ccbe81 100644 (file)
@@ -18,8 +18,8 @@
        $(MATE_DESKTOP_LIBS)
  
  plugin_in_files =                     \
---- mate-settings-daemon-1.5.5/./plugins/xrandr/msd-xrandr-manager.c~  2013-02-08 01:25:01.000000000 +0200
-+++ mate-settings-daemon-1.5.5/./plugins/xrandr/msd-xrandr-manager.c   2013-02-18 22:10:12.263775052 +0200
+--- mate-settings-daemon-1.5.5/plugins/xrandr/msd-xrandr-manager.c     2013-02-18 22:10:12.263775052 +0200
++++ mate-settings-daemon-1.5.5/plugins/xrandr/msd-xrandr-manager.c     2013-02-18 22:25:36.719541100 +0200
 @@ -46,8 +46,8 @@
  #include <libmateui/mate-rr.h>
  #include <libmateui/mate-rr-labeler.h>
          MsdXrandrManagerPrivate *priv = mgr->priv;
          NotifyNotification *notification;
  
-@@ -1107,7 +1107,7 @@
+@@ -1093,8 +1093,7 @@
+         else
+                 notification = notify_notification_new (primary_text,
+                                                         error_to_display ? error_to_display->message : secondary_text,
+-                                                        MSD_XRANDR_ICON_NAME,
+-                                                        NULL);
++                                                        MSD_XRANDR_ICON_NAME);
+         notify_notification_show (notification, NULL); /* NULL-GError */
+ #else
+@@ -1107,7 +1106,7 @@
  
          gtk_dialog_run (GTK_DIALOG (dialog));
          gtk_widget_destroy (dialog);
@@ -69,8 +79,8 @@
        $(NULL)
  
  plugin_in_files =             \
---- mate-settings-daemon-1.5.5/./plugins/a11y-keyboard/msd-a11y-keyboard-manager.c~    2013-02-08 01:25:01.000000000 +0200
-+++ mate-settings-daemon-1.5.5/./plugins/a11y-keyboard/msd-a11y-keyboard-manager.c     2013-02-18 22:10:59.255932639 +0200
+--- mate-settings-daemon-1.5.5/plugins/a11y-keyboard/msd-a11y-keyboard-manager.c       2013-02-18 22:10:59.255932639 +0200
++++ mate-settings-daemon-1.5.5/plugins/a11y-keyboard/msd-a11y-keyboard-manager.c       2013-02-18 22:20:31.682202641 +0200
 @@ -46,9 +46,9 @@
  #include <X11/extensions/XIproto.h>
  #endif
          gboolean    res;
          const char *title;
          const char *message;
-@@ -625,7 +625,7 @@
+@@ -591,8 +591,7 @@
+         msd_a11y_keyboard_manager_ensure_status_icon (manager);
+         manager->priv->notification = notify_notification_new (title,
+                                                                message,
+-                                                               "preferences-desktop-accessibility",
+-                                                               NULL);
++                                                               "preferences-desktop-accessibility");
+         notify_notification_attach_to_status_icon (manager->priv->notification, manager->priv->status_icon);
+         notify_notification_set_timeout (manager->priv->notification, NOTIFICATION_TIMEOUT * 1000);
+@@ -625,7 +624,7 @@
          return res;
  #else
          return FALSE;
  }
  
  
-@@ -700,7 +700,7 @@
+@@ -700,7 +699,7 @@
  ax_stickykeys_warning_post_bubble (MsdA11yKeyboardManager *manager,
                                     gboolean                enabled)
  {
          gboolean    res;
          const char *title;
          const char *message;
-@@ -764,7 +764,7 @@
+@@ -730,8 +729,7 @@
+         msd_a11y_keyboard_manager_ensure_status_icon (manager);
+         manager->priv->notification = notify_notification_new (title,
+                                                                message,
+-                                                               "preferences-desktop-accessibility",
+-                                                               NULL);
++                                                               "preferences-desktop-accessibility");
+         notify_notification_attach_to_status_icon (manager->priv->notification, manager->priv->status_icon);
+         notify_notification_set_timeout (manager->priv->notification, NOTIFICATION_TIMEOUT * 1000);
+@@ -764,7 +762,7 @@
          return res;
  #else
          return FALSE;
  }
  
  static void
-@@ -1250,9 +1250,9 @@
+@@ -1250,9 +1248,9 @@
  {
          manager->priv = MSD_A11Y_KEYBOARD_MANAGER_GET_PRIVATE (manager);
  
This page took 0.041129 seconds and 4 git commands to generate.