]> git.pld-linux.org Git - packages/lxqt-powermanagement.git/blob - lxqt-powermanagement.spec
98778d862c02496451ee0ecc0e16280713a19e26
[packages/lxqt-powermanagement.git] / lxqt-powermanagement.spec
1 #
2 # Conditional build:
3 #
4 %define         qtver           5.3.1
5
6 Summary:        lxqt-powermanagement
7 Name:           lxqt-powermanagement
8 Version:        0.10.0
9 Release:        1
10 License:        GPLv2 and LGPL-2.1+
11 Group:          X11/Applications
12 Source0:        http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
13 # Source0-md5:  e17763f5e7c2a9f8595a58209d51cb86
14 URL:            http://www.lxqt.org/
15 BuildRequires:  Qt5Svg-devel >= %{qtver}
16 BuildRequires:  cmake >= 2.8.3
17 BuildRequires:  kf5-solid-devel
18 BuildRequires:  liblxqt-devel >= 0.10.0
19 BuildRequires:  libqtxdg-devel >= 0.5.3
20 BuildRequires:  libxcb-devel
21 BuildRequires:  xz-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 lxqt-powermanagement.
26
27 %prep
28 %setup -q
29
30 %build
31 install -d build
32 cd build
33 %cmake \
34         ../
35
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} -C build install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %find_lang %{name} --all-name --with-qm
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files -f %{name}.lang
50 %defattr(644,root,root,755)
51 %attr(755,root,root) %{_bindir}/lxqt-config-powermanagement
52 %attr(755,root,root) %{_bindir}/lxqt-powermanagement
53 %{_desktopdir}/lxqt-config-powermanagement.desktop
54 %{_iconsdir}/hicolor/scalable/devices/laptop-lid.svg
55 %dir %{_datadir}/lxqt/translations/lxqt-config-powermanagement
56 %dir %{_datadir}/lxqt/translations/lxqt-powermanagement
This page took 0.063817 seconds and 2 git commands to generate.