]> git.pld-linux.org Git - packages/lsh.git/blob - lsh.spec
- updated to 2.1
[packages/lsh.git] / lsh.spec
1 #
2 # Conditional build:
3 %bcond_without  kerberos5       # without kerberos V support
4 #
5 Summary:        GNU implementation of the Secure Shell protocols
6 Summary(pl.UTF-8):      Implementacja GNU bezpiecznego shella
7 Name:           lsh
8 Version:        2.1
9 Release:        1
10 License:        GPL v2+
11 Group:          Networking/Daemons
12 Source0:        http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
13 # Source0-md5:  cde8e1306b1c544909e1e9ecb86e6402
14 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
15 # Source1-md5:  164cdde8060577b54954c3f9f067927e
16 Patch0:         %{name}-info.patch
17 URL:            http://www.lysator.liu.se/~nisse/lsh/
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake
20 BuildRequires:  gmp-devel >= 3.1
21 BuildRequires:  groff
22 %{?with_kerberos5:BuildRequires:        heimdal-devel}
23 BuildRequires:  liboop-devel
24 BuildRequires:  libwrap-devel
25 BuildRequires:  m4
26 BuildRequires:  nettle-devel >= 1.14
27 BuildRequires:  pam-devel
28 BuildRequires:  texinfo
29 BuildRequires:  xorg-lib-libXau-devel
30 BuildRequires:  zlib-devel
31 # only for maintainer mode
32 #BuildRequires: guile
33 #BuildRequires: slib
34 Requires:       nettle >= 1.14
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _sysconfdir      /etc/%{name}
38
39 %description
40 LSH is the GNU implementation of the secure shell protocols (secsh2).
41 LSH includes a client, a server, and a few scripts and utility
42 programs.
43
44 Note: it doesn't support SSH1 protocol, but the server can fallback to
45 /usr/sbin/sshd - if you need SSH1 support in server, please install
46 appropriate daemon (openssh-server, SSH.COM 1.2.x) as /usr/sbin/sshd.
47
48 %description -l pl.UTF-8
49 LSH jest implementacją GNU protokołów bezpiecznego shella (secsh2).
50 Zawiera klienta, serwer, kilka skryptów i narzędzi.
51
52 Uwaga: ta implementacja nie obsługuje protokołu SSH1, ale serwer może
53 wywołać /usr/sbin/sshd. Jeśli obsługa SSH1 jest potrzebna w serwerze,
54 należy zainstalować odpowiedniego demona (openssh-server lub SSH.COM
55 1.2.x) jako /usr/sbin/sshd.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60
61 %build
62 cd src/spki
63 %{__aclocal}
64 %{__autoconf}
65 %{__automake}
66 cd ../..
67 %{__aclocal}
68 %{__autoconf}
69 %{__automake}
70 %configure \
71         XAUTH_PROGRAM=/usr/bin/xauth \
72         %{!?with_kerberos5:--disable-kerberos} \
73         --with-sshd1=%{_sbindir}/sshd \
74         --with-tcpwrappers \
75         --with-zlib
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,logrotate.d},/var/spool/lsh}
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 install -d $RPM_BUILD_ROOT%{_mandir}
87 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
88 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lsh-man-pages,diff.*}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/postshell
94 -/usr/sbin/fix-info-dir -c %{_infodir}
95
96 %postun -p /sbin/postshell
97 -/usr/sbin/fix-info-dir -c %{_infodir}
98
99 %files
100 %defattr(644,root,root,755)
101 %doc ANNOUNCE AUTHORS ChangeLog* FAQ NEWS README doc/{HACKING,NOTES,PORTS,TASKLIST,TODO,*.txt}
102 #%attr(754,root,root) /etc/rc.d/init.d/*
103 #%attr(640,root,root) /etc/sysconfig/*
104 #%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/*
105 %attr(6750,root,root) %dir /var/spool/lsh
106 %attr(755,root,root) %{_bindir}/lcp
107 %attr(755,root,root) %{_bindir}/lsftp
108 %attr(755,root,root) %{_bindir}/lsh
109 %attr(755,root,root) %{_bindir}/lsh-authorize
110 %attr(755,root,root) %{_bindir}/lsh-decode-key
111 %attr(755,root,root) %{_bindir}/lsh-decrypt-key
112 %attr(755,root,root) %{_bindir}/lsh-export-key
113 %attr(755,root,root) %{_bindir}/lsh-keygen
114 %attr(755,root,root) %{_bindir}/lsh-make-seed
115 %attr(755,root,root) %{_bindir}/lsh-upgrade
116 %attr(755,root,root) %{_bindir}/lsh-upgrade-key
117 %attr(755,root,root) %{_bindir}/lsh-writekey
118 %attr(755,root,root) %{_bindir}/lshg
119 %attr(755,root,root) %{_bindir}/srp-gen
120 %attr(755,root,root) %{_bindir}/ssh-conv
121 %attr(755,root,root) %{_sbindir}/lsh-execuv
122 %{?with_kerberos5:%attr(755,root,root) %{_sbindir}/lsh-krb-checkpw}
123 %attr(755,root,root) %{_sbindir}/lsh-pam-checkpw
124 %attr(755,root,root) %{_sbindir}/lshd
125 %attr(755,root,root) %{_sbindir}/sftp-server
126 %{_infodir}/lsh.info*
127 %{_mandir}/man1/lsftp.1*
128 %{_mandir}/man1/lsh.1*
129 %{_mandir}/man1/lsh-authorize.1*
130 %{_mandir}/man1/lsh-decode-key.1*
131 %{_mandir}/man1/lsh-decrypt-key.1*
132 %{_mandir}/man1/lsh-export-key.1*
133 %{_mandir}/man1/lsh-keygen.1*
134 %{_mandir}/man1/lsh-make-seed.1*
135 %{_mandir}/man1/lsh-upgrade.1*
136 %{_mandir}/man1/lsh-upgrade-key.1*
137 %{_mandir}/man1/lsh-writekey.1*
138 %{_mandir}/man1/lshg.1*
139 %{_mandir}/man1/sexp-conv.1*
140 %{_mandir}/man1/srp-gen.1*
141 %{_mandir}/man1/ssh-conv.1*
142 %{_mandir}/man5/DSA.5*
143 %{_mandir}/man5/SHA.5*
144 %{_mandir}/man5/SPKI.5*
145 %{_mandir}/man5/secsh.5*
146 %{_mandir}/man8/lshd.8*
147 %{_mandir}/man8/sftp-server.8*
This page took 0.054313 seconds and 3 git commands to generate.