]> git.pld-linux.org Git - packages/llvm.git/blob - llvm.spec
8035a872eebead5b3aadfd784244091cd6a5aa07
[packages/llvm.git] / llvm.spec
1 # TODO:
2 # - move and package:
3 #       %{_datadir}/clang/clang-format-sublime.py - sublime plugin
4 #       %{_datadir}/clang/clang-format.el - emacs mode
5 #       %{_datadir}/clang/clang-format.py - vim plugin
6 # - no content in doc package (it used to contain parts of clang apidocs and some examples)
7 #
8 # Conditional build:
9 %bcond_without  lldb            # LLDB debugger
10 %bcond_without  polly           # Polly cache-locality optimization, auto-parallelism and vectorization
11 %bcond_without  rt              # compiler-rt libraries
12 %bcond_without  multilib        # compiler-rt multilib libraries
13 %bcond_without  ocaml           # OCaml binding
14 %bcond_without  doc             # HTML docs and man pages
15 %bcond_with     apidocs         # doxygen docs (HUGE, so they are not built by default)
16 %bcond_with     tests           # run tests
17
18 # No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
19 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
20 %undefine       with_ocaml
21 %endif
22
23 Summary:        The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
24 Summary(pl.UTF-8):      Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
25 Name:           llvm
26 Version:        3.8.1
27 Release:        0.1
28 License:        University of Illinois/NCSA Open Source License
29 Group:          Development/Languages
30 #Source0Download: http://llvm.org/releases/download.html
31 Source0:        http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
32 # Source0-md5:  538467e6028bbc9259b1e6e015d25845
33 Source1:        http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
34 # Source1-md5:  4ff2f8844a786edb0220f490f7896080
35 Source2:        http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
36 # Source2-md5:  f140db073d2453f854fbe01cc46f3110
37 Source3:        http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
38 # Source3-md5:  9e4787b71be8e432fffd31e13ac87623
39 Source4:        http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
40 # Source4-md5:  8a40e697a4ba1c8b640b85d074bd6e25
41 Source5:        http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
42 # Source5-md5:  6e49f285d0b366cc3cab782d8c92d382
43 Source6:        http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
44 # Source6-md5:  68cd069bf99c71ebcfbe01d557c0e14d
45 Patch0:         %{name}-lld-link.patch
46 Patch1:         %{name}-pld.patch
47 Patch2:         libdir.patch
48 Patch3:         x32-gcc-toolchain.patch
49 Patch4:         cmake-buildtype.patch
50 URL:            http://llvm.org/
51 BuildRequires:  bash
52 BuildRequires:  bison
53 BuildRequires:  cmake
54 BuildRequires:  flex
55 BuildRequires:  gcc >= 5:3.4
56 # gcc4 might be installed, but not current __cc
57 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
58 BuildRequires:  __cc >= 3.4
59 %endif
60 %ifarch x32
61 BuildRequires:  glibc-devel(x86_64)
62 %endif
63 BuildRequires:  groff
64 BuildRequires:  libltdl-devel
65 BuildRequires:  libstdc++-devel >= 5:3.4
66 %if %{with ocaml}
67 BuildRequires:  ocaml-ctypes-devel >= 0.4
68 BuildRequires:  ocaml-findlib
69 BuildRequires:  ocaml-ocamldoc
70 BuildRequires:  ocaml-ounit
71 %endif
72 BuildRequires:  perl-base >= 1:5.6
73 BuildRequires:  perl-tools-pod
74 BuildRequires:  rpm-pythonprov
75 %{?with_doc:BuildRequires:      sphinx-pdg}
76 BuildRequires:  tar >= 1:1.22
77 BuildRequires:  xz
78 %if %{with apidocs}
79 BuildRequires:  doxygen
80 BuildRequires:  graphviz
81 %endif
82 %if %{with tests}
83 BuildRequires:  dejagnu
84 BuildRequires:  python
85 BuildRequires:  tcl-devel
86 %endif
87 %if %{with rt} && %{with multilib}
88 %ifarch %{x8664}
89 BuildRequires:  gcc-c++-multilib-32
90 BuildRequires:  libstdc++-multilib-32-devel
91 %endif
92 %endif
93 %if %{with lldb}
94 BuildRequires:  epydoc
95 %ifarch i386 i486
96 BuildRequires:  libatomic-devel
97 %endif
98 BuildRequires:  libedit-devel
99 BuildRequires:  libxml2-devel >= 2
100 BuildRequires:  ncurses-ext-devel
101 BuildRequires:  python-devel >= 2
102 BuildRequires:  swig-python
103 %endif
104 %if %{with polly}
105 BuildRequires:  cloog-isl-devel
106 # >= 0.18.2-2
107 BuildRequires:  gmp-devel
108 BuildRequires:  isl-devel >= 0.14
109 # optional
110 BuildRequires:  pluto-devel
111 BuildRequires:  scoplib-devel >= 0.2.1-2
112 #cuda-devel
113 %endif
114 %if %{with ocaml}
115 BuildConflicts: llvm-ocaml
116 %endif
117 Requires:       %{name}-libs = %{version}-%{release}
118 # LLVM is not supported on PPC64
119 # http://llvm.org/bugs/show_bug.cgi?id=3729
120 ExcludeArch:    ppc64
121 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123 %define         abi     3.8
124 %define         _sysconfdir     /etc/%{name}
125
126 %define         specflags_ppc   -fno-var-tracking-assignments
127
128 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
129 %define         _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
130
131 # clang doesn't know -fvar-tracking-assignments, and leaving it here would pollute llvm-config
132 # -Werror=format-security is for swig
133 # TODO: add - -Werror=format-security to tools/lldb/scripts/LLDBWrapPython.cpp
134 %define         filterout_c     -fvar-tracking-assignments
135 %define         filterout_cxx   -fvar-tracking-assignments -Werror=format-security
136 %define         filterout_ccpp  -fvar-tracking-assignments
137
138 # std::__once_call, std::__once_callable non-function symbols
139 %define         skip_post_check_so      liblldb.so.*
140
141 %description
142 LLVM is a compiler infrastructure designed for compile-time,
143 link-time, runtime, and idle-time optimization of programs from
144 arbitrary programming languages. LLVM is written in C++ and has been
145 developed since 2000 at the University of Illinois and Apple. It
146 currently supports compilation of C and C++ programs using clang
147 frontend.
148
149 %description -l pl.UTF-8
150 LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
151 czasu kompilowania, linkowania, działania i bezczynności programów w
152 dowolnych językach programowania. Jest napisana w C++, rozwijana od
153 roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
154 kompilację programów w C i C++ przy użyciu frontendu clang.
155
156 %package libs
157 Summary:        LLVM shared libraries
158 Summary(pl.UTF-8):      Biblioteki współdzielone LLVM-a
159 Group:          Libraries
160 Conflicts:      llvm < 3.2
161
162 %description libs
163 LLVM shared libraries.
164
165 %description libs -l pl.UTF-8
166 Biblioteki współdzielone LLVM-a.
167
168 %package devel
169 Summary:        Static libraries and header files for LLVM
170 Summary(pl.UTF-8):      Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
171 Group:          Development/Languages
172 Requires:       %{name}-libs = %{version}-%{release}
173 Requires:       libstdc++-devel >= 6:3.4
174
175 %description devel
176 This package contains static libraries and header files needed to
177 develop new native programs that use the LLVM infrastructure.
178
179 %description devel -l pl.UTF-8
180 Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
181 potrzebne do tworzenia nowych programów natywnych wykorzystujących
182 infrastrukturę LLVM.
183
184 %package doc
185 Summary:        Documentation for LLVM
186 Summary(pl.UTF-8):      Dokumentacja do LLVM-a
187 Group:          Documentation
188 # does not require base
189
190 %description doc
191 Documentation for the LLVM compiler infrastructure.
192
193 %description doc -l pl.UTF-8
194 Dokumentacja do infrastruktury kompilatorów LLVM.
195
196 %package apidocs
197 Summary:        API documentation for LLVM
198 Summary(pl.UTF-8):      Dokumentacja API LLVM-a
199 Group:          Development/Languages
200 Requires:       %{name}-doc = %{version}-%{release}
201
202 %description apidocs
203 API documentation for the LLVM compiler infrastructure.
204
205 %description apidocs -l pl.UTF-8
206 Dokumentacja API infrastruktury kompilatorów LLVM.
207
208 %package polly
209 Summary:        Polyhedral optimizations for LLVM
210 Summary(pl.UTF-8):      Optymalizacje wielościanowe dla LLVM-a
211 Group:          Development/Tools
212 URL:            http://polly.llvm.org/
213 Requires:       %{name} = %{version}-%{release}
214
215 %description polly
216 Polly is a high-level loop and data-locality optimizer and
217 optimization infrastructure for LLVM. It uses an abstract mathematical
218 representation based on integer polyhedra to analyze and optimize the
219 memory access pattern of a program.
220
221 %description polly -l pl.UTF-8
222 Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
223 optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
224 reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
225 do analizy i optymalizacji wzorców dostępu do pamięci przez program.
226
227 %package polly-devel
228 Summary:        Header files for LLVM Polly optimization infrastructure
229 Summary(pl.UTF-8):      Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
230 Group:          Development/Libraries
231 URL:            http://polly.llvm.org/
232 Requires:       %{name}-devel = %{version}-%{release}
233 Requires:       %{name}-polly = %{version}-%{release}
234
235 %description polly-devel
236 Header files for LLVM Polly optimization infrastructure.
237
238 %description polly-devel -l pl.UTF-8
239 Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
240
241 %package -n clang
242 Summary:        A C language family frontend for LLVM
243 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C
244 License:        NCSA
245 Group:          Development/Languages
246 Requires:       %{name} = %{version}-%{release}
247 Requires:       clang-libs = %{version}-%{release}
248
249 %description -n clang
250 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
251 of a crane or goose. 3. C-language family front-end toolkit.
252
253 The goal of the Clang project is to create a new C, C++, Objective C
254 and Objective C++ front-end for the LLVM compiler. Its tools are built
255 as libraries and designed to be loosely-coupled and extendable.
256
257 %description -n clang -l pl.UTF-8
258 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
259 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
260 z rodziny C.
261
262 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
263 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
264 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
265 i rozszerzaniu.
266
267 %package -n clang-libs
268 Summary:        Clang shared libraries
269 Summary(pl.UTF-8):      Biblioteki współdzielone Clanga
270 Group:          Libraries
271
272 %description -n clang-libs
273 Clang shared libraries.
274
275 %description -n clang-libs -l pl.UTF-8
276 Biblioteki współdzielone Clanga.
277
278 %package -n clang-multilib
279 Summary:        A C language family frontend for LLVM - 32-bit support
280 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C - obsługa binariów 32-bitowych
281 License:        NCSA
282 Group:          Development/Languages
283 Requires:       clang = %{version}-%{release}
284
285 %description -n clang-multilib
286 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
287 of a crane or goose. 3. C-language family front-end toolkit.
288
289 The goal of the Clang project is to create a new C, C++, Objective C
290 and Objective C++ front-end for the LLVM compiler. Its tools are built
291 as libraries and designed to be loosely-coupled and extendable.
292
293 This package contains the C compiler support for producing 32-bit
294 programs on 64-bit host.
295
296 %description -n clang-multilib -l pl.UTF-8
297 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
298 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
299 z rodziny C.
300
301 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
302 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
303 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
304 i rozszerzaniu.
305
306 Ten pakiet zawiera rozszerzenie kompilatora C o obsługę tworzenia
307 programów 32-bitowych na maszynie 64-bitowej.
308
309 %package -n clang-analyzer
310 Summary:        A source code analysis framework
311 Summary(pl.UTF-8):      Szkielet do analizy kodu źródłowego
312 License:        NCSA
313 Group:          Development/Languages
314 Requires:       clang = %{version}-%{release}
315 # not picked up automatically since files are currently not instaled
316 # in standard Python hierarchies yet
317 Requires:       python
318
319 %description -n clang-analyzer
320 The Clang Static Analyzer consists of both a source code analysis
321 framework and a standalone tool that finds bugs in C and Objective-C
322 programs. The standalone tool is invoked from the command-line, and is
323 intended to run in tandem with a build of a project or code base.
324
325 %description -n clang-analyzer -l pl.UTF-8
326 Clang Static Analyzer składa się ze szkieletu do analizy kodu
327 źródłowego oraz samodzielnego narzędzia znajdującego błędy w
328 programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
329 myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
330
331 %package -n clang-devel
332 Summary:        Header files for Clang
333 Summary(pl.UTF-8):      Pliki nagłówkowe Clanga
334 Group:          Development/Languages
335 Requires:       %{name}-devel = %{version}-%{release}
336 Requires:       clang = %{version}-%{release}
337
338 %description -n clang-devel
339 This package contains header files for the Clang compiler.
340
341 %description -n clang-devel -l pl.UTF-8
342 Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
343
344 %package -n clang-doc
345 Summary:        Documentation for Clang
346 Summary(pl.UTF-8):      Dokumentacja do Clanga
347 Group:          Documentation
348 Requires:       %{name} = %{version}-%{release}
349
350 %description -n clang-doc
351 Documentation for the Clang compiler front-end.
352
353 %description -n clang-doc -l pl.UTF-8
354 Dokumentacja do frontendu kompilatora Clang.
355
356 %package -n clang-apidocs
357 Summary:        API documentation for Clang
358 Summary(pl.UTF-8):      Dokumentacja API Clanga
359 Group:          Development/Languages
360 Requires:       clang-doc = %{version}-%{release}
361
362 %description -n clang-apidocs
363 API documentation for the Clang compiler.
364
365 %description -n clang-apidocs -l pl.UTF-8
366 Dokumentacja API kompilatora Clang.
367
368 %package -n clang-tools-extra
369 Summary:        Extra tools for Clang
370 Summary(pl.UTF-8):      Dodatkowe narzędzia do kompilatora Clang
371 Group:          Development/Tools
372 URL:            http://clang.llvm.org/docs/ClangTools.html
373 Requires:       clang = %{version}-%{release}
374
375 %description -n clang-tools-extra
376 Extra tools for Clang.
377
378 %description -n clang-tools-extra -l pl.UTF-8
379 Dodatkowe narzędzia do kompilatora Clang.
380
381 %package -n lld
382 Summary:        The LLVM linker
383 Summary(pl.UTF-8):      Konsolidator z projektu LLVM
384 Group:          Development/Libraries
385 URL:            http://lld.llvm.org/
386 Requires:       %{name} = %{version}-%{release}
387
388 %description -n lld
389 lld is a new set of modular code for creating linker tools.
390
391 %description -n lld -l pl.UTF-8
392 lld to nowy zbiór modularnego kodu do tworzenia narzędzi
393 konsolidujących.
394
395 %package -n lld-devel
396 Summary:        Development files for LLD linker tools
397 Summary(pl.UTF-8):      Pliki programistyczne narzędzi konsolidujących LLD
398 Group:          Development/Tools
399 URL:            http://lld.llvm.org/
400 Requires:       %{name}-devel = %{version}-%{release}
401
402 %description -n lld-devel
403 Development files for LLD linker tools.
404
405 %description -n lld-devel -l pl.UTF-8
406 Pliki programistyczne narzędzi konsolidujących LLD.
407
408 %package -n lldb
409 Summary:        Next generation high-performance debugger
410 Summary(pl.UTF-8):      Wydajny debugger nowej generacji
411 Group:          Development/Debuggers
412 URL:            http://lldb.llvm.org/
413 Requires:       %{name} = %{version}-%{release}
414
415 %description -n lldb
416 LLDB is a next generation, high-performance debugger. It is built as a
417 set of reusable components which highly leverage existing libraries in
418 the larger LLVM Project, such as the Clang expression parser and LLVM
419 disassembler.
420
421 %description -n lldb -l pl.UTF-8
422 LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
423 komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
424 w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
425 disasembler LLVM.
426
427 %package -n lldb-devel
428 Summary:        Development files for LLDB debugger
429 Summary(pl.UTF-8):      Pliki programistyczne debuggera LLDB
430 Group:          Development/Libraries
431 URL:            http://lldb.llvm.org/
432 Requires:       %{name}-devel = %{version}-%{release}
433 Requires:       clang-devel = %{version}-%{release}
434 Requires:       lldb = %{version}-%{release}
435
436 %description -n lldb-devel
437 Development files for LLDB debugger.
438
439 %description -n lldb-devel -l pl.UTF-8
440 Pliki programistyczne debuggera LLDB.
441
442 %package ocaml
443 Summary:        OCaml binding for LLVM
444 Summary(pl.UTF-8):      Wiązanie OCamla do LLVM-a
445 Group:          Libraries
446 Requires:       %{name} = %{version}-%{release}
447 %requires_eq    ocaml-runtime
448
449 %description ocaml
450 OCaml binding for LLVM.
451
452 %description ocaml -l pl.UTF-8
453 Wiązanie OCamla do LLVM-a.
454
455 %package ocaml-devel
456 Summary:        Development files for LLVM OCaml binding
457 Summary(pl.UTF-8):      Pliki programistyczne wiązania OCamla do LLVM-a
458 Group:          Development/Libraries
459 Requires:       %{name}-devel = %{version}-%{release}
460 Requires:       %{name}-ocaml = %{version}-%{release}
461
462 %description ocaml-devel
463 The llvm-ocaml-devel package contains libraries and signature files
464 for developing applications that use llvm-ocaml binding.
465
466 %description ocaml-devel -l pl.UTF-8
467 Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
468 wykorzystujących wiązanie llvm-ocaml.
469
470 %package ocaml-doc
471 Summary:        Documentation for LLVM's OCaml binding
472 Summary(pl.UTF-8):      Dokumentacja wiązania OCamla do LLVM-a
473 Group:          Documentation
474 Requires:       %{name}-ocaml = %{version}-%{release}
475
476 %description ocaml-doc
477 HTML documentation for LLVM's OCaml binding.
478
479 %description ocaml-doc -l pl.UTF-8
480 Dokumentacja HTML wiązania OCamla do LLVM-a.
481
482 %prep
483 %setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
484 mv cfe-%{version}.src tools/clang
485 %{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
486 %{?with_lldb:mv lldb-%{version}.src tools/lldb}
487 %{?with_polly:mv polly-%{version}.src tools/polly}
488 mv clang-tools-extra-%{version}.src tools/clang/tools/extra
489 mv lld-%{version}.src tools/lld
490
491 %patch0 -p1
492 %patch1 -p1
493 %patch2 -p1
494 %patch3 -p1
495 %patch4 -p1
496
497 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
498         s,^#!.*bin/env python,#!%{__python},
499         s,^#!.*bin/env perl,#!%{__perl},
500 }'
501
502 %build
503 install -d build
504
505 # Disabling assertions now, rec. by pure and needed for OpenGTL
506 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
507 cd build
508 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
509
510 %cmake \
511 %ifarch %{x8664}
512         -DLLVM_LIBDIR_SUFFIX:STRING=64 \
513 %endif
514 %ifarch x32
515         -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
516 %endif
517 %if %{with apidocs}
518         -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
519 %endif
520 %if %{with doc}
521         -DLLVM_ENABLE_SPHINX:BOOL=ON \
522         -DSPHINX_WARNINGS_AS_ERRORS=OFF \
523 %endif
524         -DLLVM_ENABLE_PIC:BOOL=ON \
525         -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
526         -DLLVM_ENABLE_CXX1Y:BOOL=ON \
527         -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
528         -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
529         -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
530         -DBUILD_SHARED_LIBS:BOOL=OFF \
531         ../
532
533 %{__make} \
534         VERBOSE=1 \
535         REQUIRES_RTTI=1 \
536         OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
537
538 %if %{with tests}
539 %{__make} check 2>&1 | tee llvm-testlog.txt
540 %{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
541 %endif
542
543 %if %{with doc}
544 %{__make} -C docs docs-llvm-html
545 %{__make} -C docs docs-llvm-man
546 %if %{with ocaml}
547 %{__make} -C docs ocaml_doc
548 %endif
549 %{__make} -C tools/clang/docs docs-clang-html
550 %{__make} -C tools/clang/docs docs-clang-man
551 %{__make} -C tools/lld/docs docs-lld-html
552 %{__make} -C tools/lldb/docs lldb-python-doc
553 %{__make} -C tools/lldb/docs lldb-cpp-doc
554 %{__make} -C ../tools/clang/tools/extra/docs html
555 %endif
556
557 %install
558 rm -rf $RPM_BUILD_ROOT
559 %{__make} -C build install \
560         DESTDIR=$RPM_BUILD_ROOT
561
562 # only some .pyc files are created by make install
563 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
564 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
565
566 # Adjust static analyzer installation
567 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
568 install -d $RPM_BUILD_ROOT%{_libdir}/scan-build
569 %{__mv} $RPM_BUILD_ROOT%{_prefix}/libexec/c??-analyzer $RPM_BUILD_ROOT%{_libdir}/scan-build
570 %{__sed} -i -e 's,/\.\./libexec/,../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
571 %py_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
572 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
573 %py_postclean %{_datadir}/scan-view
574
575 # not installed by cmake buildsystem
576 install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
577
578 %if %{with doc}
579 cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
580 # these tools are not installed
581 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
582 # make links
583 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
584 %endif
585
586 # Move documentation back to build directory
587 %if %{with ocaml}
588 rm -rf ocamldocs
589 %{__mv} $RPM_BUILD_ROOT%{_prefix}/docs/ocaml/html/html ocamldocs
590 %endif
591
592 # and separate the apidoc
593 %if %{with apidocs}
594 rm -rf clang-apidoc
595 cp -a build/tools/clang/docs/html clang-apidoc
596 %endif
597
598 # And prepare Clang documentation
599 rm -rf clang-docs
600 install -d clang-docs
601 for f in LICENSE.TXT NOTES.txt README.txt; do
602         ln tools/clang/$f clang-docs
603 done
604
605 # Get rid of erroneously installed example files.
606 %{__rm} $RPM_BUILD_ROOT%{_libdir}/LLVMHello.so
607 # test?
608 %{__rm} $RPM_BUILD_ROOT%{_bindir}/llvm-c-test
609 # not this OS
610 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
611
612 %clean
613 rm -rf $RPM_BUILD_ROOT
614
615 %post   libs -p /sbin/ldconfig
616 %postun libs -p /sbin/ldconfig
617
618 %post   -n clang -p /sbin/ldconfig
619 %postun -n clang -p /sbin/ldconfig
620
621 %post   -n clang-tools-extra -p /sbin/ldconfig
622 %postun -n clang-tools-extra -p /sbin/ldconfig
623
624 %post   -n lldb -p /sbin/ldconfig
625 %postun -n lldb -p /sbin/ldconfig
626
627 %files
628 %defattr(644,root,root,755)
629 %doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
630 %attr(755,root,root) %{_bindir}/bugpoint
631 %attr(755,root,root) %{_bindir}/llc
632 %attr(755,root,root) %{_bindir}/lli
633 %attr(755,root,root) %{_bindir}/llvm-ar
634 %attr(755,root,root) %{_bindir}/llvm-as
635 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
636 %attr(755,root,root) %{_bindir}/llvm-cov
637 %attr(755,root,root) %{_bindir}/llvm-diff
638 %attr(755,root,root) %{_bindir}/llvm-dis
639 %attr(755,root,root) %{_bindir}/llvm-dsymutil
640 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
641 %attr(755,root,root) %{_bindir}/llvm-extract
642 %attr(755,root,root) %{_bindir}/llvm-lib
643 %attr(755,root,root) %{_bindir}/llvm-link
644 %attr(755,root,root) %{_bindir}/llvm-lto
645 %attr(755,root,root) %{_bindir}/llvm-mc
646 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
647 %attr(755,root,root) %{_bindir}/llvm-nm
648 %attr(755,root,root) %{_bindir}/llvm-objdump
649 %attr(755,root,root) %{_bindir}/llvm-profdata
650 %attr(755,root,root) %{_bindir}/llvm-ranlib
651 %attr(755,root,root) %{_bindir}/llvm-readobj
652 %attr(755,root,root) %{_bindir}/llvm-rtdyld
653 %attr(755,root,root) %{_bindir}/llvm-size
654 %attr(755,root,root) %{_bindir}/llvm-stress
655 %attr(755,root,root) %{_bindir}/llvm-symbolizer
656 %attr(755,root,root) %{_bindir}/llvm-tblgen
657 %attr(755,root,root) %{_bindir}/llvm-cxxdump
658 %attr(755,root,root) %{_bindir}/llvm-pdbdump
659 %attr(755,root,root) %{_bindir}/obj2yaml
660 %attr(755,root,root) %{_bindir}/opt
661 %attr(755,root,root) %{_bindir}/verify-uselistorder
662 %attr(755,root,root) %{_bindir}/yaml2obj
663 %if %{with doc}
664 %{_mandir}/man1/bugpoint.1*
665 %{_mandir}/man1/lit.1*
666 %{_mandir}/man1/llc.1*
667 %{_mandir}/man1/lli.1*
668 %{_mandir}/man1/llvm-ar.1*
669 %{_mandir}/man1/llvm-as.1*
670 %{_mandir}/man1/llvm-bcanalyzer.1*
671 %{_mandir}/man1/llvm-cov.1*
672 %{_mandir}/man1/llvm-diff.1*
673 %{_mandir}/man1/llvm-dis.1*
674 %{_mandir}/man1/llvm-dwarfdump.1*
675 %{_mandir}/man1/llvm-extract.1*
676 %{_mandir}/man1/llvm-link.1*
677 %{_mandir}/man1/llvm-nm.1*
678 %{_mandir}/man1/llvm-profdata.1*
679 %{_mandir}/man1/llvm-ranlib.1*
680 %{_mandir}/man1/llvm-readobj.1*
681 %{_mandir}/man1/llvm-stress.1*
682 %{_mandir}/man1/llvm-symbolizer.1*
683 %{_mandir}/man1/opt.1*
684 %{_mandir}/man1/tblgen.1*
685 %endif
686
687 %files libs
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
690 # non-soname symlink
691 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
692 %attr(755,root,root) %{_libdir}/libLTO.so
693
694 %files devel
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_bindir}/llvm-config
697 %attr(755,root,root) %{_libdir}/libLLVM.so
698 %attr(755,root,root) %{_libdir}/BugpointPasses.so
699 %{_includedir}/llvm
700 %{_includedir}/llvm-c
701 %dir %{_datadir}/llvm
702 %{_datadir}/llvm/cmake
703 %if %{with doc}
704 %{_mandir}/man1/llvm-config.1*
705 %endif
706
707 #%files doc
708 #%defattr(644,root,root,755)
709
710 %if %{with apidocs}
711 %files apidocs
712 %defattr(644,root,root,755)
713 %doc apidoc/*
714 %endif
715
716 %if %{with polly}
717 %files polly
718 %defattr(644,root,root,755)
719 %doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
720 %attr(755,root,root) %{_libdir}/LLVMPolly.so
721
722 %files polly-devel
723 %defattr(644,root,root,755)
724 %{_libdir}/libPolly.a
725 %{_libdir}/libPollyISL.a
726 %{_includedir}/polly
727 %endif
728
729 %files -n clang
730 %defattr(644,root,root,755)
731 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
732 %attr(755,root,root) %{_bindir}/clang
733 %attr(755,root,root) %{_bindir}/clang++
734 %attr(755,root,root) %{_bindir}/clang-%{abi}
735 %attr(755,root,root) %{_bindir}/clang-check
736 %attr(755,root,root) %{_bindir}/clang-cl
737 %attr(755,root,root) %{_bindir}/clang-format
738 %attr(755,root,root) %{_bindir}/git-clang-format
739 %dir %{_libdir}/clang
740 %dir %{_libdir}/clang/%{version}
741 %{_libdir}/clang/%{version}/include
742 %if %{with rt}
743 %ifarch %{ix86} %{x8664}
744 %{_libdir}/clang/%{version}/asan_blacklist.txt
745 %dir %{_libdir}/clang/%{version}/lib
746 %dir %{_libdir}/clang/%{version}/lib/linux
747 %endif
748 %ifarch %{ix86}
749 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.a
750 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.so
751 %endif
752 %ifarch %{x8664}
753 %{_libdir}/clang/%{version}/dfsan_abilist.txt
754 %{_libdir}/clang/%{version}/msan_blacklist.txt
755 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
756 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
757 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
758 %endif
759 %endif
760 %dir %{_datadir}/clang
761 %{_datadir}/clang/clang-format-diff.py
762
763 %files -n clang-libs
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/libclang.so.%{abi}
766
767 %if %{with rt} && %{with multilib}
768 %ifarch %{x8664}
769 %files -n clang-multilib
770 %defattr(644,root,root,755)
771 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.a
772 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.so
773 %endif
774 %endif
775
776 %files -n clang-analyzer
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_bindir}/scan-build
779 %attr(755,root,root) %{_bindir}/scan-view
780 %{_datadir}/scan-build
781 %{_datadir}/scan-view
782 %{_mandir}/man1/scan-build.1*
783 %dir %{_libdir}/scan-build
784 %attr(755,root,root) %{_libdir}/scan-build/c++-analyzer
785 %attr(755,root,root) %{_libdir}/scan-build/ccc-analyzer
786
787 %files -n clang-devel
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/libclang.so
790 %{_libdir}/libclang*.a
791 %{_includedir}/clang
792 %{_includedir}/clang-c
793
794 %files -n clang-doc
795 %defattr(644,root,root,755)
796 %doc tools/clang/docs/*.{html,png,txt}
797
798 %if %{with apidocs}
799 %files -n clang-apidocs
800 %defattr(644,root,root,755)
801 %doc clang-apidoc/*
802 %endif
803
804 %files -n clang-tools-extra
805 %defattr(644,root,root,755)
806 %doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt} tools/clang/tools/extra/docs/_build/html/{*.html,*.js,_static}
807 %attr(755,root,root) %{_bindir}/clang-apply-replacements
808 %attr(755,root,root) %{_bindir}/clang-query
809 %attr(755,root,root) %{_bindir}/clang-rename
810 %attr(755,root,root) %{_bindir}/clang-tidy
811 %attr(755,root,root) %{_bindir}/pp-trace
812
813 %files -n lld
814 %defattr(644,root,root,755)
815 %doc tools/lld/{LICENSE.TXT,README.md}
816 %attr(755,root,root) %{_bindir}/lld
817
818 %files -n lld-devel
819 %defattr(644,root,root,755)
820 %{_libdir}/liblld[ACDEHMRXY]*.a
821 %{_includedir}/lld
822
823 %if %{with lldb}
824 %files -n lldb
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{_bindir}/lldb
827 %attr(755,root,root) %{_bindir}/lldb-%{version}
828 %attr(755,root,root) %{_bindir}/lldb-argdumper
829 %attr(755,root,root) %{_bindir}/lldb-mi
830 %attr(755,root,root) %{_bindir}/lldb-mi-%{version}
831 %attr(755,root,root) %{_bindir}/lldb-server
832 %attr(755,root,root) %{_bindir}/lldb-server-%{version}
833 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
834 %dir %{py_sitedir}/lldb
835 %attr(755,root,root) %{py_sitedir}/lldb/lldb-argdumper
836 %{py_sitedir}/lldb/formatters
837 %{py_sitedir}/lldb/runtime
838 %{py_sitedir}/lldb/utils
839 %{py_sitedir}/lldb/__init__.py[co]
840 %{py_sitedir}/lldb/embedded_interpreter.py[co]
841 %attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
842 %attr(755,root,root) %{py_sitedir}/readline.so
843
844 %files -n lldb-devel
845 %defattr(644,root,root,755)
846 %attr(755,root,root) %{_libdir}/liblldb.so
847 %{_libdir}/liblldb*.a
848 %{_includedir}/lldb
849 %endif
850
851 %if %{with ocaml}
852 %files ocaml
853 %defattr(644,root,root,755)
854 %{_libdir}/ocaml/META.llvm*
855 %attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
856 %{_libdir}/ocaml/llvm*.cma
857 %{_libdir}/ocaml/llvm*.cmi
858
859 %files ocaml-devel
860 %defattr(644,root,root,755)
861 %{_libdir}/ocaml/libllvm*.a
862 %{_libdir}/ocaml/llvm*.a
863 %{_libdir}/ocaml/llvm*.cmx*
864
865 %files ocaml-doc
866 %defattr(644,root,root,755)
867 %doc ocamldocs/*
868 %endif
This page took 0.135973 seconds and 2 git commands to generate.