]> git.pld-linux.org Git - packages/lirc.git/blob - lirc.spec
- rebuild for kernel-3.7.10-4
[packages/lirc.git] / lirc.spec
1 # TODO
2 # - restore lirc_parallel driver
3 # - try to make it use builder_kernel_modules and install_kernel_modules; I couldn't make it
4 # - build is running kernel arch dependent, try to get rid of this
5 # - libcaraca_client (http://caraca.sourceforge.net/) - no releases yet
6 # - create modprobe alias files instead of reminding in post scriptlets
7 #
8 # Conditional build:
9 %bcond_without  dist_kernel     # without sources of distribution kernel
10 %bcond_without  kernel          # don't build kernel modules, only library+programs
11 %bcond_without  userspace       # build only packages with kernel modules
12 %bcond_with     svga            # without svgalib-based utility
13 %bcond_without  x               # without X11-based utilitied
14
15 %if %{without kernel}
16 %undefine       with_dist_kernel
17 %endif
18
19 %if "%{_alt_kernel}" != "%{nil}"
20 %undefine       with_userspace
21 %endif
22
23 %define         pname   lirc
24 %define         rel     82
25
26 #
27 # main package
28 #
29 # lirc_gpio fails to build under kernel >= 2.6.23
30 #
31 %if "%{_kernel_ver}" >= "2.6.23"
32 %if "%{_kernel_ver}" >= "3.0.0"
33 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir"
34 %else
35 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
36 %endif
37 %else
38 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_gpio lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
39 %endif
40 Summary:        Linux Infrared Remote Control daemons
41 Summary(pl.UTF-8):      Serwery do zdalnego sterowania Linuksem za pomocą podczerwieni
42 Name:           %{pname}%{_alt_kernel}
43 Version:        0.9.0
44 Release:        %{rel}
45 License:        GPL v2+
46 Group:          Daemons
47 Source0:        http://downloads.sourceforge.net/lirc/%{pname}-%{version}.tar.bz2
48 # Source0-md5:  b232aef26f23fe33ea8305d276637086
49 Source1:        http://lirc.sourceforge.net/remotes.tar.bz2
50 # Source1-md5:  238d1773d3c405acc02813674f5a55f8
51 Source2:        %{pname}d.sysconfig
52 Source3:        %{pname}d.init
53 Source4:        %{pname}md.init
54 Source5:        %{pname}.tmpfiles
55 Patch0:         %{pname}-opt.patch
56 Patch1:         %{pname}-tmp.patch
57 Patch2:         %{pname}-no-svgalib.patch
58 Patch3:         %{pname}-kernel.patch
59 Patch4:         %{pname}-sparc.patch
60 Patch5:         %{pname}-remotes.patch
61 Patch6:         %{pname}-kernelcc.patch
62 Patch7:         format-security.patch
63 Patch8:         %{pname}-am.patch
64 URL:            http://www.lirc.org/
65 BuildRequires:  alsa-lib-devel
66 BuildRequires:  autoconf >= 2.50
67 BuildRequires:  automake
68 BuildRequires:  iguanaIR-devel
69 BuildRequires:  libftdi-devel >= 0.12
70 BuildRequires:  libirman-devel >= 0.4.5
71 BuildRequires:  libtool
72 BuildRequires:  libusb-compat-devel >= 0.1.0
73 %if %{with kernel}
74 BuildRequires:  kernel%{_alt_kernel}-headers
75 BuildRequires:  kernel%{_alt_kernel}-module-build
76 %endif
77 %{?with_kernel:BuildRequires:   %{kgcc_package}}
78 BuildRequires:  rpm-pythonprov
79 BuildRequires:  rpmbuild(macros) >= 1.379
80 %{?with_svga:BuildRequires:     svgalib-devel}
81 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
82 Requires(post,preun):   /sbin/chkconfig
83 BuildRequires:  rpmbuild(macros) >= 1.268
84 Requires:       %{pname}-libs = %{version}-%{release}
85 Requires:       libftdi >= 0.12
86 Requires:       rc-scripts
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %if %{without userspace}
90 %define         no_spec_install_post_check_tmpfiles     1
91 %endif
92
93 %description
94 LIRC is a package that allows you to decode and send infra-red signals
95 of many (but not all) commonly used remote controls.
96
97 %description -l pl.UTF-8
98 LIRC to program pozwalający na dekodowanie nadchodzących oraz
99 wysyłanie sygnałów w podczerwieni za pomocą wielu (ale nie wszystkich)
100 popularnych urządzeń do zdalnego sterowania.
101
102 %package remotes
103 Summary:        Lirc remotes database
104 Summary(pl.UTF-8):      Baza pilotów obsługiwanych przez lirc
105 Group:          Documentation
106 Requires:       %{pname} = %{version}-%{rel}
107
108 %description remotes
109 This package contains configuration files for many remotes supported
110 by lirc.
111
112 %description remotes -l pl.UTF-8
113 Ten pakiet zawiera pliki konfiguracyjne dla wielu pilotów
114 obsługiwanych przez lirc.
115
116 %package X11
117 Summary:        Linux Infrared Remote Control - X11 utilities
118 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11
119 Group:          X11/Applications
120 Requires:       %{pname}-libs = %{version}-%{release}
121
122 %description X11
123 Linux Infrared Remote Control - X11 utilities.
124
125 %description X11 -l pl.UTF-8
126 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11.
127
128 %package svga
129 Summary:        Linux Infrared Remote Control - svgalib utilities
130 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia svgalib
131 Group:          Applications
132 Requires:       %{pname}-libs = %{version}-%{release}
133
134 %description svga
135 Linux Infrared Remote Control - svgalib-based utilities.
136
137 %description svga -l pl.UTF-8
138 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia oparte
139 na svgalibie.
140
141 %package libs
142 Summary:        LIRC libraries
143 Summary(pl.UTF-8):      Biblioteki LIRC
144 Group:          Libraries
145 Conflicts:      lirc < 0.6.3-3
146 # didn't use /tmp/.lircd
147
148 %description libs
149 This package provides the libraries necessary to run lirc client
150 programs.
151
152 %description libs -l pl.UTF-8
153 Ten pakiet zawiera biblioteki niezbędne do działania klientów LIRC.
154
155 %package devel
156 Summary:        Header files for LIRC development
157 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów z obsługą LIRC
158 Group:          Development/Libraries
159 Requires:       %{pname}-libs = %{version}-%{release}
160
161 %description devel
162 This package provides the files necessary to develop LIRC-based
163 programs.
164
165 %description devel -l pl.UTF-8
166 Ten pakiet zawiera pliki niezbędne do tworzenia programów opartych na
167 LIRC.
168
169 %package static
170 Summary:        Static library for LIRC development
171 Summary(pl.UTF-8):      Biblioteka statyczna LIRC
172 Group:          Development/Libraries
173 Requires:       %{pname}-devel = %{version}-%{release}
174
175 %description static
176 The files necessary for development of statically-linked lirc-based
177 programs.
178
179 %description static -l pl.UTF-8
180 Pliki potrzebne do tworzenia łączonych statycznie programów opartych
181 na LIRC.
182
183 %package -n kernel%{_alt_kernel}-char-lirc-atiusb
184 Summary:        Kernel modules for Linux Infrared Remote Control
185 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
186 Release:        %{rel}@%{_kernel_ver_str}
187 Group:          Base/Kernel
188 %if %{with dist_kernel}
189 %requires_releq_kernel
190 Requires(postun):       %releq_kernel
191 %endif
192 Requires(post,postun):  /sbin/depmod
193 Requires:       %{pname} = %{version}
194 Conflicts:      dev < 2.8.0-3
195
196 %description -n kernel%{_alt_kernel}-char-lirc-atiusb
197 This package contains the kernel modules necessary to operate some
198 infrared remote control devices (such as the ones bundled with TV
199 cards).
200
201 lirc_atiusb module.
202
203 %description -n kernel%{_alt_kernel}-char-lirc-atiusb -l pl.UTF-8
204 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
205 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
206
207 Moduł lirc_atiusb.
208
209 %package -n kernel%{_alt_kernel}-char-lirc-bt829
210 Summary:        Kernel modules for Linux Infrared Remote Control
211 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
212 Release:        %{rel}@%{_kernel_ver_str}
213 Group:          Base/Kernel
214 %if %{with dist_kernel}
215 %requires_releq_kernel
216 Requires(postun):       %releq_kernel
217 %endif
218 Requires(post,postun):  /sbin/depmod
219 Requires:       %{pname} = %{version}
220 Conflicts:      dev < 2.8.0-3
221
222 %description -n kernel%{_alt_kernel}-char-lirc-bt829
223 This package contains the kernel modules necessary to operate some
224 infrared remote control devices (such as the ones bundled with TV
225 cards).
226
227 lirc_bt829 module.
228
229 %description -n kernel%{_alt_kernel}-char-lirc-bt829 -l pl.UTF-8
230 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
231 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
232
233 Moduł lirc_bt829.
234
235 %package -n kernel%{_alt_kernel}-char-lirc-dev
236 Summary:        Kernel modules for Linux Infrared Remote Control
237 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
238 Release:        %{rel}@%{_kernel_ver_str}
239 Group:          Base/Kernel
240 %if %{with dist_kernel}
241 %requires_releq_kernel
242 Requires(postun):       %releq_kernel
243 %endif
244 Requires(post,postun):  /sbin/depmod
245 Requires:       %{pname} = %{version}
246 Obsoletes:      lirc-modules
247 Obsoletes:      lirc-modules-dev
248 Conflicts:      dev < 2.8.0-3
249
250 %description -n kernel%{_alt_kernel}-char-lirc-dev
251 This package contains the kernel modules necessary to operate some
252 infrared remote control devices (such as the ones bundled with TV
253 cards).
254
255 lirc_dev module.
256
257 %description -n kernel%{_alt_kernel}-char-lirc-dev -l pl.UTF-8
258 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
259 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
260
261 Moduł lirc_dev.
262
263 %package -n kernel%{_alt_kernel}-char-lirc-ene0100
264 Summary:        Kernel modules for Linux Infrared Remote Control
265 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
266 Release:        %{rel}@%{_kernel_ver_str}
267 Group:          Base/Kernel
268 %if %{with dist_kernel}
269 %requires_releq_kernel
270 Requires(postun):       %releq_kernel
271 %endif
272 Requires(post,postun):  /sbin/depmod
273 Requires:       %{pname} = %{version}
274 Obsoletes:      lirc-modules
275 Conflicts:      dev < 2.8.0-3
276
277 %description -n kernel%{_alt_kernel}-char-lirc-ene0100
278 This package contains the kernel modules necessary to operate some
279 infrared remote control ene0100ices (such as the ones bundled with TV
280 cards).
281
282 lirc_ene0100 module.
283
284 %description -n kernel%{_alt_kernel}-char-lirc-ene0100 -l pl.UTF-8
285 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
286 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
287
288 Moduł lirc_ene0100.
289
290 %package -n kernel%{_alt_kernel}-char-lirc-gpio
291 Summary:        Kernel modules for Linux Infrared Remote Control
292 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
293 Release:        %{rel}@%{_kernel_ver_str}
294 Group:          Base/Kernel
295 %if %{with dist_kernel}
296 %requires_releq_kernel
297 Requires(postun):       %releq_kernel
298 %endif
299 Requires(post,postun):  /sbin/depmod
300 Requires:       %{pname} = %{version}
301 Obsoletes:      lirc-modules
302 Obsoletes:      lirc-modules-gpio
303 Conflicts:      dev < 2.8.0-3
304
305 %description -n kernel%{_alt_kernel}-char-lirc-gpio
306 This package contains the kernel modules necessary to operate some
307 infrared remote control devices (such as the ones bundled with TV
308 cards).
309
310 lirc_gpio module.
311
312 %description -n kernel%{_alt_kernel}-char-lirc-gpio -l pl.UTF-8
313 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
314 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
315
316 Moduł lirc_gpio.
317
318 %package -n kernel%{_alt_kernel}-char-lirc-i2c
319 Summary:        Kernel modules for Linux Infrared Remote Control
320 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
321 Release:        %{rel}@%{_kernel_ver_str}
322 Group:          Base/Kernel
323 %if %{with dist_kernel}
324 %requires_releq_kernel
325 Requires(postun):       %releq_kernel
326 %endif
327 Requires(post,postun):  /sbin/depmod
328 Requires:       %{pname} = %{version}
329 Obsoletes:      lirc-modules
330 Obsoletes:      lirc-modules-i2c
331 Conflicts:      dev < 2.8.0-3
332
333 %description -n kernel%{_alt_kernel}-char-lirc-i2c
334 This package contains the kernel modules necessary to operate some
335 infrared remote control devices (such as the ones bundled with TV
336 cards).
337
338 lirc_i2c module.
339
340 %description -n kernel%{_alt_kernel}-char-lirc-i2c -l pl.UTF-8
341 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
342 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
343
344 Moduł lirc_i2c.
345
346 %package -n kernel%{_alt_kernel}-char-lirc-igorplugusb
347 Summary:        Kernel modules for Linux Infrared Remote Control
348 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
349 Release:        %{rel}@%{_kernel_ver_str}
350 Group:          Base/Kernel
351 %if %{with dist_kernel}
352 %requires_releq_kernel
353 Requires(postun):       %releq_kernel
354 %endif
355 Requires(post,postun):  /sbin/depmod
356 Requires:       %{pname} = %{version}
357 Obsoletes:      lirc-modules
358 Obsoletes:      lirc-modules-igorplugusb
359 Conflicts:      dev < 2.8.0-3
360
361 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb
362 This package contains the kernel modules necessary to operate some
363 infrared remote control devices (such as the ones bundled with TV
364 cards).
365
366 lirc_igorplugusb module.
367
368 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb -l pl.UTF-8
369 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
370 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
371
372 Moduł lirc_igorplugusb.
373
374 %package -n kernel%{_alt_kernel}-char-lirc-imon
375 Summary:        Kernel modules for Linux Infrared Remote Control
376 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
377 Release:        %{rel}@%{_kernel_ver_str}
378 Group:          Base/Kernel
379 %if %{with dist_kernel}
380 %requires_releq_kernel
381 Requires(postun):       %releq_kernel
382 %endif
383 Requires(post,postun):  /sbin/depmod
384 Requires:       %{pname} = %{version}
385 Obsoletes:      lirc-modules
386 Obsoletes:      lirc-modules-imon
387 Conflicts:      dev < 2.8.0-3
388
389 %description -n kernel%{_alt_kernel}-char-lirc-imon
390 This package contains the kernel modules necessary to operate some
391 infrared remote control devices (such as the ones bundled with TV
392 cards).
393
394 lirc_imon module.
395
396 %description -n kernel%{_alt_kernel}-char-lirc-imon -l pl.UTF-8
397 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
398 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
399
400 Moduł lirc_imon.
401
402 %package -n kernel%{_alt_kernel}-char-lirc-sasem
403 Summary:        Kernel modules for Linux Infrared Remote Control
404 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
405 Release:        %{rel}@%{_kernel_ver_str}
406 Group:          Base/Kernel
407 %if %{with dist_kernel}
408 %requires_releq_kernel
409 Requires(postun):       %releq_kernel
410 %endif
411 Requires(post,postun):  /sbin/depmod
412 Requires:       %{pname} = %{version}
413 Conflicts:      dev < 2.8.0-3
414
415 %description -n kernel%{_alt_kernel}-char-lirc-sasem
416 This package contains the kernel modules necessary to operate some
417 infrared remote control devices (such as the ones bundled with TV
418 cards).
419
420 lirc_sasem module.
421
422 %description -n kernel%{_alt_kernel}-char-lirc-sasem -l pl.UTF-8
423 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
424 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
425
426 Moduł lirc_sasem.
427
428 %package -n kernel%{_alt_kernel}-char-lirc-serial
429 Summary:        Kernel modules for Linux Infrared Remote Control
430 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
431 Release:        %{rel}@%{_kernel_ver_str}
432 Group:          Base/Kernel
433 %if %{with dist_kernel}
434 %requires_releq_kernel
435 Requires(postun):       %releq_kernel
436 %endif
437 Requires(post,postun):  /sbin/depmod
438 Requires:       %{pname} = %{version}
439 %{?with_dist_kernel:Requires:   setserial}
440 Obsoletes:      lirc-modules
441 Obsoletes:      lirc-modules-serial
442 Conflicts:      dev < 2.8.0-3
443
444 %description -n kernel%{_alt_kernel}-char-lirc-serial
445 This package contains the kernel modules necessary to operate some
446 infrared remote control devices (such as the ones bundled with TV
447 cards).
448
449 lirc_serial module for devices connected to serial port.
450
451 %description -n kernel%{_alt_kernel}-char-lirc-serial -l pl.UTF-8
452 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
453 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
454
455 Moduł lirc_serial dla urządzeń podłączanych do portu szeregowego.
456
457 %package -n kernel%{_alt_kernel}-char-lirc-sir
458 Summary:        Kernel modules for Linux Infrared Remote Control
459 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
460 Release:        %{rel}@%{_kernel_ver_str}
461 Group:          Base/Kernel
462 %if %{with dist_kernel}
463 %requires_releq_kernel
464 Requires(postun):       %releq_kernel
465 %endif
466 Requires(post,postun):  /sbin/depmod
467 Requires:       %{pname} = %{version}
468 Obsoletes:      lirc-modules
469 Obsoletes:      lirc-modules-sir
470 Conflicts:      dev < 2.8.0-3
471
472 %description -n kernel%{_alt_kernel}-char-lirc-sir
473 This package contains the kernel modules necessary to operate some
474 infrared remote control devices (such as the ones bundled with TV
475 cards).
476
477 lirc_sir module.
478
479 %description -n kernel%{_alt_kernel}-char-lirc-sir -l pl.UTF-8
480 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
481 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
482
483 Moduł lirc_sir.
484
485 %package -n kernel%{_alt_kernel}-char-lirc-ttusbir
486 Summary:        Kernel modules for Linux Infrared Remote Control
487 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
488 Release:        %{rel}@%{_kernel_ver_str}
489 Group:          Base/Kernel
490 %if %{with dist_kernel}
491 %requires_releq_kernel
492 Requires(postun):       %releq_kernel
493 %endif
494 Requires(post,postun):  /sbin/depmod
495 Requires:       %{pname} = %{version}
496 Obsoletes:      lirc-modules
497 Obsoletes:      lirc-modules-ttusbir
498 Conflicts:      dev < 2.8.0-3
499
500 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir
501 This package contains the kernel modules necessary to operate
502 TechnoTrend USB IR Receiver.
503
504 lirc_ttusbir module.
505
506 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir -l pl.UTF-8
507 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
508 TechnoTrend USB IR Receiver.
509
510 Moduł lirc_ttusbir.
511
512 %package -n kernel%{_alt_kernel}-char-lirc-wpc87691
513 Summary:        Kernel modules for Linux Infrared Remote Control
514 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
515 Release:        %{rel}@%{_kernel_ver_str}
516 Group:          Base/Kernel
517 %if %{with dist_kernel}
518 %requires_releq_kernel
519 Requires(postun):       %releq_kernel
520 %endif
521 Requires(post,postun):  /sbin/depmod
522 Requires:       %{pname} = %{version}
523 Conflicts:      dev < 2.8.0-3
524
525 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691
526 This package contains the kernel modules necessary to operate
527 TechnoTrend USB IR Receiver.
528
529 lirc_wpc87691 module.
530
531 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691 -l pl.UTF-8
532 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
533 TechnoTrend USB IR Receiver.
534
535 Moduł lirc_wpc87691.
536
537 %package -n kernel%{_alt_kernel}-char-lirc-parallel
538 Summary:        Kernel modules for Linux Infrared Remote Control
539 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
540 Release:        %{rel}@%{_kernel_ver_str}
541 Group:          Base/Kernel
542 %if %{with dist_kernel}
543 %requires_releq_kernel
544 Requires(postun):       %releq_kernel
545 %endif
546 Requires(post,postun):  /sbin/depmod
547 Requires:       %{pname} = %{version}
548 Obsoletes:      lirc-modules
549 Obsoletes:      lirc-modules-parallel
550 Conflicts:      dev < 2.8.0-3
551
552 %description -n kernel%{_alt_kernel}-char-lirc-parallel
553 This package contains the kernel modules necessary to operate some
554 infrared remote control devices (such as the ones bundled with TV
555 cards).
556
557 lirc-parallel module for devices connected to parallel port.
558
559 %description -n kernel%{_alt_kernel}-char-lirc-parallel -l pl.UTF-8
560 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
561 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
562
563 Moduł lirc_parallel dla urządzeń podłączanych do portu równoległego.
564
565 %prep
566 %setup -q -n %{pname}-%{version} -a 1
567 %patch0 -p1
568 %patch1 -p1
569 %if !%{with svga}
570 %patch2 -p1
571 %endif
572 %patch3 -p1
573 %patch4 -p1
574 %patch5 -p1
575 %patch6 -p1
576 %patch7 -p1
577 %patch8 -p1
578
579 %build
580 echo '#' > drivers/Makefile.am
581 %{__libtoolize}
582 %{__aclocal}
583 %{__automake}
584 %{__autoheader}
585 %{__autoconf}
586
587 %configure \
588         ac_cv_header_portaudio_h=no \
589 %if %{with kernel}
590         KERNELCC="%{kgcc}" \
591 %else
592         ac_cv_have_kernel="no_kernel=yes" \
593 %endif
594         --with-kerneldir=%{_kernelsrcdir} \
595         %{?with_x:--with-x} \
596         --with-port=0x2f8 \
597         --with-irq=3 \
598         --without-soft-carrier \
599         --with-driver=userspace \
600         --with-igor
601
602 %if %{with userspace}
603 %{__make} -j1
604 %endif
605
606 %if %{with kernel}
607 cd drivers
608
609 drivers=%{drivers}
610
611 for drv in $drivers; do
612         cd $drv
613         %{__make} clean \
614                 LIRC_DEVDIR=`pwd` \
615                 RCS_FIND_IGNORE="-name '*.ko' -o" \
616                 %{?with_verbose:V=1}
617
618         %{__make} -j1 \
619                 LIRC_DEVDIR=`pwd` \
620                 CONSTIFY_PLUGIN="" \
621                 KBUILD_MODPOST_WARN=1 \
622                 %{?with_verbose:V=1}
623         cd ..
624 done
625
626 cd ..
627
628 %endif
629
630 %install
631 rm -rf $RPM_BUILD_ROOT
632
633 %if %{with kernel}
634 drivers=%{drivers}
635 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
636 for drv in $drivers; do
637         %install_kernel_modules -m drivers/$drv/$drv -d misc
638 done
639 %endif
640
641 %if %{with userspace}
642 install -d $RPM_BUILD_ROOT{%{_bindir},%{_aclocaldir},/dev,/var/{log,run/lirc}} \
643         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,lirc} \
644         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
645
646 %{__make} -j1 install \
647         DESTDIR=$RPM_BUILD_ROOT \
648         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
649
650 cat>$RPM_BUILD_ROOT%{_sysconfdir}/lirc/lircd.conf<<END
651 #
652 # This is a placeholder for your configuration file.
653 # See %{_docdir}/%{pname}-%{version}/remotes for some examples.
654 #
655 END
656 cp -f $RPM_BUILD_ROOT%{_sysconfdir}/lirc/lirc{,m}d.conf
657 cp -p contrib/*.m4 $RPM_BUILD_ROOT%{_aclocaldir}
658 :> $RPM_BUILD_ROOT/var/log/lircd
659
660 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lircd
661 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircd
662 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircmd
663 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
664 %endif
665
666 %clean
667 rm -rf $RPM_BUILD_ROOT
668
669 %post   libs -p /sbin/ldconfig
670 %postun libs -p /sbin/ldconfig
671
672 %post
673 /sbin/chkconfig --add lircd
674 /sbin/chkconfig --add lircmd
675 %service lircd restart
676 %service lircmd restart
677
678 echo "If you are using a kernel-module-based driver, don't forget to"
679 echo "install the kernel%{_alt_kernel}-char-lirc-<your_driver> package."
680
681 %preun
682 if [ "$1" = "0" ]; then
683         %service lircd stop
684         %service lircmd stop
685         /sbin/chkconfig --del lircd
686         /sbin/chkconfig --del lircmd
687 fi
688
689 %triggerpostun -- %{name} < 0.8.6-8
690 if [ -f %{_sysconfdir}/lircd.conf.rpmsave ]; then
691         mv -f %{_sysconfdir}/lircd.conf.rpmsave %{_sysconfdir}/lirc/lircd.conf
692 fi
693 if [ -f %{_sysconfdir}/lircmd.conf.rpmsave ]; then
694         mv -f %{_sysconfdir}/lircmd.conf.rpmsave %{_sysconfdir}/lirc/lircmd.conf
695 fi
696
697 %post   -n kernel%{_alt_kernel}-char-lirc-atiusb
698 %depmod %{_kernel_ver}
699 if [ "$1" = "1" ]; then
700         echo "Don't forget to add an 'alias lirc lirc_atiusb' to modprobe config"
701 fi
702
703 %postun -n kernel%{_alt_kernel}-char-lirc-atiusb
704 %depmod %{_kernel_ver}
705
706 %post   -n kernel%{_alt_kernel}-char-lirc-bt829
707 %depmod %{_kernel_ver}
708 if [ "$1" = "1" ]; then
709         echo "Don't forget to add an 'alias lirc lirc_bt829' to modprobe config"
710 fi
711
712 %postun -n kernel%{_alt_kernel}-char-lirc-bt829
713 %depmod %{_kernel_ver}
714
715 %post   -n kernel%{_alt_kernel}-char-lirc-dev
716 %depmod %{_kernel_ver}
717
718 %postun -n kernel%{_alt_kernel}-char-lirc-dev
719 %depmod %{_kernel_ver}
720
721 %post   -n kernel%{_alt_kernel}-char-lirc-ene0100
722 %depmod %{_kernel_ver}
723
724 %postun -n kernel%{_alt_kernel}-char-lirc-ene0100
725 %depmod %{_kernel_ver}
726
727 %post   -n kernel%{_alt_kernel}-char-lirc-gpio
728 %depmod %{_kernel_ver}
729 if [ "$1" = "1" ]; then
730         echo "Don't forget to add an 'alias lirc lirc_gpio' to modprobe config"
731 fi
732
733 %postun -n kernel%{_alt_kernel}-char-lirc-gpio
734 %depmod %{_kernel_ver}
735
736 %post   -n kernel%{_alt_kernel}-char-lirc-i2c
737 %depmod %{_kernel_ver}
738 if [ "$1" = "1" ]; then
739         echo "Don't forget to add an 'alias lirc lirc_i2c' to modprobe config"
740 fi
741
742 %postun -n kernel%{_alt_kernel}-char-lirc-i2c
743 %depmod %{_kernel_ver}
744
745 %post   -n kernel%{_alt_kernel}-char-lirc-igorplugusb
746 %depmod %{_kernel_ver}
747 if [ "$1" = "1" ]; then
748         echo "Don't forget to add an 'alias lirc lirc_igorplugusb' to modprobe config"
749 fi
750
751 %postun -n kernel%{_alt_kernel}-char-lirc-igorplugusb
752 %depmod %{_kernel_ver}
753
754 %post   -n kernel%{_alt_kernel}-char-lirc-imon
755 %depmod %{_kernel_ver}
756 if [ "$1" = "1" ]; then
757         echo "Don't forget to add an 'alias lirc lirc_imon' to modprobe config"
758 fi
759
760 %postun -n kernel%{_alt_kernel}-char-lirc-imon
761 %depmod %{_kernel_ver}
762
763 %post   -n kernel%{_alt_kernel}-char-lirc-sasem
764 %depmod %{_kernel_ver}
765 if [ "$1" = "1" ]; then
766         echo "Don't forget to add an 'alias lirc lirc_sasem' to modprobe config"
767 fi
768
769 %postun -n kernel%{_alt_kernel}-char-lirc-sasem
770 %depmod %{_kernel_ver}
771
772 %post   -n kernel%{_alt_kernel}-char-lirc-serial
773 %depmod %{_kernel_ver}
774 if [ "$1" = "1" ]; then
775         echo "Don't forget to add an 'alias lirc lirc_serial' to modprobe config"
776 fi
777
778 %postun -n kernel%{_alt_kernel}-char-lirc-serial
779 %depmod %{_kernel_ver}
780
781 %post   -n kernel%{_alt_kernel}-char-lirc-parallel
782 %depmod %{_kernel_ver}
783 if [ "$1" = "1" ]; then
784         echo "Don't forget to add an 'alias lirc lirc_parallel' modprobe config"
785 fi
786
787 %postun -n kernel%{_alt_kernel}-char-lirc-parallel
788 %depmod %{_kernel_ver}
789
790 %post   -n kernel%{_alt_kernel}-char-lirc-sir
791 %depmod %{_kernel_ver}
792 if [ "$1" = "1" ]; then
793         echo "Don't forget to add an 'alias lirc lirc_sir' to modprobe config"
794 fi
795
796 %postun -n kernel%{_alt_kernel}-char-lirc-sir
797 %depmod %{_kernel_ver}
798
799 %post   -n kernel%{_alt_kernel}-char-lirc-ttusbir
800 %depmod %{_kernel_ver}
801 if [ "$1" = "1" ]; then
802         echo "Don't forget to add an 'alias lirc lirc_ttusbir' to modprobe config"
803 fi
804
805 %postun -n kernel%{_alt_kernel}-char-lirc-ttusbir
806 %depmod %{_kernel_ver}
807
808 %post   -n kernel%{_alt_kernel}-char-lirc-wpc87691
809 %depmod %{_kernel_ver}
810 if [ "$1" = "1" ]; then
811         echo "Don't forget to add an 'alias lirc lirc_wpc87691' to modprobe config"
812 fi
813
814 %postun -n kernel%{_alt_kernel}-char-lirc-wpc87691
815 %depmod %{_kernel_ver}
816
817 %if %{with userspace}
818 %files
819 %defattr(644,root,root,755)
820 %doc ANNOUNCE AUTHORS NEWS README TODO ChangeLog
821 %doc contrib/lircrc doc/{html,images,lirc.css}
822 %attr(755,root,root) %{_bindir}/ircat
823 %attr(755,root,root) %{_bindir}/irexec
824 %attr(755,root,root) %{_bindir}/irpty
825 %attr(755,root,root) %{_bindir}/irrecord
826 %attr(755,root,root) %{_bindir}/irsend
827 %attr(755,root,root) %{_bindir}/irw
828 %attr(755,root,root) %{_bindir}/mode2
829 %attr(755,root,root) %{_bindir}/lircrcd
830 %attr(755,root,root) %{_bindir}/pronto2lirc
831 %attr(755,root,root) %{_sbindir}/lircd
832 %attr(755,root,root) %{_sbindir}/lircmd
833 %attr(754,root,root) /etc/rc.d/init.d/lircd
834 %attr(754,root,root) /etc/rc.d/init.d/lircmd
835 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lircd
836 %dir %{_sysconfdir}/lirc
837 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircd.conf
838 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircmd.conf
839 %{_mandir}/man1/ircat.1*
840 %{_mandir}/man1/irexec.1*
841 %{_mandir}/man1/irpty.1*
842 %{_mandir}/man1/irrecord.1*
843 %{_mandir}/man1/irsend.1*
844 %{_mandir}/man1/irw.1*
845 %{_mandir}/man1/lircrcd.1*
846 %{_mandir}/man1/mode2.1*
847 %{_mandir}/man8/lircd.8*
848 %{_mandir}/man8/lircmd.8*
849 %attr(600,root,root) %ghost /var/log/lircd
850 %dir /var/run/lirc
851 %{systemdtmpfilesdir}/%{name}.conf
852
853 %files remotes
854 %defattr(644,root,root,755)
855 # XXX: are jpegs in docs (remotes) a good idea?
856 %doc remotes
857
858 %if %{with x}
859 %files X11
860 %defattr(644,root,root,755)
861 %doc doc/irxevent.keys
862 %attr(755,root,root) %{_bindir}/irxevent
863 %attr(755,root,root) %{_bindir}/xmode2
864 %{_mandir}/man1/irxevent.1*
865 %{_mandir}/man1/xmode2.1*
866 %endif
867
868 %if %{with svga}
869 %files svga
870 %defattr(644,root,root,755)
871 %attr(755,root,root) %{_bindir}/smode2
872 %{_mandir}/man1/smode2.1*
873 %endif
874
875 %files libs
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_libdir}/liblirc_client.so.*.*.*
878 %attr(755,root,root) %ghost %{_libdir}/liblirc_client.so.0
879
880 %files devel
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/liblirc_client.so
883 %{_libdir}/liblirc_client.la
884 %{_includedir}/lirc
885 %{_aclocaldir}/lirc.m4
886
887 %files static
888 %defattr(644,root,root,755)
889 %{_libdir}/liblirc_client.a
890 %endif
891
892 %if %{with kernel}
893 %files -n kernel%{_alt_kernel}-char-lirc-atiusb
894 %defattr(644,root,root,755)
895 /lib/modules/%{_kernel_ver}/misc/lirc_atiusb.ko*
896
897 %files -n kernel%{_alt_kernel}-char-lirc-bt829
898 %defattr(644,root,root,755)
899 /lib/modules/%{_kernel_ver}/misc/lirc_bt829.ko*
900
901 %files -n kernel%{_alt_kernel}-char-lirc-dev
902 %defattr(644,root,root,755)
903 /lib/modules/%{_kernel_ver}/misc/lirc_dev.ko*
904
905 %if "%{_kernel_ver}" < "3.0.0"
906 %files -n kernel%{_alt_kernel}-char-lirc-ene0100
907 %defattr(644,root,root,755)
908 /lib/modules/%{_kernel_ver}/misc/lirc_ene0100.ko*
909 %endif
910
911 %if "%{_kernel_ver}" < "2.6.23"
912 %files -n kernel%{_alt_kernel}-char-lirc-gpio
913 %defattr(644,root,root,755)
914 /lib/modules/%{_kernel_ver}/misc/lirc_gpio.ko*
915 %endif
916
917 %files -n kernel%{_alt_kernel}-char-lirc-i2c
918 %defattr(644,root,root,755)
919 /lib/modules/%{_kernel_ver}/misc/lirc_i2c.ko*
920
921 %files -n kernel%{_alt_kernel}-char-lirc-igorplugusb
922 %defattr(644,root,root,755)
923 /lib/modules/%{_kernel_ver}/misc/lirc_igorplugusb.ko*
924
925 %files -n kernel%{_alt_kernel}-char-lirc-imon
926 %defattr(644,root,root,755)
927 /lib/modules/%{_kernel_ver}/misc/lirc_imon.ko*
928
929 %files -n kernel%{_alt_kernel}-char-lirc-sasem
930 %defattr(644,root,root,755)
931 /lib/modules/%{_kernel_ver}/misc/lirc_sasem.ko*
932
933 %files -n kernel%{_alt_kernel}-char-lirc-serial
934 %defattr(644,root,root,755)
935 /lib/modules/%{_kernel_ver}/misc/lirc_serial.ko*
936
937 %files -n kernel%{_alt_kernel}-char-lirc-sir
938 %defattr(644,root,root,755)
939 /lib/modules/%{_kernel_ver}/misc/lirc_sir.ko*
940
941 %files -n kernel%{_alt_kernel}-char-lirc-ttusbir
942 %defattr(644,root,root,755)
943 /lib/modules/%{_kernel_ver}/misc/lirc_ttusbir.ko*
944
945 %if "%{_kernel_ver}" < "3.0.0"
946 %files -n kernel%{_alt_kernel}-char-lirc-wpc87691
947 %defattr(644,root,root,755)
948 /lib/modules/%{_kernel_ver}/misc/lirc_wpc8769l.ko*
949 %endif
950
951 %files -n kernel%{_alt_kernel}-char-lirc-parallel
952 %defattr(644,root,root,755)
953 /lib/modules/%{_kernel_ver}/misc/lirc_parallel.ko*
954 %endif
This page took 0.217792 seconds and 3 git commands to generate.