]> git.pld-linux.org Git - packages/libvirt.git/commitdiff
- rel 2 auto/th/libvirt-0_9_11-2
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 23 Apr 2012 18:21:52 +0000 (18:21 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix regression in virURIParse

Changed files:
    libvirt-uri-user.patch -> 1.1
    libvirt.spec -> 1.81

libvirt-uri-user.patch [new file with mode: 0644]
libvirt.spec

diff --git a/libvirt-uri-user.patch b/libvirt-uri-user.patch
new file mode 100644 (file)
index 0000000..fe09b24
--- /dev/null
@@ -0,0 +1,98 @@
+From 4eb1c2560d1ab8bae620788d343e9e7b32ddc066 Mon Sep 17 00:00:00 2001
+From: =?utf8?q?Guido=20G=C3=BCnther?= <agx@sigxcpu.org>
+Date: Thu, 5 Apr 2012 17:52:42 +0200
+Subject: [PATCH] virURIParse: don't forget to copy the user part
+
+This got dropped with 300e60e15b22387dda41ed5985a9ebadfd86dd25
+
+Cheers,
+ -- Guido
+---
+ src/util/viruri.c  |    5 ++++-
+ tests/viruritest.c |   24 +++++++++++++-----------
+ 2 files changed, 17 insertions(+), 12 deletions(-)
+
+diff --git a/src/util/viruri.c b/src/util/viruri.c
+index 2c6de51..a41f345 100644
+--- a/src/util/viruri.c
++++ b/src/util/viruri.c
+@@ -185,7 +185,9 @@ virURIParse(const char *uri)
+     if (xmluri->fragment &&
+         !(ret->fragment = strdup(xmluri->fragment)))
+         goto no_memory;
+-
++    if (xmluri->user &&
++        !(ret->user = strdup(xmluri->user)))
++        goto no_memory;
+     /* First check: does it even make sense to jump inside */
+     if (ret->server != NULL &&
+@@ -249,6 +251,7 @@ virURIFormat(virURIPtr uri)
+     xmluri.query = uri->query;
+ #endif
+     xmluri.fragment = uri->fragment;
++    xmluri.user = uri->user;
+     /* First check: does it make sense to do anything */
+     if (xmluri.server != NULL &&
+diff --git a/tests/viruritest.c b/tests/viruritest.c
+index 3570217..4bb6a03 100644
+--- a/tests/viruritest.c
++++ b/tests/viruritest.c
+@@ -42,6 +42,7 @@ struct URIParseData {
+     const char *path;
+     const char *query;
+     const char *fragment;
++    const char *user;
+     virURIParamPtr params;
+ };
+@@ -143,33 +144,34 @@ mymain(void)
+     signal(SIGPIPE, SIG_IGN);
+ #define TEST_FULL(uri, uri_out, scheme, server, port, path, query,      \
+-                  fragment, params)                                     \
++                  fragment, user, params)                               \
+     do  {                                                               \
+         const struct URIParseData data = {                              \
+             uri, (uri_out) ? (uri_out) : (uri), scheme, server, port,   \
+-            path, query, fragment, params                               \
++            path, query, fragment, user, params                         \
+         };                                                              \
+         if (virtTestRun("Test URI " # uri,  1, testURIParse, &data) < 0) \
+             ret = -1;                                                   \
+     } while (0)
+-#define TEST_PARSE(uri, scheme, server, port, path, query, fragment, params) \
+-    TEST_FULL(uri, NULL, scheme, server, port, path, query, fragment, params)
++#define TEST_PARSE(uri, scheme, server, port, path, query, fragment, user, params) \
++    TEST_FULL(uri, NULL, scheme, server, port, path, query, fragment, user, params)
+ #define TEST_PARAMS(query_in, query_out, params)                        \
+     TEST_FULL("test://example.com/?" query_in,                          \
+               *query_out ? "test://example.com/?" query_out : NULL,     \
+-              "test", "example.com", 0, "/", query_in, NULL, params)
++              "test", "example.com", 0, "/", query_in, NULL, NULL, params)
+     virURIParam params[] = {
+         { (char*)"name", (char*)"value" },
+         { NULL, NULL },
+     };
+-    TEST_PARSE("test://example.com", "test", "example.com", 0, NULL, NULL, NULL, NULL);
+-    TEST_PARSE("test://example.com:123", "test", "example.com", 123, NULL, NULL, NULL, NULL);
+-    TEST_PARSE("test://example.com:123/system?name=value#foo", "test", "example.com", 123, "/system", "name=value", "foo", params);
+-    TEST_PARSE("test://127.0.0.1:123/system", "test", "127.0.0.1", 123, "/system", NULL, NULL, NULL);
+-    TEST_PARSE("test://[::1]:123/system", "test", "::1", 123, "/system", NULL, NULL, NULL);
+-    TEST_PARSE("test://[2001:41c8:1:4fd4::2]:123/system", "test", "2001:41c8:1:4fd4::2", 123, "/system", NULL, NULL, NULL);
++    TEST_PARSE("test://example.com", "test", "example.com", 0, NULL, NULL, NULL, NULL, NULL);
++    TEST_PARSE("test://foo@example.com", "test", "example.com", 0, NULL, NULL, NULL, "foo", NULL);
++    TEST_PARSE("test://example.com:123", "test", "example.com", 123, NULL, NULL, NULL, NULL, NULL);
++    TEST_PARSE("test://example.com:123/system?name=value#foo", "test", "example.com", 123, "/system", "name=value", "foo", NULL, params);
++    TEST_PARSE("test://127.0.0.1:123/system", "test", "127.0.0.1", 123, "/system", NULL, NULL, NULL, NULL);
++    TEST_PARSE("test://[::1]:123/system", "test", "::1", 123, "/system", NULL, NULL, NULL, NULL);
++    TEST_PARSE("test://[2001:41c8:1:4fd4::2]:123/system", "test", "2001:41c8:1:4fd4::2", 123, "/system", NULL, NULL, NULL, NULL);
+     virURIParam params1[] = {
+         { (char*)"foo", (char*)"one" },
+-- 
+1.7.1
+
index f9e26096d96e9dbadbfbb6e00ede72c919a6dfc7..9c56abe75f11f881e03d4d15700ae371e06d3675 100644 (file)
@@ -28,7 +28,7 @@ Summary:      Toolkit to interact with virtualization capabilities
 Summary(pl.UTF-8):     Narzędzia współpracujące z funkcjami wirtualizacji
 Name:          libvirt
 Version:       0.9.11
-Release:       1
+Release:       2
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       ftp://ftp.libvirt.org/libvirt/%{name}-%{version}.tar.gz
@@ -41,6 +41,7 @@ Patch2:               %{name}-qemu-acl.patch
 Patch3:                %{name}-xend.patch
 Patch4:                lxc-without-selinux.patch
 Patch5:                %{name}-driver-modules.patch
+Patch6:                %{name}-uri-user.patch
 URL:           http://www.libvirt.org/
 BuildRequires: audit-libs-devel
 BuildRequires: augeas-devel
@@ -492,6 +493,7 @@ biblioteki libvirt.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 # weird translations
 %{__rm} po/{my,eu_ES}.{po,gmo}
This page took 0.915523 seconds and 4 git commands to generate.