]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/commitdiff
- updated for 0.15.0 auto/th/libtorrent-rasterbar-0_15_0-1 auto/ti/libtorrent-rasterbar-0_15_0-1
authorlisu <lisu@pld-linux.org>
Mon, 22 Mar 2010 09:15:32 +0000 (09:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bashizm.patch -> 1.2

bashizm.patch

index 6c2f60a688bac71489373c455fe4ad8061191abb..5b5b506f959c34b4f05610aa310c6e8b7a574817 100644 (file)
@@ -1,94 +1,90 @@
---- libtorrent-rasterbar-0.14.6/configure.in.wiget     2009-11-14 13:39:06.000000000 +0100
-+++ libtorrent-rasterbar-0.14.6/configure.in   2009-11-14 13:44:58.000000000 +0100
-@@ -185,7 +185,7 @@ AC_ARG_WITH(
+--- libtorrent-rasterbar-0.15.0/configure.ac~  2010-02-08 06:18:10.000000000 +0100
++++ libtorrent-rasterbar-0.15.0/configure.ac   2010-03-22 09:59:00.075165939 +0100
+@@ -390,7 +390,7 @@
+   ["yes"|"default"], [
+       AC_MSG_RESULT([yes])
+       AC_DEFINE([TORRENT_LOGGING],[1],[Define to enable logging of the session events.])
+-      COMPILETIME_OPTIONS+="-DTORRENT_LOGGING "
++      COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_LOGGING "
+     ],
+   ["no"|"none"], [
+       AC_MSG_RESULT([no])
+@@ -398,12 +398,12 @@
+   ["verbose"], [
+       AC_MSG_RESULT([verbose])
+       AC_DEFINE([TORRENT_VERBOSE_LOGGING],[1],[Define to enable logging of the session events and every peer connection.])
+-      COMPILETIME_OPTIONS+="-DTORRENT_VERBOSE_LOGGING "
++      COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_VERBOSE_LOGGING "
+     ],
+   ["errors"], [
+       AC_MSG_RESULT([errors])
+       AC_DEFINE([TORRENT_ERROR_LOGGING],[1],[Define to enable logging of the session events and every peer connection limited to errors.])
+-      COMPILETIME_OPTIONS+="-DTORRENT_ERROR_LOGGING "
++      COMPILETIME_OPTIONS+="${COMPILETIME_OPTIONS} -DTORRENT_ERROR_LOGGING "
+     ],
+   [AC_MSG_RESULT([$ARG_ENABLE_LOGGING])
+    AC_MSG_ERROR([Unknown option "$ARG_ENABLE_LOGGING". Use either "yes", "no", "verbose" or "errors".])]
+@@ -446,7 +446,7 @@
+       AX_CHECK_OPENSSL([
+           AC_DEFINE([TORRENT_USE_OPENSSL],[1],[Define to use OpenSSL support.])
+-          COMPILETIME_OPTIONS+="-DTORRENT_USE_OPENSSL "
++          COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_USE_OPENSSL "
+         ], [
+           AC_MSG_ERROR([OpenSSL library not found. Try using --with-openssl=DIR or disabling encryption at all.])
+       ])
+@@ -454,7 +454,7 @@
+   ["no"|"off"], [
+       AC_MSG_RESULT([no])
+       AC_DEFINE([TORRENT_DISABLE_ENCRYPTION],[1],[Define to disable any encryption support and avoid linking against OpenSSL.])
+-      COMPILETIME_OPTIONS+="-DTORRENT_DISABLE_ENCRYPTION "
++      COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_DISABLE_ENCRYPTION "
+     ],
+   [AC_MSG_RESULT([$ARG_ENABLE_ENCRYPTION])
+    AC_MSG_ERROR([Unknown option "$ARG_ENABLE_ENCRYPTION". Use either "yes" or "no".])]
+@@ -468,7 +468,7 @@
+   ["no"], [
+     AC_MSG_RESULT([no])
+     AC_DEFINE([TORRENT_DISABLE_GEO_IP],[1],[Define to disable the GeoIP support and avoid linking against LGPLed code.])
+-    COMPILETIME_OPTIONS+="-DTORRENT_DISABLE_GEO_IP "
++    COMPILETIME_OPTIONS+="${COMPILETIME_OPTIONS} -DTORRENT_DISABLE_GEO_IP "
+    ],
+   [AC_MSG_RESULT([$ARG_ENABLE_GEOIP])
+    AC_MSG_ERROR([Unknown option "$ARG_ENABLE_GEOIP". Use either "yes" or "no".])]
+@@ -482,12 +482,12 @@
+   ["no"|"off"], [
+       AC_MSG_RESULT([no])
+       AC_DEFINE([TORRENT_DISABLE_DHT],[1],[Define to disable the DHT support.])
+-      COMPILETIME_OPTIONS+="-DTORRENT_DISABLE_DHT "
++      COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_DISABLE_DHT "
+     ],
+   ["logging"], [
+       AC_MSG_RESULT([logging])
+       AC_DEFINE([TORRENT_DHT_VERBOSE_LOGGING],[1],[Define to enable DHT support with verbose logging.])
+-      COMPILETIME_OPTIONS+="-DTORRENT_DHT_VERBOSE_LOGGING "
++      COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_DHT_VERBOSE_LOGGING "
+     ],
+   [AC_MSG_RESULT([$ARG_ENABLE_DHT])
+    AC_MSG_ERROR([Unknown option "$ARG_ENABLE_DHT". Use either "yes", "no" or "logging".])]
+@@ -627,10 +627,10 @@
  # this works around a bug in asio in boost-1.39
  # see: https://svn.boost.org/trac/boost/ticket/3095
- AC_DEFINE(BOOST_ASIO_HASH_MAP_BUCKETS,1021,)
+ AC_DEFINE([BOOST_ASIO_HASH_MAP_BUCKETS],[1021],[Define to fix a wrong behavior in boost 1.39.])
 -COMPILETIME_OPTIONS+="-DBOOST_ASIO_HASH_MAP_BUCKETS=1021 "
 +COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DBOOST_ASIO_HASH_MAP_BUCKETS=1021 "
  
- dnl Check the value for the --with-logging switch
- AC_MSG_CHECKING([what form of logging to use])
-@@ -196,12 +196,12 @@ case "$logging" in
-       "default")
-               AC_MSG_RESULT(default)
-               AC_DEFINE(TORRENT_LOGGING,,[define to use some logging])
--              COMPILETIME_OPTIONS+="-DTORRENT_LOGGING "
-+              COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_LOGGING "
-               ;;
-       "verbose")
-               AC_MSG_RESULT(verbose)
-               AC_DEFINE(TORRENT_VERBOSE_LOGGING,,[define to use verbose logging])
--              COMPILETIME_OPTIONS+="-DTORRENT_VERBOSE_LOGGING "
-+              COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_VERBOSE_LOGGING "
-               ;;
-       *)
-               AC_MSG_RESULT()
-@@ -225,12 +225,12 @@ case "$dht" in
-       "off")
-               AC_MSG_RESULT(off)
-               AC_DEFINE(TORRENT_DISABLE_DHT,,[define not to use DHT support])
--              COMPILETIME_OPTIONS+="-DTORRENT_DISABLE_DHT "
-+              COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_DISABLE_DHT "
-               ;;
-       "logging")
-               AC_MSG_RESULT(logging)
-               AC_DEFINE(TORRENT_DHT_VERBOSE_LOGGING,,[define to use DHT support with extra logging])
--              COMPILETIME_OPTIONS+="-DTORRENT_DHT_VERBOSE_LOGGING "
-+              COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_DHT_VERBOSE_LOGGING "
-               ;;
-       *)
-               AC_MSG_RESULT()
-@@ -254,13 +254,13 @@ case "$encryption" in
-                AC_MSG_RESULT(on)
-                CHECK_SSL()
-                AC_DEFINE(TORRENT_USE_OPENSSL,,[define to use openssl with libtorrent-rasterbar])
--               COMPILETIME_OPTIONS+="-DTORRENT_USE_OPENSSL "
-+               COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_USE_OPENSSL "
+ AC_DEFINE([BOOST_EXCEPTION_DISABLE],[1],[Define to disable the boost.exception features.])
+-COMPILETIME_OPTIONS+="-DBOOST_EXCEPTION_DISABLE "
++COMPILETIME_OPTIONS+="${COMPILETIME_OPTIONS} -DBOOST_EXCEPTION_DISABLE "
  
-                ;;
-        "off")
-                AC_MSG_RESULT(off)
-                AC_DEFINE(TORRENT_DISABLE_ENCRYPTION,,[define not to use encryption support])
--               COMPILETIME_OPTIONS+="-DTORRENT_DISABLE_ENCRYPTION "
-+               COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_DISABLE_ENCRYPTION "
-                ;;
-        *)
-                AC_MSG_RESULT()
-@@ -476,11 +476,11 @@ esac
+ dnl Use possibly specific python install params
+ AC_ARG_VAR([PYTHON_INSTALL_PARAMS], [Set specific install parameters for python bindings.])
+@@ -640,7 +640,7 @@
  dnl Set some defines if we are building a shared library
- if [[ "x$enable_shared" == "xyes" ]]; then
-       AC_DEFINE(TORRENT_BUILDING_SHARED,,[Make sure the functions and classes are exported.])
--      COMPILETIME_OPTIONS+="-DTORRENT_LINKING_SHARED "
-+      COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_LINKING_SHARED "
- fi
- AC_DEFINE(BOOST_EXCEPTION_DISABLE,,[We do not need boost.exception features])
--COMPILETIME_OPTIONS+="-DBOOST_EXCEPTION_DISABLE "
-+COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DBOOST_EXCEPTION_DISABLE "
+ AS_IF([test "x$enable_shared" = "xyes"],
+       [AC_DEFINE([TORRENT_BUILDING_SHARED],[1],[Define to exports functions and classes with default visibility in GCC.])
+-       COMPILETIME_OPTIONS+="-DTORRENT_LINKING_SHARED "])
++       COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_LINKING_SHARED "])
  
- dnl want some debugging symbols with that?
- AC_ARG_ENABLE(
-@@ -490,11 +490,11 @@ AC_ARG_ENABLE(
-               no)
-                       AC_DEFINE(NDEBUG,,[Define to disable debugging])
-                       DEBUGFLAGS="-Os"
--#                     COMPILETIME_OPTIONS+="-DNDEBUG "
-+#                     COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DNDEBUG "
-                       ;;
-               yes)
-                       DEBUGFLAGS="-g"
--                      COMPILETIME_OPTIONS+="-DTORRENT_DEBUG "
-+                      COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DTORRENT_DEBUG "
-                       AC_DEFINE(TORRENT_DEBUG,,[Define to enable libtorrent debug build])
-                       ;;
-               *)
-@@ -504,7 +504,7 @@ AC_ARG_ENABLE(
-       esac],
-       [DEBUGFLAGS="-Os"
-       AC_DEFINE(NDEBUG,,[Define to disable debugging])
--#     COMPILETIME_OPTIONS+="-DNDEBUG "
-+#     COMPILETIME_OPTIONS="${COMPILETIME_OPTIONS} -DNDEBUG "
-       ]
- )
  AC_SUBST(DEBUGFLAGS)
+ AC_SUBST(PYTHON_INSTALL_PARAMS)
This page took 0.271036 seconds and 4 git commands to generate.