]> git.pld-linux.org Git - packages/librsync.git/commitdiff
- rel.5 - support more than 4G auto/th/librsync-0_9_7-5
authorPaweł Gołaszewski <blues@pld-linux.org>
Mon, 9 Jan 2012 15:26:54 +0000 (15:26 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    librsync-4Gigbug.patch -> 1.1
    librsync.spec -> 1.26

librsync-4Gigbug.patch [new file with mode: 0644]
librsync.spec

diff --git a/librsync-4Gigbug.patch b/librsync-4Gigbug.patch
new file mode 100644 (file)
index 0000000..fef0894
--- /dev/null
@@ -0,0 +1,31 @@
+diff -urN librsync-0.9.7/mdfour.h librsync-0.9.7dev/mdfour.h
+--- librsync-0.9.7/mdfour.h    2004-02-07 18:17:57.000000000 -0500
++++ librsync-0.9.7dev/mdfour.h 2006-03-06 03:21:46.000000000 -0500
+@@ -24,7 +24,7 @@
+ #include "types.h"
+ struct rs_mdfour {
+-    int                 A, B, C, D;
++    unsigned int        A, B, C, D;
+ #if HAVE_UINT64
+     uint64_t            totalN;
+ #else
+diff -urN librsync-0.9.7/patch.c librsync-0.9.7dev/patch.c
+--- librsync-0.9.7/patch.c     2004-09-17 17:35:50.000000000 -0400
++++ librsync-0.9.7dev/patch.c  2006-03-06 03:21:06.000000000 -0500
+@@ -214,12 +214,12 @@
+     void            *buf, *ptr;
+     rs_buffers_t    *buffs = job->stream;
+-    len = job->basis_len;
+-    
+     /* copy only as much as will fit in the output buffer, so that we
+      * don't have to block or store the input. */
+-    if (len > buffs->avail_out)
++    if (job->basis_len > buffs->avail_out)
+         len = buffs->avail_out;
++    else
++        len = job->basis_len;
+     if (!len)
+         return RS_BLOCKED;
index b186d8dedb6f9689b1f4e5d03f8ef2be8cc8ec75..d660c9b7f5e5a3d00bb9da85fc6b02159ce7ddc3 100644 (file)
@@ -2,12 +2,13 @@ Summary:      Rsync libraries
 Summary(pl.UTF-8):     Biblioteki rsync
 Name:          librsync
 Version:       0.9.7
-Release:       4
+Release:       5
 License:       LGPL
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/librsync/%{name}-%{version}.tar.gz
 # Source0-md5: 24cdb6b78f45e0e83766903fd4f6bc84
 Patch0:                %{name}-link.patch
+Patch1:                %{name}-4Gigbug.patch
 URL:           http://librsync.sourceforge.net/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -68,6 +69,7 @@ Statyczna biblioteka librsync.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -96,7 +98,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS NEWS README THANKS TODO
 %attr(755,root,root) %{_bindir}/rdiff
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%attr(755,root,root) %{_libdir}/librsync.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/librsync.so.1
 %{_mandir}/man1/rdiff.1*
 
 %files devel
This page took 0.094066 seconds and 4 git commands to generate.