]> git.pld-linux.org Git - packages/libmpack.git/blob - libmpack.spec
apply upstream fix for packaging
[packages/libmpack.git] / libmpack.spec
1 Summary:        Simple implementation of msgpack in C
2 Name:           libmpack
3 Version:        1.0.2
4 Release:        0.1
5 License:        MIT
6 Group:          Development/Libraries
7 Source0:        https://github.com/tarruda/libmpack/archive/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  a6320e37991bb56520d4670419edb43c
9 Patch0:         https://patch-diff.githubusercontent.com/raw/tarruda/libmpack/pull/8.diff
10 # Patch0-md5:   91f4f18a5b74713465b392b3fe20d07a
11 URL:            https://github.com/tarruda/libmpack/
12 BuildRequires:  libtool
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 libmpack is a small binary serialization/RPC library that implements
17 both the msgpack and msgpack-rpc specifications.
18
19 Differences from mspack-c:
20  - Callback-based API to simplify (de)serialization directly to/from
21    application-specific objects.
22  - C89 compatible code
23  - No allocation performed by the library, but helpers to simplify
24    dynamic allocation if the application needs it.
25  - Non-backtracking, incremental/iterative parse/serialization API
26
27 %package devel
28 Summary:        Header files for %{name} library
29 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 Header files for %{name} library.
35
36 %prep
37 %setup -q
38 %patch0 -p1
39
40 %build
41 %{__make} config=release \
42         CC="%{__cc}" \
43         PREFIX=%{_prefix} \
44         CFLAGS="%{rpmcflags}" \
45         LDFLAGS="%{rpmldflags}" \
46         LIBDIR=%{_libdir} \
47         VERBOSE=1
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 %{__make} install \
52         PREFIX=%{_prefix} \
53         LIBDIR=%{_libdir} \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmpack.a
57 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmpack.la
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post   -p /sbin/ldconfig
63 %postun -p /sbin/ldconfig
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README.md LICENSE-MIT
68 %attr(755,root,root) %{_libdir}/libmpack.so.*.*.*
69 %ghost %{_libdir}/libmpack.so.0
70
71 %files devel
72 %defattr(644,root,root,755)
73 %{_libdir}/libmpack.so
74 %{_includedir}/mpack.h
75 %{_pkgconfigdir}/mpack.pc
This page took 0.127328 seconds and 3 git commands to generate.