]> git.pld-linux.org Git - packages/libmpack.git/blob - libmpack.spec
0021dce094476b6bc963662804a46dcafb260b1f
[packages/libmpack.git] / libmpack.spec
1 Summary:        Simple implementation of msgpack in C
2 Name:           libmpack
3 Version:        1.0.2
4 Release:        0.1
5 License:        MIT
6 Group:          Development/Libraries
7 Source0:        https://github.com/tarruda/libmpack/archive/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  a6320e37991bb56520d4670419edb43c
9 URL:            https://github.com/tarruda/libmpack/
10 BuildRequires:  libtool
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 libmpack is a small binary serialization/RPC library that implements
15 both the msgpack and msgpack-rpc specifications.
16
17 Differences from mspack-c:
18  - Callback-based API to simplify (de)serialization directly to/from
19    application-specific objects.
20  - C89 compatible code
21  - No allocation performed by the library, but helpers to simplify
22    dynamic allocation if the application needs it.
23  - Non-backtracking, incremental/iterative parse/serialization API
24
25 %prep
26 %setup -q
27
28 %build
29 %{__make} config=release \
30         CC="%{__cc}" \
31         PREFIX=%{_prefix} \
32         CFLAGS="%{rpmcflags}" \
33         LDFLAGS="%{rpmldflags} -fPIC -shared" \
34         LIBDIR=%{_libdir} \
35         VERBOSE=1
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_libdir}
40
41 libtool --mode=install install -p build/release/*.la $RPM_BUILD_ROOT%{_libdir}
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc README.md LICENSE-MIT
This page took 0.058994 seconds and 2 git commands to generate.