]> git.pld-linux.org Git - packages/libe-book.git/blob - libe-book.spec
- updated to 0.1.3
[packages/libe-book.git] / libe-book.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 Summary:        Library and tools for reading and converting various non-HTML reflowable e-book formats
6 Summary(pl.UTF-8):      Biblioteka i narzedzia do odczytu i konwersji różnych formatów e-booków
7 Name:           libe-book
8 Version:        0.1.3
9 Release:        1
10 License:        LGPL v2.1+ or MPL v2.0+
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/libebook/%{name}-%{version}.tar.xz
13 # Source0-md5:  2956f1c5e7950b0018979a132165da8b
14 Patch0:         %{name}-missing.patch
15 URL:            http://libebook.sourceforge.net/
16 BuildRequires:  boost-devel
17 BuildRequires:  cppunit-devel
18 BuildRequires:  doxygen
19 BuildRequires:  gperf
20 BuildRequires:  libCSS-devel >= 0.6.0
21 BuildRequires:  libhubbub-devel >= 0.3.0
22 BuildRequires:  libicu-devel
23 BuildRequires:  liblangtag-devel
24 BuildRequires:  libmspack-devel
25 BuildRequires:  libparserutils-devel
26 BuildRequires:  librevenge-devel >= 0.0
27 BuildRequires:  libstdc++-devel >= 6:4.7
28 BuildRequires:  libwapcaplet-devel
29 BuildRequires:  libxml2-devel >= 2.0
30 BuildRequires:  pkgconfig >= 1:0.20
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 BuildRequires:  zlib-devel
34 Requires:       libCSS >= 0.6.0
35 Requires:       libhubbub >= 0.3.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 libe-book is a library and a set of tools for reading and converting
40 various non-HTML reflowable e-book formats.
41
42 Currently supported are:
43 - eReader .pdb
44 - FictionBook v. 2 (including zipped files)
45 - PalmDoc Ebook
46 - Plucker .pdb
47 - QiOO (mobile format, for java-enabled cellphones)
48 - TCR (simple compressed text format)
49 - TealDoc
50 - zTXT
51 - ZVR (simple compressed text format)
52
53 %description -l pl.UTF-8
54 libe-book to biblioteka i zestaw narzędzi do odczytu i konwersji
55 różnych nie-HTML-owych, tekstowych formatów e-booków.
56
57 Obecnie obsługiwane są:
58 - eReader .pdb
59 - FictionBook w wersji 2 (wraz z plikami skompresowanymi zipem)
60 - PalmDoc Ebook
61 - Plucker .pdb
62 - QiOO (format przenośny, dla telefonów z Javą)
63 - TCR (prosty skompresowany format tekstowy)
64 - TealDoc
65 - zTXT
66 - ZVR (prosty skompresowany format tekstowy)
67
68 %package devel
69 Summary:        Header files for libe-book library
70 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libe-book
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       libCSS-devel >= 0.6.0
74 Requires:       libhubbub-devel >= 0.3.0
75 Requires:       libicu-devel
76 Requires:       liblangtag-devel
77 Requires:       libmspack-devel
78 Requires:       librevenge-devel >= 0.0
79 Requires:       libstdc++-devel >= 6:4.7
80 Requires:       libxml2-devel >= 2.0
81 Requires:       zlib-devel
82
83 %description devel
84 Header files for libe-book library.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki libe-book.
88
89 %package static
90 Summary:        Static libe-book library
91 Summary(pl.UTF-8):      Statyczna biblioteka libe-book
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description static
96 Static libe-book library.
97
98 %description static -l pl.UTF-8
99 Statyczna biblioteka libe-book.
100
101 %package apidocs
102 Summary:        libe-book API documentation
103 Summary(pl.UTF-8):      Dokumentacja API biblioteki libe-book
104 Group:          Documentation
105 %if "%{_rpmversion}" >= "5"
106 BuildArch:      noarch
107 %endif
108
109 %description apidocs
110 API documentation for libe-book library.
111
112 %description apidocs -l pl.UTF-8
113 Dokumentacja API biblioteki libe-book.
114
115 %package tools
116 Summary:        Tools to transform e-books into other formats
117 Summary(pl.UTF-8):      Programy przekształcania e-booków do innych formatów
118 Group:          Applications/Publishing
119 Requires:       %{name} = %{version}-%{release}
120
121 %description tools
122 Tools to transform e-books into other formats. Currently supported:
123 HTML, text, raw.
124
125 %description tools -l pl.UTF-8
126 Narzędzia do przekształcania e-booków do innych formatów. Aktualnie
127 obsługiwane są HTML, tekst i format surowy.
128
129 %prep
130 %setup -q
131 %patch0 -p1
132
133 %build
134 export CXXFLAGS="%{rpmcxxflags} -Wno-unused-function"
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoconf}
138 %{__autoheader}
139 %{__automake}
140 %configure \
141         --enable-experimental \
142         --disable-silent-rules \
143         %{?with_static_libs:--enable-static}
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 # obsoleted by pkg-config
153 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libe-book-*.la
154 # packaged as %doc in -apidocs
155 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libe-book
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 %doc AUTHORS ChangeLog NEWS README TODO
166 %attr(755,root,root) %{_libdir}/libe-book-0.1.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libe-book-0.1.so.1
168 %{_datadir}/libe-book
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libe-book-0.1.so
173 %{_includedir}/libe-book-0.1
174 %{_pkgconfigdir}/libe-book-0.1.pc
175
176 %if %{with static_libs}
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/libe-book-0.1.a
180 %endif
181
182 %files apidocs
183 %defattr(644,root,root,755)
184 %doc docs/doxygen/html/*
185
186 %files tools
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_bindir}/ebook2html
189 %attr(755,root,root) %{_bindir}/ebook2raw
190 %attr(755,root,root) %{_bindir}/ebook2text
This page took 0.082079 seconds and 3 git commands to generate.