]> git.pld-linux.org Git - packages/libde265.git/commitdiff
- new auto/th/libde265-1.0.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 16 Oct 2015 19:18:29 +0000 (21:18 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 16 Oct 2015 19:18:29 +0000 (21:18 +0200)
libde265-sh.patch [new file with mode: 0644]
libde265.spec [new file with mode: 0644]

diff --git a/libde265-sh.patch b/libde265-sh.patch
new file mode 100644 (file)
index 0000000..417eaca
--- /dev/null
@@ -0,0 +1,71 @@
+--- libde265-1.0.2/configure.ac.orig   2015-07-14 13:49:47.000000000 +0200
++++ libde265-1.0.2/configure.ac        2015-10-16 17:46:08.702362000 +0200
+@@ -36,8 +36,8 @@
+ # Initialize automake stuff
+ AM_INIT_AUTOMAKE
+-CFLAGS+=" -std=c99"
+-CXXFLAGS+=" -Werror=return-type -Werror=unused-result -Werror=reorder"
++CFLAGS="$CFLAGS -std=c99"
++CXXFLAGS="$CXXFLAGS -Werror=return-type -Werror=unused-result -Werror=reorder"
+ AX_CXX_COMPILE_STDCXX_11()
+ dnl Use -Wall if we have gcc.
+@@ -101,8 +101,8 @@
+ ],[],[need_strict_ansi=no],[need_strict_ansi=yes]);
+ AC_LANG_POP(C++)
+ if eval "test x$need_strict_ansi = xyes"; then
+-  CFLAGS+=" -D__STRICT_ANSI__"
+-  CXXFLAGS+=" -D__STRICT_ANSI__"
++  CFLAGS="$CFLAGS -D__STRICT_ANSI__"
++  CXXFLAGS="$CXXFLAGS -D__STRICT_ANSI__"
+ fi
+ AC_MSG_RESULT([$need_strict_ansi])
+@@ -136,8 +136,8 @@
+ fi
+ AM_CONDITIONAL([ENABLE_SSE_OPT], [test x"$ax_cv_support_sse41_ext" = x"yes"])
+-# CFLAGS+=$SIMD_FLAGS
+-# CFLAGS+=" -march=x86-64"
++# CFLAGS="$CFLAGS $SIMD_FLAGS"
++# CFLAGS="$CFLAGS -march=x86-64"
+ case $target_cpu in
+   arm*)
+@@ -180,7 +180,7 @@
+   [enable_log_error=$enableval],
+   [enable_log_error=yes])
+ if eval "test $enable_log_error = yes"; then
+-  CXXFLAGS+=" -DDE265_LOG_ERROR"
++  CXXFLAGS="$CXXFLAGS -DDE265_LOG_ERROR"
+ fi
+ AC_ARG_ENABLE(log-info,
+@@ -189,7 +189,7 @@
+   [enable_log_info=$enableval],
+   [enable_log_info=no])
+ if eval "test $enable_log_info = yes"; then
+-  CXXFLAGS+=" -DDE265_LOG_INFO"
++  CXXFLAGS="$CXXFLAGS -DDE265_LOG_INFO"
+ fi
+ AC_ARG_ENABLE(log-debug,
+@@ -198,7 +198,7 @@
+   [enable_log_debug=$enableval],
+   [enable_log_debug=no])
+ if eval "test $enable_log_debug = yes"; then
+-  CXXFLAGS+=" -DDE265_LOG_DEBUG"
++  CXXFLAGS="$CXXFLAGS -DDE265_LOG_DEBUG"
+ fi
+ AC_ARG_ENABLE(log-trace,
+@@ -207,7 +207,7 @@
+   [enable_log_trace=$enableval],
+   [enable_log_trace=no])
+ if eval "test $enable_log_trace = yes"; then
+-  CXXFLAGS+=" -DDE265_LOG_TRACE"
++  CXXFLAGS="$CXXFLAGS -DDE265_LOG_TRACE"
+ fi
diff --git a/libde265.spec b/libde265.spec
new file mode 100644 (file)
index 0000000..e7bc3ed
--- /dev/null
@@ -0,0 +1,158 @@
+#
+# Conditional build:
+%bcond_without qt              # Qt based visual inspection GUI (sherlock265)
+%bcond_without static_libs     # don't build static libraries
+#
+Summary:       H.265/HEVC video decoder
+Summary(pl.UTF-8):     Dekoder obrazu H.265/HEVC
+Name:          libde265
+Version:       1.0.2
+Release:       1
+License:       LGPL v3+ (library), GPL v3+ (programs)
+Group:         Libraries
+Source0:       https://github.com/strukturag/libde265/releases/download/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 93520b378df25f3a94e962f2b54872cc
+Patch0:                %{name}-sh.patch
+URL:           http://www.libde265.org/
+BuildRequires: SDL-devel
+BuildRequires: autoconf >= 2.68
+BuildRequires: ffmpeg-devel
+BuildRequires: libstdc++-devel
+BuildRequires: libtool >= 2:2
+BuildRequires: libvideogfx-devel
+BuildRequires: pkgconfig
+%if %{with qt}
+BuildRequires: Qt5Core-devel >= 5
+BuildRequires: Qt5Gui-devel >= 5
+BuildRequires: Qt5Widgets-devel >= 5
+BuildRequires: qt5-build >= 5
+%endif
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+libde265 is an open source implementation of the H.265 video codec. It
+is written from scratch and has a plain C API to enable a simple
+integration into other software.
+
+%description -l pl.UTF-8
+libde265 to mająca otwarte źródła implementacja kodeka obrazu H.265.
+Została napisana od zera i ma API w czystym C, pozwalające na prostą
+integrację w innym oprogramowaniu.
+
+%package tools
+Summary:       Encoding and decoding tools for libde265 library
+Summary(pl.UTF-8):     Narzędzia kodujące i dekodujące dla biblioteki libde265
+License:       LGPL v3+ (library), GPL v3+ (programs)
+Group:         Applications/Graphics
+Requires:      %{name} = %{version}-%{release}
+
+%description tools
+Encoding and decoding tools for libde265 library.
+
+%description tools -l pl.UTF-8
+Narzędzia kodujące i dekodujące dla biblioteki libde265.
+
+%package gui
+Summary:       Visual inspection tool (sherlock265) for libde265 library
+Summary(pl.UTF-8):     Narzędzie do wizualnego badania (sherlock265) dla biblioteki libde265
+Group:         X11/Applications/Graphics
+Requires:      %{name} = %{version}-%{release}
+
+%description gui
+Visual inspection tool (sherlock265) for libde265 library.
+
+%description gui -l pl.UTF-8
+Narzędzie do wizualnego badania (sherlock265) dla biblioteki libde265.
+
+%package devel
+Summary:       Header files for libde265 library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libde265
+License:       LGPL v3+
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      libstdc++-devel
+
+%description devel
+Header files for libde265 library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki libde265.
+
+%package static
+Summary:       Static libde265 library
+Summary(pl.UTF-8):     Statyczna biblioteka libde265
+License:       LGPL v3+
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static libde265 library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka libde265.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%configure \
+       %{!?with_qt:--disable-sherlock265} \
+       %{!?with_static_libs:--disable-static}
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+# examples
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/{bjoentegaard,block-rate-estim,gen-enc-table,hdrcopy,rd-curves,tests,yuv-distortion}
+
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS NEWS README.md TODO
+%attr(755,root,root) %{_libdir}/libde265.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libde265.so.0
+
+%files tools
+%defattr(644,root,root,755)
+# R: SDL libvideogfx
+%attr(755,root,root) %{_bindir}/dec265
+# R: (only base)
+%attr(755,root,root) %{_bindir}/enc265
+
+%if %{with qt}
+%files gui
+%defattr(644,root,root,755)
+%doc sherlock265/README
+# R: Qt5 (Core Gui Widgets) ffmpeg/libswscale
+%attr(755,root,root) %{_bindir}/sherlock265
+%endif
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libde265.so
+%{_includedir}/libde265
+%{_pkgconfigdir}/libde265.pc
+
+%if %{with static_libs}
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libde265.a
+%endif
This page took 0.140439 seconds and 4 git commands to generate.