]> git.pld-linux.org Git - packages/libcdio.git/blob - libcdio.spec
99d0d1ba16d34cb655f8fd9209fe21882c8d3200
[packages/libcdio.git] / libcdio.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # disable features to able to build without circular dependencies
4 %bcond_without  cddb            # build cd-info without CDDB lookups (for bootstrap)
5 %bcond_without  static_libs     # don't build static library
6 %bcond_without  vcd             # build cd-info without VCD support (for bootstrap) (affects only *-utils, not libraries)
7
8 %if %{with bootstrap}
9 %undefine       with_cddb
10 %undefine       with_vcd
11 %endif
12
13 Summary:        GNU Compact Disc Input, Output and Control Library
14 Summary(pl.UTF-8):      Biblioteka GNU do obsługi wejścia, wyjścia i sterowania czytnikiem CD
15 Name:           libcdio
16 Version:        0.93
17 Release:        2
18 License:        GPL v3+
19 Group:          Libraries
20 Source0:        http://ftp.gnu.org/gnu/libcdio/%{name}-%{version}.tar.bz2
21 # Source0-md5:  8be842d903f086941c45ad0360420314
22 Patch0:         %{name}-info.patch
23 URL:            http://www.gnu.org/software/libcdio/
24 BuildRequires:  autoconf >= 2.61
25 BuildRequires:  automake >= 1:1.8.3
26 # for AM_ICONV and config.rpath
27 BuildRequires:  gettext-tools >= 0.14
28 BuildRequires:  help2man
29 %{?with_cddb:BuildRequires:     libcddb-devel >= 1.0.1}
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtool >= 2:1.5
32 BuildRequires:  ncurses-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  texinfo
36 %{?with_vcd:BuildRequires:      vcdimager-devel >= 0.7.21}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 This library is to encapsulate CD-ROM reading and control.
41 Applications wishing to be oblivious of the OS- and device-dependent
42 properties of a CD-ROM can use this library.
43
44 Some support for disk image types like BIN/CUE and NRG is available,
45 so applications that use this library also have the ability to read
46 disc images as though they were CD's.
47
48 Immediate uses are VCDImager, a navigation-capable Video CD plugin
49 and CD-DA plugin for the media player xine.
50
51 A sample utility, cd-info which displayings CD info is included in
52 utils subpackage.
53
54 %description -l pl.UTF-8
55 Ta biblioteka obudowuje czynności odczytu i sterowania czytnikami
56 CD-ROM. Aplikacje chcące zapomnieć o zależnych od systemu lub
57 urządzenia własnościach CD-ROM-u mogą używać tej biblioteki.
58
59 Dostępna jest pewna obsługa obrazów dysków typu BIN/CUE czy NRG, więc
60 aplikacje używające tej biblioteki mogą czytać także takie obrazy
61 dysków tak jakby były płytami.
62
63 Biblioteka jest używana bezpośrednio w VCDImagerze, wtyczce z
64 nawigacją do Video CD oraz wtyczce CD-DA dla odtwarzacza multimediów
65 xine.
66
67 W podpakiecie utils załączone jest przykładowe narzędzie cd-info
68 służące do wyświetlania informacji o płytach kompaktowych.
69
70 %package devel
71 Summary:        Header files for libcdio libraries
72 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek libcdio
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description devel
77 Header files for libcdio libraries.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe bibliotek libcdio.
81
82 %package static
83 Summary:        Static libcdio libraries
84 Summary(pl.UTF-8):      Statyczne biblioteki libcdio
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 Static libcdio libraries.
90
91 %description static -l pl.UTF-8
92 Statyczne biblioteki libcdio.
93
94 %package c++
95 Summary:        C++ libcdio libraries
96 Summary(pl.UTF-8):      Biblioteki C++ libcdio
97 Group:          Libraries
98 Requires:       %{name} = %{version}-%{release}
99
100 %description c++
101 C++ libcdio libraries.
102
103 %description c++ -l pl.UTF-8
104 Biblioteki C++ libcdio.
105
106 %package c++-devel
107 Summary:        Header files for C++ libcdio libraries
108 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ libcdio
109 Group:          Development/Libraries
110 Requires:       %{name}-c++ = %{version}-%{release}
111 Requires:       %{name}-devel = %{version}-%{release}
112 Requires:       libstdc++-devel
113
114 %description c++-devel
115 Header files for C++ libcdio libraries.
116
117 %description c++-devel -l pl.UTF-8
118 Pliki nagłówkowe bibliotek C++ libcdio.
119
120 %package c++-static
121 Summary:        Static C++ libcdio libraries
122 Summary(pl.UTF-8):      Statyczne biblioteki C++ libcdio
123 Group:          Development/Libraries
124 Requires:       %{name}-c++-devel = %{version}-%{release}
125
126 %description c++-static
127 Static C++ libcdio libraries.
128
129 %description c++-static -l pl.UTF-8
130 Statyczne biblioteki C++ libcdio.
131
132 %package utils
133 Summary:        libcdio utilities: cd-info, cd-read
134 Summary(pl.UTF-8):      Narzędzia używające libcdio: cd-info, cd-read
135 Group:          Applications
136 Requires:       %{name} = %{version}-%{release}
137
138 %description utils
139 libcdio utilities: cd-info, cd-read.
140
141 %description utils -l pl.UTF-8
142 Narzędzia używające libcdio: cd-info, cd-read.
143
144 %prep
145 %setup -q
146 %patch0 -p1
147
148 %{__sed} -i 's, example$,,' Makefile.am
149
150 # bug: *.pc for C++ bindings, not programs
151 %{__sed} -i 's,ENABLE_CPP,ENABLE_CXX_BINDINGS,' Makefile.am
152
153 cp -f /usr/share/gettext/config.rpath .
154
155 %build
156 %{__libtoolize}
157 %{__aclocal}
158 %{__autoconf}
159 %{__autoheader}
160 %{__automake}
161 CPPFLAGS="-I/usr/include/ncurses"
162 %configure \
163         --disable-silent-rules \
164         --enable-cd-info-linux \
165         --enable-maintainer-mode \
166         --enable-rock \
167         %{!?with_cddb:--disable-cddb} \
168         %{!?with_vcd:--disable-vcd-info} \
169         %{!?with_static_libs:--disable-static}
170
171 %{__make}
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175
176 %{__make} install \
177         DESTDIR=$RPM_BUILD_ROOT
178
179 # obsoleted by pkg-config
180 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post   -p /sbin/ldconfig
186 %postun -p /sbin/ldconfig
187
188 %post   devel -p /sbin/postshell
189 -/usr/sbin/fix-info-dir -c %{_infodir}
190
191 %postun devel -p /sbin/postshell
192 -/usr/sbin/fix-info-dir -c %{_infodir}
193
194 %post   c++ -p /sbin/ldconfig
195 %postun c++ -p /sbin/ldconfig
196
197 %files
198 %defattr(644,root,root,755)
199 %doc AUTHORS ChangeLog NEWS README THANKS TODO
200 %attr(755,root,root) %{_libdir}/libcdio.so.*.*.*
201 %attr(755,root,root) %ghost %{_libdir}/libcdio.so.16
202 %attr(755,root,root) %{_libdir}/libiso9660.so.*.*.*
203 %attr(755,root,root) %ghost %{_libdir}/libiso9660.so.10
204 %attr(755,root,root) %{_libdir}/libudf.so.*.*.*
205 %attr(755,root,root) %ghost %{_libdir}/libudf.so.0
206
207 %files devel
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/libcdio.so
210 %attr(755,root,root) %{_libdir}/libiso9660.so
211 %attr(755,root,root) %{_libdir}/libudf.so
212 %{_includedir}/cdio
213 %{_pkgconfigdir}/libcdio.pc
214 %{_pkgconfigdir}/libiso9660.pc
215 %{_pkgconfigdir}/libudf.pc
216 %{_infodir}/libcdio.info*
217
218 %if %{with static_libs}
219 %files static
220 %defattr(644,root,root,755)
221 %{_libdir}/libcdio.a
222 %{_libdir}/libiso9660.a
223 %{_libdir}/libudf.a
224 %endif
225
226 %files c++
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_libdir}/libcdio++.so.*.*.*
229 %attr(755,root,root) %ghost %{_libdir}/libcdio++.so.0
230 %attr(755,root,root) %{_libdir}/libiso9660++.so.*.*.*
231 %attr(755,root,root) %ghost %{_libdir}/libiso9660++.so.0
232
233 %files c++-devel
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_libdir}/libcdio++.so
236 %attr(755,root,root) %{_libdir}/libiso9660++.so
237 %{_includedir}/cdio++
238 %{_pkgconfigdir}/libcdio++.pc
239 %{_pkgconfigdir}/libiso9660++.pc
240
241 %if %{with static_libs}
242 %files c++-static
243 %defattr(644,root,root,755)
244 %{_libdir}/libcdio++.a
245 %{_libdir}/libiso9660++.a
246 %endif
247
248 %files utils
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_bindir}/cd-drive
251 %attr(755,root,root) %{_bindir}/cd-info
252 %attr(755,root,root) %{_bindir}/cd-read
253 %attr(755,root,root) %{_bindir}/cdda-player
254 %attr(755,root,root) %{_bindir}/cdinfo-linux
255 %attr(755,root,root) %{_bindir}/iso-info
256 %attr(755,root,root) %{_bindir}/iso-read
257 %attr(755,root,root) %{_bindir}/mmc-tool
258 %{_mandir}/man1/cd-drive.1*
259 %{_mandir}/man1/cd-info.1*
260 %{_mandir}/man1/cd-read.1*
261 %{_mandir}/man1/iso-info.1*
262 %{_mandir}/man1/iso-read.1*
This page took 0.081921 seconds and 2 git commands to generate.