]> git.pld-linux.org Git - packages/kp5-polkit-kde-agent.git/blob - kp5-polkit-kde-agent.spec
0c40d1f4c06cd03a69af53e73dc736e36ba38e3c
[packages/kp5-polkit-kde-agent.git] / kp5-polkit-kde-agent.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.27.9
5 %define         qtver           5.15.2
6 %define         kpname          polkit-kde-agent
7
8 Summary:        Daemon providing a polkit authentication UI for KDE
9 Name:           kp5-%{kpname}
10 Version:        5.27.9
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-1-%{version}.tar.xz
15 # Source0-md5:  2cb62b325b04238f4ded20db70a144f9
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 3.16.0
19 BuildRequires:  kf5-kconfig-devel
20 BuildRequires:  kf5-kcoreaddons-devel
21 BuildRequires:  kf5-kcrash-devel
22 BuildRequires:  kf5-kdbusaddons-devel
23 BuildRequires:  kf5-ki18n-devel
24 BuildRequires:  kf5-kiconthemes-devel
25 BuildRequires:  kf5-knotifications-devel
26 BuildRequires:  kf5-kwidgetsaddons-devel
27 BuildRequires:  kf5-kwindowsystem-devel
28 BuildRequires:  ninja
29 BuildRequires:  polkit-qt5-1-gui-devel
30 BuildRequires:  rpmbuild(macros) >= 1.164
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 Daemon providing a polkit authentication UI for KDE.
38
39 %prep
40 %setup -q -n %{kpname}-1-%{version}
41
42 %build
43 %cmake -B build \
44         -G Ninja \
45         %{!?with_tests:-DBUILD_TESTING=OFF} \
46         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
47         -DHTML_INSTALL_DIR=%{_kdedocdir}
48 %ninja_build -C build
49
50 %if %{with tests}
51 ctest
52 %endif
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %ninja_install -C build
57
58 # not supported by glibc yet
59 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
60
61 %find_lang %{kpname} --all-name --with-kde
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post -p /sbin/ldconfig
67 %postun -p /sbin/ldconfig
68
69 %files -f %{kpname}.lang
70 %defattr(644,root,root,755)
71 %attr(755,root,root) %{_libexecdir}/polkit-kde-authentication-agent-1
72 /etc/xdg/autostart/polkit-kde-authentication-agent-1.desktop
73 %{_datadir}/knotifications5/policykit1-kde.notifyrc
74 %{_desktopdir}/org.kde.polkit-kde-authentication-agent-1.desktop
75 %{systemduserunitdir}/plasma-polkit-agent.service
This page took 0.216539 seconds and 2 git commands to generate.