]> git.pld-linux.org Git - packages/kp5-libkscreen.git/blob - kp5-libkscreen.spec
- updated to 5.5.4
[packages/kp5-libkscreen.git] / kp5-libkscreen.spec
1 %define         kdeplasmaver    5.5.4
2 %define         qtver           5.3.2
3 %define         kpname          libkscreen
4
5 Summary:        KDE screen management software
6 Name:           kp5-%{kpname}
7 Version:        5.5.4
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
12 # Source0-md5:  bc23b108f5e5dccdc03183e4b72c354d
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  cmake >= 2.8.12
16 BuildRequires:  rpmbuild(macros) >= 1.164
17 BuildRequires:  xz
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         qt5dir          %{_libdir}/qt5
21
22 %description
23 KDE screen management software.
24
25 %package devel
26 Summary:        Header files for %{kpname} development
27 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
28 Group:          X11/Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 Header files for %{kpname} development.
33
34 %description devel -l pl.UTF-8
35 Pliki nagłówkowe dla programistów używających %{kpname}.
36
37 %prep
38 %setup -q -n %{kpname}-%{version}
39
40 %build
41 install -d build
42 cd build
43 %cmake \
44         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
45         ../
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} -C build/ install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post -p /sbin/ldconfig
58 %postun -p /sbin/ldconfig
59
60 %files
61 %defattr(644,root,root,755)
62 %defattr(644,root,root,755)
63 %attr(755,root,root) %{_libdir}/kf5/kscreen_backend_launcher
64 %attr(755,root,root) %{_libdir}/libKF5Screen.so.*.*.*
65 %attr(755,root,root) %ghost %{_libdir}/libKF5Screen.so.6
66 %dir %{_libdir}/qt5/plugins/kf5/kscreen
67 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kscreen/KSC_Fake.so
68 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kscreen/KSC_QScreen.so
69 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kscreen/KSC_XRandR.so
70 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kscreen/KSC_XRandR11.so
71 %{_datadir}/dbus-1/services/org.kde.kscreen.service
72
73 %files devel
74 %defattr(644,root,root,755)
75 %attr(755,root,root) %{_libdir}/libKF5Screen.so
76 %{_includedir}/KF5/KScreen
77 %{_includedir}/KF5/kscreen_version.h
78 %{_libdir}/cmake/KF5Screen
79 %{_pkgconfigdir}/kscreen2.pc
80 %{_libdir}/qt5/mkspecs/modules/qt_KScreen.pri
This page took 0.087178 seconds and 3 git commands to generate.