]> git.pld-linux.org Git - packages/kp5-kwayland-integration.git/blob - kp5-kwayland-integration.spec
- updated to 5.27.11
[packages/kp5-kwayland-integration.git] / kp5-kwayland-integration.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.27.11
5 %define         qtver           5.15.2
6 %define         kpname          kwayland-integration
7
8 Summary:        Provides integration plugins for various KDE frameworks for the wayland windowing system
9 Name:           kp5-%{kpname}
10 Version:        5.27.11
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
15 # Source0-md5:  83d238cc06bf9e77fd77e0ca48386689
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5WaylandClient-devel >= %{qtver}
19 BuildRequires:  cmake >= 3.16.0
20 BuildRequires:  kf5-kidletime-devel
21 BuildRequires:  kf5-kwayland-devel
22 BuildRequires:  kf5-kwindowsystem-devel
23 BuildRequires:  ninja
24 BuildRequires:  rpmbuild(macros) >= 1.164
25 BuildRequires:  xz
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         qt5dir          %{_libdir}/qt5
29
30 %description
31 Provides integration plugins for various KDE frameworks for the
32 wayland windowing system.
33
34 %prep
35 %setup -q -n %{kpname}-%{version}
36
37 %build
38 %cmake -B build \
39         -G Ninja \
40         %{!?with_tests:-DBUILD_TESTING=OFF} \
41         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
42         -DHTML_INSTALL_DIR=%{_kdedocdir}
43 %ninja_build -C build
44
45 %if %{with tests}
46 ctest
47 %endif
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 %ninja_install -C build
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %{_datadir}/qlogging-categories5/kwindowsystem.kwayland.categories
59 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kwindowsystem/KF5WindowSystemKWaylandPlugin.so
This page took 0.060821 seconds and 4 git commands to generate.