]> git.pld-linux.org Git - packages/kodi-addon-inputstream-ffmpegdirect.git/blob - kodi-addon-inputstream-ffmpegdirect.spec
62d1d4ba7f9006d80611a8d49dde19c3771a4ff0
[packages/kodi-addon-inputstream-ffmpegdirect.git] / kodi-addon-inputstream-ffmpegdirect.spec
1 %define         kodi_ver        19
2 %define         next_kodi_ver   %(echo $((%{kodi_ver}+1)))
3 %define         codename        Matrix
4 %define         addon           inputstream.ffmpegdirect
5
6 Summary:        Kodi InputStream ffmpegdirect addon
7 Name:           kodi-addon-inputstream-ffmpegdirect
8 Version:        %{kodi_ver}.0.1
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/Multimedia
12 Source0:        https://github.com/xbmc/inputstream.ffmpegdirect/archive/%{version}-%{codename}/%{version}-%{codename}.tar.gz
13 # Source0-md5:  8df4664544115545dd68d554ae1f85de
14 URL:            https://github.com/xbmc/inputstream.ffmpegdirect
15 BuildRequires:  bzip2-devel
16 BuildRequires:  cmake >= 3.5
17 BuildRequires:  ffmpeg-devel
18 BuildRequires:  kodi-devel >= %{kodi_ver}
19 BuildRequires:  kodi-devel < %{next_kodi_ver}
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpmbuild(macros) >= 1.605
22 BuildRequires:  zlib-devel
23 Requires:       kodi >= %{kodi_ver}
24 Requires:       kodi < %{next_kodi_ver}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This is a Kodi input stream addon for streams that can be opened by
29 either FFmpeg's libavformat or Kodi's cURL. Common stream formats such
30 as plain TS, HLS and DASH are supported as well as many others. Note
31 that the only DASH streams supported are those without DRM.
32
33 The addon also has support for Archive/Catchup services where there is
34 a replay window (usually in days) and can timeshift across that span.
35 In addition the addon can also provide timeshift to live streams where
36 rewind/pause and fast-forward woud not have previously been possible.
37
38 %prep
39 %setup -q -n %{addon}-%{version}-%{codename}
40
41 %build
42 %cmake -B build
43 %{__make} -C build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %{__make} -C build install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %dir %{_libdir}/kodi/addons/%{addon}
56 %attr(755,root,root) %{_libdir}/kodi/addons/%{addon}/%{addon}.so.%{version}
57 %dir %{_datadir}/kodi/addons/%{addon}
58 %{_datadir}/kodi/addons/%{addon}/addon.xml
59 %{_datadir}/kodi/addons/%{addon}/changelog.txt
60 %{_datadir}/kodi/addons/%{addon}/fanart.jpg
61 %{_datadir}/kodi/addons/%{addon}/icon.png
62 %{_datadir}/kodi/addons/%{addon}/resources
This page took 0.101894 seconds and 2 git commands to generate.