]> git.pld-linux.org Git - packages/kf5-kplotting.git/blob - kf5-kplotting.spec
- updated to 5.106.0
[packages/kf5-kplotting.git] / kf5-kplotting.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.106
5 %define         qtver           5.15.2
6 %define         kfname          kplotting
7 #
8 Summary:        Data plotting
9 Name:           kf5-%{kfname}
10 Version:        5.106.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  e37e4e120db15ab92a3fe6ef0207c223
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel
18 BuildRequires:  Qt5Gui-devel >= 5.3.1
19 BuildRequires:  Qt5Test-devel
20 BuildRequires:  Qt5Widgets-devel
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  kf5-extra-cmake-modules >= %{version}
23 BuildRequires:  ninja
24 BuildRequires:  rpmbuild(macros) >= 1.164
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       kf5-dirs
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         qt5dir          %{_libdir}/qt5
31
32 %description
33 KPlotWidget is a QWidget-derived class that provides a virtual base
34 class for easy data-plotting. The idea behind KPlotWidget is that you
35 only have to specify information in "data units"; i.e., the natural
36 units of the data being plotted. KPlotWidget automatically converts
37 everything to screen pixel units.
38
39 KPlotWidget draws X and Y axes with tick marks and tick labels. It
40 automatically determines how many tick marks to use and where they
41 should be, based on the data limits specified for the plot. You change
42 the limits by calling `setLimits(double x1, double x2, double y1,
43 double y2)`.
44
45 Data to be plotted are stored using the KPlotObject class. KPlotObject
46 consists of a QList of QPointF's, each specifying the X,Y coordinates
47 of a data point. KPlotObject also specifies the "type" of data to be
48 plotted (POINTS or CURVE or POLYGON or LABEL).
49
50 %package devel
51 Summary:        Header files for %{kfname} development
52 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
53 Group:          X11/Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 Header files for %{kfname} development.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe dla programistów używających %{kfname}.
61
62 %prep
63 %setup -q -n %{kfname}-%{version}
64
65 %build
66 install -d build
67 cd build
68 %cmake -G Ninja \
69         %{!?with_tests:-DBUILD_TESTING=OFF} \
70         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
71         ../
72 %ninja_build
73
74 %if %{with tests}
75 ctest
76 %endif
77
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 %ninja_install -C build
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README.md
92 %ghost %{_libdir}/libKF5Plotting.so.5
93 %attr(755,root,root) %{_libdir}/libKF5Plotting.so.*.**
94 %attr(755,root,root) %{qt5dir}/plugins/designer/kplotting5widgets.so
95
96 %files devel
97 %defattr(644,root,root,755)
98 %{_includedir}/KF5/KPlotting
99 %{_libdir}/cmake/KF5Plotting
100 %{_libdir}/libKF5Plotting.so
101 %{qt5dir}/mkspecs/modules/qt_KPlotting.pri
This page took 0.16021 seconds and 3 git commands to generate.