]> git.pld-linux.org Git - packages/kf5-kconfig.git/blob - kf5-kconfig.spec
- Up to 5.62.
[packages/kf5-kconfig.git] / kf5-kconfig.spec
1 %define         kdeframever     5.62
2 %define         qtver           5.9.0
3 %define         kfname          kconfig
4
5 Summary:        Backend for storing application configuration
6 Name:           kf5-%{kfname}
7 Version:        5.62.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  4374c59af59f2f8f620219f1804b90b9
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5Xml-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= %{kdeframever}
20 BuildRequires:  ninja
21 BuildRequires:  qt5-linguist >= %{qtver}
22 BuildRequires:  rpmbuild(macros) >= 1.164
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Requires:       kf5-dirs
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         qt5dir          %{_libdir}/qt5
29
30 %description
31 KConfig provides an advanced configuration system. It is made of two
32 parts: KConfigCore and KConfigGui.
33
34 KConfigCore provides access to the configuration files themselves. It
35 features:
36
37 - Code generation: describe your configuration in an XML file, and use
38   `kconfig_compiler to generate classes that read and write
39   configuration entries.
40 - Cascading configuration files (global settings overridden by local
41   settings).
42 - Optional shell expansion support (see [docs/options.md](@ref
43   options)).
44 - The ability to lock down configuration options (see
45   [docs/options.md](@ref options)).
46
47 KConfigGui provides a way to hook widgets to the configuration so that
48 they are automatically initialized from the configuration and
49 automatically propagate their changes to their respective
50 configuration files.
51
52 %package devel
53 Summary:        Header files for %{kfname} development
54 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
55 Group:          X11/Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       Qt5Xml-devel >= %{qtver}
58 Requires:       cmake >= 2.6.0
59
60 %description devel
61 Header files for %{kfname} development.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe dla programistów używających %{kfname}.
65
66 %prep
67 %setup -q -n %{kfname}-%{version}
68
69 %build
70 install -d build
71 cd build
72 %cmake -G Ninja \
73         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
74         ../
75 %ninja_build
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_datadir}/kconf_update
80 %ninja_install -C build
81
82 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files -f %{kfname}5_qt.lang
91 %defattr(644,root,root,755)
92 %doc DESIGN README.md TODO
93 %attr(755,root,root) %ghost %{_libdir}/libKF5ConfigCore.so.5
94 %attr(755,root,root) %{_libdir}/libKF5ConfigCore.so.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libKF5ConfigGui.so.5
96 %attr(755,root,root) %{_libdir}/libKF5ConfigGui.so.*.*
97 %attr(755,root,root) %{_bindir}/kreadconfig5
98 %attr(755,root,root) %{_bindir}/kwriteconfig5
99 %attr(755,root,root) %{_libexecdir}/kf5/kconf_update
100 %attr(755,root,root) %{_libexecdir}/kf5/kconfig_compiler_kf5
101 %dir %{_datadir}/kconf_update
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libKF5ConfigCore.so
106 %attr(755,root,root) %{_libdir}/libKF5ConfigGui.so
107 %{_includedir}/KF5/KConfigCore
108 %{_includedir}/KF5/KConfigGui
109 %{_includedir}/KF5/kconfig_version.h
110 %{_libdir}/cmake/KF5Config
111 %{qt5dir}/mkspecs/modules/qt_KConfigCore.pri
112 %{qt5dir}/mkspecs/modules/qt_KConfigGui.pri
This page took 0.034116 seconds and 4 git commands to generate.