]> git.pld-linux.org Git - packages/kf5-kconfig.git/blob - kf5-kconfig.spec
- updated to 5.97.0
[packages/kf5-kconfig.git] / kf5-kconfig.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.97
5 %define         qtver           5.15.2
6 %define         kfname          kconfig
7
8 Summary:        Backend for storing application configuration
9 Name:           kf5-%{kfname}
10 Version:        5.97.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  e007684ef4b71aa63c997f7e53257936
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5DBus-devel >= %{qtver}
19 BuildRequires:  Qt5Gui-devel >= %{qtver}
20 BuildRequires:  Qt5Test-devel >= %{qtver}
21 BuildRequires:  Qt5Xml-devel >= %{qtver}
22 BuildRequires:  cmake >= 3.16
23 BuildRequires:  kf5-extra-cmake-modules >= %{kdeframever}
24 BuildRequires:  ninja
25 BuildRequires:  qt5-linguist >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.736
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Requires:       Qt5DBus >= %{qtver}
30 Requires:       Qt5Gui >= %{qtver}
31 Requires:       Qt5Xml >= %{qtver}
32 Requires:       kf5-dirs
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         qt5dir          %{_libdir}/qt5
36
37 %description
38 KConfig provides an advanced configuration system. It is made of two
39 parts: KConfigCore and KConfigGui.
40
41 KConfigCore provides access to the configuration files themselves. It
42 features:
43
44 - Code generation: describe your configuration in an XML file, and use
45   `kconfig_compiler to generate classes that read and write
46   configuration entries.
47 - Cascading configuration files (global settings overridden by local
48   settings).
49 - Optional shell expansion support (see [docs/options.md](@ref
50   options)).
51 - The ability to lock down configuration options (see
52   [docs/options.md](@ref options)).
53
54 KConfigGui provides a way to hook widgets to the configuration so that
55 they are automatically initialized from the configuration and
56 automatically propagate their changes to their respective
57 configuration files.
58
59 %package devel
60 Summary:        Header files for %{kfname} development
61 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
62 Group:          X11/Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       Qt5DBus-devel >= %{qtver}
65 Requires:       Qt5Xml-devel >= %{qtver}
66 Requires:       cmake >= 3.16
67
68 %description devel
69 Header files for %{kfname} development.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe dla programistów używających %{kfname}.
73
74 %prep
75 %setup -q -n %{kfname}-%{version}
76
77 %build
78 install -d build
79 cd build
80 %cmake -G Ninja \
81         %{!?with_tests:-DBUILD_TESTING=OFF} \
82         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
83         ../
84 %ninja_build
85
86 %if %{with tests}
87 ctest
88 %endif
89
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_datadir}/kconf_update
94 %ninja_install -C build
95
96 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files -f %{kfname}5_qt.lang
105 %defattr(644,root,root,755)
106 %doc DESIGN README.md TODO
107 %ghost %{_libdir}/libKF5ConfigCore.so.5
108 %attr(755,root,root) %{_libdir}/libKF5ConfigCore.so.*.*
109 %ghost %{_libdir}/libKF5ConfigGui.so.5
110 %ghost %{_libdir}/libKF5ConfigQml.so.5
111 %attr(755,root,root) %{_libdir}/libKF5ConfigQml.so.*.*
112 %attr(755,root,root) %{_libdir}/libKF5ConfigGui.so.*.*
113 %attr(755,root,root) %{_bindir}/kreadconfig5
114 %attr(755,root,root) %{_bindir}/kwriteconfig5
115 %attr(755,root,root) %{_libexecdir}/kf5/kconf_update
116 %attr(755,root,root) %{_libexecdir}/kf5/kconfig_compiler_kf5
117 %dir %{_datadir}/kconf_update
118 %{_datadir}/qlogging-categories5/kconfig.categories
119 %{_datadir}/qlogging-categories5/kconfig.renamecategories
120
121 %files devel
122 %defattr(644,root,root,755)
123 %{_libdir}/libKF5ConfigCore.so
124 %{_libdir}/libKF5ConfigGui.so
125 %{_libdir}/libKF5ConfigQml.so
126 %{_includedir}/KF5/KConfigCore
127 %{_includedir}/KF5/KConfigGui
128 %{_includedir}/KF5/KConfigQml
129 %{_includedir}/KF5/KConfig
130 %{_libdir}/cmake/KF5Config
131 %{qt5dir}/mkspecs/modules/qt_KConfigCore.pri
132 %{qt5dir}/mkspecs/modules/qt_KConfigGui.pri
This page took 0.133496 seconds and 4 git commands to generate.