]> git.pld-linux.org Git - packages/kf5-kcodecs.git/blob - kf5-kcodecs.spec
- updated to 5.95.0
[packages/kf5-kcodecs.git] / kf5-kcodecs.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 # TODO:
5 # - runtime Requires if any
6 %define         kdeframever     5.95
7 %define         qtver           5.15.2
8 %define         kfname          kcodecs
9
10 Summary:        String encoding
11 Name:           kf5-%{kfname}
12 Version:        5.95.0
13 Release:        1
14 License:        GPL v2+/LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
17 # Source0-md5:  3078901c1fd1407844fe190fb4e60917
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Core-devel >= %{qtver}
20 BuildRequires:  Qt5Test-devel >= %{qtver}
21 BuildRequires:  cmake >= 3.16
22 BuildRequires:  gperf
23 BuildRequires:  kf5-extra-cmake-modules >= %{version}
24 BuildRequires:  ninja
25 BuildRequires:  qt5-linguist >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.736
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Requires:       Qt5Core >= %{qtver}
30 Requires:       kf5-dirs
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 KCodecs provide a collection of methods to manipulate strings using
35 various encodings. It supports:
36
37 - base64
38 - uu
39 - quoted-printable
40
41 %package devel
42 Summary:        Header files for %{kfname} development
43 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
44 Group:          X11/Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       Qt5Core-devel >= %{qtver}
47 Requires:       cmake >= 3.16
48
49 %description devel
50 Header files for %{kfname} development.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe dla programistów używających %{kfname}.
54
55 %prep
56 %setup -q -n %{kfname}-%{version}
57
58 %build
59 install -d build
60 cd build
61 %cmake -G Ninja \
62         %{!?with_tests:-DBUILD_TESTING=OFF} \
63         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
64         ../
65 %ninja_build
66
67 %if %{with tests}
68 ctest
69 %endif
70
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %ninja_install -C build
75
76 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files -f %{kfname}5_qt.lang
85 %defattr(644,root,root,755)
86 %doc README.md
87 %ghost %{_libdir}/libKF5Codecs.so.5
88 %attr(755,root,root) %{_libdir}/libKF5Codecs.so.*.*
89 %{_datadir}/qlogging-categories5/kcodecs.categories
90 %{_datadir}/qlogging-categories5/kcodecs.renamecategories
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_libdir}/libKF5Codecs.so
95 %{_includedir}/KF5/KCodecs
96 %{_libdir}/cmake/KF5Codecs
97 %{_libdir}/qt5/mkspecs/modules/qt_KCodecs.pri
This page took 0.036662 seconds and 4 git commands to generate.