]> git.pld-linux.org Git - packages/kf5-kcodecs.git/blob - kf5-kcodecs.spec
-updated to 5.24.0; fetch sources
[packages/kf5-kcodecs.git] / kf5-kcodecs.spec
1 # TODO:
2 # - runtime Requires if any
3 %define         kdeframever     5.24
4 %define         qtver           5.3.2
5 %define         kfname          kcodecs
6
7 Summary:        String encoding
8 Name:           kf5-%{kfname}
9 Version:        5.24.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  970920c17542e24d3520a05f1cf7695e
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Test-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= %{version}
20 BuildRequires:  qt5-linguist >= %{qtver}
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 Requires:       kf5-dirs
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 KCodecs provide a collection of methods to manipulate strings using
29 various encodings. It supports:
30
31 - base64
32 - uu
33 - quoted-printable
34
35 %package devel
36 Summary:        Header files for %{kfname} development
37 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
38 Group:          X11/Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for %{kfname} development.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe dla programistów używających %{kfname}.
46
47 %prep
48 %setup -q -n %{kfname}-%{version}
49
50 %build
51 install -d build
52 cd build
53 %cmake \
54         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
55         ../
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} -C build/ install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
71
72 %files -f %{kfname}5_qt.lang
73 %defattr(644,root,root,755)
74 %doc README.md
75 %attr(755,root,root) %ghost %{_libdir}/libKF5Codecs.so.5
76 %attr(755,root,root) %{_libdir}/libKF5Codecs.so.*.*
77
78 %files devel
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_libdir}/libKF5Codecs.so
81 %{_includedir}/KF5/KCodecs
82 %{_includedir}/KF5/kcodecs_version.h
83 %{_libdir}/cmake/KF5Codecs
84 %{_libdir}/qt5/mkspecs/modules/qt_KCodecs.pri
This page took 0.02866 seconds and 4 git commands to generate.