]> git.pld-linux.org Git - packages/kf5-kcodecs.git/blob - kf5-kcodecs.spec
- Up to 5.67.0.
[packages/kf5-kcodecs.git] / kf5-kcodecs.spec
1 # TODO:
2 # - runtime Requires if any
3 %define         kdeframever     5.67
4 %define         qtver           5.9.0
5 %define         kfname          kcodecs
6
7 Summary:        String encoding
8 Name:           kf5-%{kfname}
9 Version:        5.67.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  080f45c31980d514774161d1b4a30ff8
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Test-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  gperf
20 BuildRequires:  kf5-extra-cmake-modules >= %{version}
21 BuildRequires:  ninja
22 BuildRequires:  qt5-linguist >= %{qtver}
23 BuildRequires:  rpmbuild(macros) >= 1.164
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 Requires:       kf5-dirs
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 KCodecs provide a collection of methods to manipulate strings using
31 various encodings. It supports:
32
33 - base64
34 - uu
35 - quoted-printable
36
37 %package devel
38 Summary:        Header files for %{kfname} development
39 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
40 Group:          X11/Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       Qt5Core-devel >= %{qtver}
43 Requires:       cmake >= 2.6.0
44
45 %description devel
46 Header files for %{kfname} development.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe dla programistów używających %{kfname}.
50
51 %prep
52 %setup -q -n %{kfname}-%{version}
53
54 %build
55 install -d build
56 cd build
57 %cmake -G Ninja \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         ../
60 %ninja_build
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %ninja_install -C build
65
66 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %files -f %{kfname}5_qt.lang
75 %defattr(644,root,root,755)
76 %doc README.md
77 %attr(755,root,root) %ghost %{_libdir}/libKF5Codecs.so.5
78 %attr(755,root,root) %{_libdir}/libKF5Codecs.so.*.*
79 %{_datadir}/qlogging-categories5/kcodecs.categories
80
81 %files devel
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_libdir}/libKF5Codecs.so
84 %{_includedir}/KF5/KCodecs
85 %{_includedir}/KF5/kcodecs_version.h
86 %{_libdir}/cmake/KF5Codecs
87 %{_libdir}/qt5/mkspecs/modules/qt_KCodecs.pri
This page took 0.044408 seconds and 3 git commands to generate.