]> git.pld-linux.org Git - packages/kf5-extra-cmake-modules.git/blob - kf5-extra-cmake-modules.spec
7588efefca2ed1277a9188b9afa2ae2f287927fc
[packages/kf5-extra-cmake-modules.git] / kf5-extra-cmake-modules.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         orgname         extra-cmake-modules
6 %define         kdeframever     5.48
7 Summary:        Extra Cmake Modules for KF5
8 Summary(pl.UTF-8):      Dodatkowe moduły Cmake'a dla KF5
9 Name:           kf5-%{orgname}
10 Version:        5.48.0
11 Release:        1
12 License:        BSD
13 Group:          Development/Building
14 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{orgname}-%{version}.tar.xz
15 # Source0-md5:  58c0a638cf85734c03fb5228b240182e
16 Patch0:         %{orgname}-tests.patch
17 URL:            http://www.kde.org/
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  qt5-assistant >= 5.5.1
20 BuildRequires:  qt5-linguist
21 BuildRequires:  rpmbuild(macros) >= 1.698
22 BuildRequires:  sed >= 4.0
23 BuildRequires:  sphinx-pdg >= 1.2
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 %if %{with tests}
27 BuildRequires:  Qt5Core-devel >= 5.5.1
28 BuildRequires:  Qt5Gui-devel >= 5.5.1
29 BuildRequires:  Qt5Network-devel >= 5.5.1
30 BuildRequires:  Qt5Qml-devel >= 5.5.1
31 BuildRequires:  Qt5Quick-devel >= 5.5.1
32 BuildRequires:  libstdc++-devel >= 6:4.9
33 BuildRequires:  qt5-build >= 5.5.1
34 %endif
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The Extra CMake Modules package, or ECM, adds to the modules provided
39 by CMake, including both ones used by find_package() to find common
40 software and ones that can be used directly in CMakeLists.txt files to
41 perform common tasks.
42
43 In addition, it provides common build settings used in software
44 produced by the KDE community.
45
46 While the driving force of this module is to reduce duplication in
47 CMake scripts across KDE software, it is intended to be useful for any
48 software that uses the CMake build system.
49
50 %description -l pl.UTF-8
51 Pakiet Extra CMake Modules (ECM) dostarcza dodatkowe moduły do tych
52 dostarczanych przez CMake'a, zawierające te używane przez
53 find_package() do szukania popularnego oprogramowania, a także takie,
54 których można używać bezpośrednio w CMakeLists.txt do wykonywania
55 wspólnych zadań.
56
57 Ponadto pakiet dostarcza wspólne ustawienia budowana używane w
58 oprogramowaniu tworzonym przez społeczność KDE.
59
60 O ile główną motywacją tego modułu jest zmniejszenie duplikacji w
61 skryptach CMake'a w oprogramowaniu KDE, ma także być przydatny dla
62 dowolnych programów wykorzystujących system budowania CMake.
63
64 %prep
65 %setup -q -n %{orgname}-%{version}
66 %patch0 -p1
67
68 # causes make install failure after running tests
69 %{__sed} -i -e '/ECMToolchainAndroidTest/d' tests/CMakeLists.txt
70
71 %build
72 install -d build
73 cd build
74 %cmake .. \
75         %{!?with_tests:-DBUILD_TESTING=OFF}
76
77 %{__make}
78
79 %if %{with tests}
80 # GenerateSipBindings wants clang and has libclang checks incompatible with libclang >= 4
81 ctest -E GenerateSipBindings
82 %endif
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} -C build -j1 install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %{__mv} $RPM_BUILD_ROOT%{_docdir}/ECM ECM-doc
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc COPYING-CMAKE-SCRIPTS README.rst ECM-doc/*
98 %{_datadir}/ECM
99 %{_mandir}/man7/ecm*.7*
This page took 0.049537 seconds and 2 git commands to generate.