]> git.pld-linux.org Git - packages/kf5-extra-cmake-modules.git/blob - kde5-extra-cmake-modules.spec
conditional noarch subpkg (for rpm4); cleanups
[packages/kf5-extra-cmake-modules.git] / kde5-extra-cmake-modules.spec
1 # TODO where to put files and docs of KF5
2 %define         orgname extra-cmake-modules
3 %define         qt5ver  5.2.0
4
5 Summary:        Extra Cmake Modules for KF5
6 Name:           kde5-extra-cmake-modules
7 Version:        1.0.0
8 Release:        0.1
9 License:        See COPYING-CMAKE-SCRIPTS
10 Group:          X11/Libraries
11 Source0:        ftp://ftp.kde.org/pub/kde/stable/frameworks/5.0.0/%{orgname}-%{version}.tar.xz
12 # Source0-md5:  a7b9e8756fdc2b3a8518ad9f9d21dfd5
13 URL:            http://www.kde.org/
14 BuildRequires:  cmake >= 2.8.12
15 BuildRequires:  rpmbuild(macros) >= 1.164
16 BuildRequires:  sphinx-pdg
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The Extra CMake Modules package, or ECM, adds to the modules provided
21 by CMake, including both ones used by ``find_package()`` to find
22 common software and ones that can be used directly in
23 ``CMakeLists.txt`` files to perform common tasks.
24
25 In addition, it provides common build settings used in software
26 produced by the KDE community.
27
28 While the driving force of this module is to reduce duplication in
29 CMake scripts across KDE software, it is intended to be useful for any
30 software that uses the CMake build system.
31
32 %package doc
33 Summary:        Documentation for ECM
34 Group:          Documentation
35 %if "%{_rpmversion}" >= "5"
36 BuildArch:      noarch
37 %endif
38
39 %description doc
40 Documentation for ECM.
41
42 %prep
43 %setup -q -n %{orgname}-%{version}
44
45 %build
46 install -d build
47 cd build
48 %cmake \
49         ../
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} -C build/ install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc COPYING-CMAKE-SCRIPTS README.rst
64 %{_datadir}/ECM
65 %{_mandir}/man7/ecm*
66
67 %files doc
68 %defattr(644,root,root,755)
69 %{_docdir}/ECM
This page took 0.060837 seconds and 3 git commands to generate.