]> git.pld-linux.org Git - packages/js.git/commitdiff
- rel 10; build fixed auto/th/js-1.7.0-10
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 18 Oct 2016 20:24:20 +0000 (22:24 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 18 Oct 2016 20:24:20 +0000 (22:24 +0200)
js-build.patch [new file with mode: 0644]
js.spec

diff --git a/js-build.patch b/js-build.patch
new file mode 100644 (file)
index 0000000..1645c56
--- /dev/null
@@ -0,0 +1,11 @@
+--- js/src/js.c~       2007-04-20 20:45:18.000000000 +0200
++++ js/src/js.c        2016-10-18 22:22:16.509762977 +0200
+@@ -160,7 +160,7 @@
+ #endif
+     {
+         char line[256];
+-        fprintf(gOutFile, prompt);
++        fprintf(gOutFile, "%s", prompt);
+         fflush(gOutFile);
+         if (!fgets(line, sizeof line, file))
+             return JS_FALSE;
diff --git a/js.spec b/js.spec
index 310fb524564f1ea1742b57d2d401a4adca303abc..8a7fcf9c6b23b926a46d4f0617eca5c8e42cbc63 100644 (file)
--- a/js.spec
+++ b/js.spec
@@ -8,7 +8,7 @@ Summary:        JavaScript Reference Implementation
 Summary(pl.UTF-8):     Wzorcowa implementacja JavaScriptu
 Name:          js
 Version:       1.7.0
-Release:       9
+Release:       10
 Epoch:         2
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         Development/Languages
@@ -16,6 +16,7 @@ Source0:      http://ftp.mozilla.org/pub/mozilla.org/js/%{name}-%{version}.tar.gz
 # Source0-md5: 5571134c3863686b623ebe4e6b1f6fe6
 Patch0:                %{name}-makefile.patch
 Patch1:                %{name}-java.patch
+Patch2:                %{name}-build.patch
 URL:           http://www.mozilla.org/js/
 %{?with_java:BuildRequires:    jdk}
 %{?with_java:BuildRequires:    jpackage-utils}
@@ -144,6 +145,7 @@ Biblioteka statyczna implementacji JavaScript LiveConnect 3.
 %setup -q -n %{name}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 echo 'SONAME=libjs.so.1' >> src/Makefile.ref
 echo 'SONAME=libjsj.so.1' >> src/liveconnect/Makefile.ref
This page took 0.102411 seconds and 4 git commands to generate.