]> git.pld-linux.org Git - packages/iptables.git/commitdiff
- outdated
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 16 Mar 2005 22:21:11 +0000 (22:21 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    grsecurity-1.2.9rc1-iptables.patch -> 1.2

grsecurity-1.2.9rc1-iptables.patch [deleted file]

diff --git a/grsecurity-1.2.9rc1-iptables.patch b/grsecurity-1.2.9rc1-iptables.patch
deleted file mode 100644 (file)
index 8e05559..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-diff -urN iptables-1.2.8/extensions/Makefile iptables-1.2.8-new/extensions/Makefile
---- iptables-1.2.8/extensions/Makefile 2003-03-05 06:39:31.000000000 -0500
-+++ iptables-1.2.8-new/extensions/Makefile     2003-04-23 10:27:41.000000000 -0400
-@@ -5,7 +5,7 @@
- # header files are present in the include/linux directory of this iptables
- # package (HW)
- #
--PF_EXT_SLIB:=ah connlimit conntrack dscp ecn esp helper icmp iprange length limit mac mark multiport owner physdev pkttype realm rpc standard state tcp tcpmss tos ttl udp unclean CLASSIFY CONNMARK DNAT DSCP ECN LOG MARK MASQUERADE MIRROR NETMAP NOTRACK REDIRECT REJECT SAME SNAT TARPIT TCPMSS TOS TRACE TTL ULOG
-+PF_EXT_SLIB:=ah connlimit conntrack dscp ecn esp helper stealth icmp iprange length limit mac mark multiport owner physdev pkttype realm rpc standard state tcp tcpmss tos ttl udp unclean CLASSIFY CONNMARK DNAT DSCP ECN LOG MARK MASQUERADE MIRROR NETMAP NOTRACK REDIRECT REJECT SAME SNAT TARPIT TCPMSS TOS TRACE TTL ULOG IMQ
- PF6_EXT_SLIB:=eui64 hl icmpv6 length limit mac mark multiport owner standard tcp udp HL LOG MARK TRACE
- # Optionals
-diff -urN iptables-1.2.8/extensions/libipt_stealth.c iptables-1.2.8-new/extensions/libipt_stealth.c
---- iptables-1.2.8/extensions/libipt_stealth.c 1969-12-31 19:00:00.000000000 -0500
-+++ iptables-1.2.8-new/extensions/libipt_stealth.c     2003-04-23 10:27:06.000000000 -0400
-@@ -0,0 +1,64 @@
-+/* Shared library add-on to iptables to add stealth support.
-+ * Copyright (C) 2002 Brad Spengler  <spender@grsecurity.net>
-+ * This netfilter module is licensed under the GNU GPL.
-+ */
-+
-+#include <stdio.h>
-+#include <netdb.h>
-+#include <stdlib.h>
-+#include <getopt.h>
-+#include <iptables.h>
-+
-+/* Function which prints out usage message. */
-+static void
-+help(void)
-+{
-+      printf("stealth v%s takes no options\n\n", IPTABLES_VERSION);
-+}
-+
-+static struct option opts[] = {
-+      {0}
-+};
-+
-+/* Initialize the match. */
-+static void
-+init(struct ipt_entry_match *m, unsigned int *nfcache)
-+{
-+      *nfcache |= NFC_UNKNOWN;
-+}
-+
-+static int
-+parse(int c, char **argv, int invert, unsigned int *flags,
-+      const struct ipt_entry *entry,
-+      unsigned int *nfcache,
-+      struct ipt_entry_match **match)
-+{
-+      return 0;
-+}
-+
-+static void
-+final_check(unsigned int flags)
-+{
-+      return;
-+}
-+
-+static
-+struct iptables_match stealth = {
-+      NULL,
-+      "stealth",
-+      IPTABLES_VERSION,
-+      IPT_ALIGN(0),
-+      IPT_ALIGN(0),
-+      &help,
-+      &init, 
-+      &parse,
-+      &final_check,
-+      NULL,
-+      NULL,
-+      opts  
-+};
-+
-+void _init(void)
-+{
-+      register_match(&stealth);
-+}
This page took 0.065755 seconds and 4 git commands to generate.