]> git.pld-linux.org Git - packages/horde-kronolith.git/blob - horde-kronolith.spec
- migrated to apache 2.4
[packages/horde-kronolith.git] / horde-kronolith.spec
1 %define         hordeapp kronolith
2 #
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Kronolith - calendar for Horde
5 Summary(pl.UTF-8):      Kronolith - kalendarz dla Horde
6 Name:           horde-%{hordeapp}
7 Version:        2.3.5
8 Release:        3
9 License:        LGPL
10 Group:          Applications/WWW
11 Source0:        ftp://ftp.horde.org/pub/kronolith/%{hordeapp}-h3-%{version}.tar.gz
12 # Source0-md5:  3305f6f2951c863b57c39d258d796ae6
13 Source1:        %{hordeapp}-apache.conf
14 Source2:        %{hordeapp}-httpd.conf
15 URL:            http://www.horde.org/kronolith/
16 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires:       horde >= 3.1
19 Requires:       php(core) >= 4.1.0
20 Requires:       php(xml)
21 Requires:       webapps
22 Suggests:       php-pear-Date
23 Suggests:       php-pear-Date_Holidays >= 0.17.1
24 Suggests:       php-pear-XML_Serializer
25 Obsoletes:      kronolith
26 Conflicts:      apache-base < 2.4.0-1
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _noautoreq      'pear(Horde.*)'
31
32 %define         hordedir        /usr/share/horde
33 %define         _appdir         %{hordedir}/%{hordeapp}
34 %define         _webapps        /etc/webapps
35 %define         _webapp         horde-%{hordeapp}
36 %define         _sysconfdir     %{_webapps}/%{_webapp}
37
38 %description
39 Kronolith is the Horde calendar application. It provides a stable and
40 featureful individual calendar system for every Horde user, with
41 integrated collaboration/scheduling features. It makes extensive use
42 of the Horde Framework to provide integration with other applications.
43
44 Right now, Kronolith implements a solid, stand-alone calendar system,
45 allowing repeating events, all-day events, custom fields, keywords,
46 shared calendars, iCalendar support, generation of free/busy
47 information, and managing multiple users through Horde Authentication.
48 The calendar API that Kronolith uses is abstracted such that it could
49 work with any backend, but right now we provide SQL (abstracted to
50 support most databases, including MySQL, PostgreSQL, Oracle, and MSSQL
51 via PEAR DB), MCAL, and Kolab backend libraries.
52
53 %description -l pl.UTF-8
54 Kronolith to kalendarz będący aplikacją dla Horde. Dostarcza stabilny
55 system kalendarza o dużych możliwościach dla każdego użytkownika Horde
56 wraz ze zintegrowanymi możliwościami współpracy/planowania.
57 Intensywnie wykorzystuje szkielet Horde w celu integracji z innymi
58 aplikacjami.
59
60 Jak na razie Kronolith implementuje solidny, samodzielny system
61 kalendarza, pozwalający na powtarzanie zdarzeń, zdarzenia codzienne,
62 własne pola, słowa kluczowe, współdzielone kalendarze, obsługę
63 iCalendar, generowanie informacji o wolnym i zajętym czasie oraz
64 zarządzanie wieloma użytkownikami poprzez uwierzytelnianie Horde. API
65 kalendarza używane przez Kronolith jest abstrakcyjne, tak że może
66 działać z dowolnym backendem, ale aktualnie dostarczane są biblioteki
67 backendów SQL (jako abstrakcja do obsługi większości baz, w tym MySQL,
68 PostgreSQL, Oracle i MS SQL poprzez PEAR DB), MCAL i Kolab.
69
70 %prep
71 %setup -q -n %{hordeapp}-h3-%{version}
72
73 for i in config/*.dist; do
74         mv $i config/$(basename $i .dist)
75 done
76
77 # Described in documentation as dangerous file...
78 rm test.php
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/docs}
83
84 cp -a *.php $RPM_BUILD_ROOT%{_appdir}
85 cp -a config/* $RPM_BUILD_ROOT%{_sysconfdir}
86 echo '<?php ?>' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.php
87 touch $RPM_BUILD_ROOT%{_sysconfdir}/conf.php.bak
88 cp -a calendars feed js lib locale templates themes $RPM_BUILD_ROOT%{_appdir}
89 cp -a docs/CREDITS $RPM_BUILD_ROOT%{_appdir}/docs
90
91 ln -s %{_sysconfdir} $RPM_BUILD_ROOT%{_appdir}/config
92 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
93 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 if [ ! -f %{_sysconfdir}/conf.php.bak ]; then
100         install /dev/null -o root -g http -m660 %{_sysconfdir}/conf.php.bak
101 fi
102
103 if [ "$1" = 1 ]; then
104 %banner %{name} -e <<EOF
105 IMPORTANT:
106 If you are installing Kronolith for the first time, you must now
107 create the Kronolith database tables. Look into directory
108 %{_docdir}/%{name}-%{version}/sql
109 to find out how to do this for your database.
110 EOF
111 fi
112
113 %triggerin -- apache1 < 1.3.37-3, apache1-base
114 %webapp_register apache %{_webapp}
115
116 %triggerun -- apache1 < 1.3.37-3, apache1-base
117 %webapp_unregister apache %{_webapp}
118
119 %triggerin -- apache-base
120 %webapp_register httpd %{_webapp}
121
122 %triggerun -- apache-base
123 %webapp_unregister httpd %{_webapp}
124
125 %files
126 %defattr(644,root,root,755)
127 %doc README docs/* scripts/*
128 %dir %attr(750,root,http) %{_sysconfdir}
129 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
130 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
131 %attr(660,root,http) %config(noreplace) %{_sysconfdir}/conf.php
132 %attr(660,root,http) %config(noreplace) %ghost %{_sysconfdir}/conf.php.bak
133 %attr(640,root,http) %config(noreplace) %{_sysconfdir}/[!c]*.php
134 %attr(640,root,http) %{_sysconfdir}/conf.xml
135
136 %dir %{_appdir}
137 %{_appdir}/*.php
138 %{_appdir}/calendars
139 %{_appdir}/config
140 %{_appdir}/docs
141 %{_appdir}/feed
142 %{_appdir}/js
143 %{_appdir}/lib
144 %{_appdir}/locale
145 %{_appdir}/templates
146 %{_appdir}/themes
This page took 0.098575 seconds and 3 git commands to generate.