]> git.pld-linux.org Git - packages/gvfs.git/blob - gvfs.spec
- BR openssh-clients, meson is a PoS
[packages/gvfs.git] / gvfs.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # docs building and packaging
4 %bcond_without  admin   # admin backend
5 %bcond_without  afc     # AFC backend
6 %bcond_without  afp     # AFP support
7 %bcond_without  archive # archive support
8 %bcond_without  avahi   # DNS-SD / Avahi support
9 %bcond_without  bluray  # bluray metadata support
10 %bcond_without  cdda    # CDDA backend
11 %bcond_without  fuse    # FUSE support
12 %bcond_without  goa     # GOA backend
13 %bcond_without  google  # Google backend
14 %bcond_with     gdu     # GDU (Gnome Disk Utility) volume monitor (3.0.2 <= v < 3.4)
15 %bcond_without  gphoto2 # gphoto2 support
16 %bcond_without  gtk     # GTK+
17 %bcond_without  gudev   # gudev support (if disabled, HAL could be used)
18 %bcond_without  http    # HTTP/DAV backend
19 %bcond_without  keyring # GNOME Keyring support in gvfs and udisks plugin
20 %bcond_without  mtp     # MTP support
21 %bcond_without  nfs     # NFS support
22 %bcond_without  samba   # SMB support
23 %bcond_without  systemd # libsystemd-login support
24 %bcond_without  udev    # udev support (needed also for gphoto2, mtp, udisks2)
25 %bcond_without  udisks2 # libudisks2 support
26
27 %if %{without gudev}
28 %undefine       with_gphoto2
29 %undefine       with_mtp
30 %undefine       with_udisks2
31 %endif
32
33 %ifarch s390 s390x
34 %undefine       with_afc
35 %endif
36
37 Summary:        gvfs - userspace virtual filesystem
38 Summary(pl.UTF-8):      gvfs - wirtualny system plików w przestrzeni użytkownika
39 Name:           gvfs
40 Version:        1.38.2
41 Release:        1
42 License:        LGPL v2+
43 Group:          Libraries
44 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gvfs/1.38/%{name}-%{version}.tar.xz
45 # Source0-md5:  20e31b85a73c6a42aa8c2cabf3d6698b
46 Patch0:         set_attributes_from_info-v1.patch
47 URL:            https://live.gnome.org/gvfs
48 %{?with_avahi:BuildRequires:    avahi-devel >= 0.6.22}
49 %{?with_avahi:BuildRequires:    avahi-glib-devel >= 0.6.22}
50 BuildRequires:  dbus-devel
51 %{?with_doc:BuildRequires:      docbook-dtd42-xml}
52 %{?with_doc:BuildRequires:      docbook-style-xsl}
53 BuildRequires:  gcr-devel >= 3
54 BuildRequires:  gettext-tools >= 0.19.4
55 BuildRequires:  glib2-devel >= 1:2.52.0
56 %{?with_gdu:BuildRequires:      gnome-disk-utility-devel < 3.4}
57 %{?with_gdu:BuildRequires:      gnome-disk-utility-devel >= 3.0.2}
58 %{?with_goa:BuildRequires:      gnome-online-accounts-devel >= 3.8.0}
59 %{?with_google:BuildRequires:   gnome-online-accounts-devel >= 3.18.0}
60 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.0}
61 %{?with_archive:BuildRequires:  libarchive-devel >= 3.0.22}
62 %{?with_bluray:BuildRequires:   libbluray-devel}
63 %{?with_admin:BuildRequires:    libcap-devel}
64 %{?with_cdda:BuildRequires:     libcdio-paranoia-devel >= 0.78.2}
65 %{?with_fuse:BuildRequires:     libfuse-devel >= 2.8.0}
66 BuildRequires:  libgcrypt-devel >= 1.2.2
67 %{?with_google:BuildRequires:   libgdata-devel >= 0.17.7}
68 %{?with_gphoto2:BuildRequires:  libgphoto2-devel >= 2.5.0}
69 %{?with_afc:BuildRequires:      libimobiledevice-devel >= 1.2.0}
70 %{?with_mtp:BuildRequires:      libmtp-devel >= 1.1.12}
71 %{?with_nfs:BuildRequires:      libnfs-devel >= 1.9.8}
72 %{?with_afc:BuildRequires:      libplist-devel >= 0.15}
73 %{?with_keyring:BuildRequires:  libsecret-devel}
74 %{?with_samba:BuildRequires:    libsmbclient-devel >= 3.4}
75 %{?with_http:BuildRequires:     libsoup-devel >= 2.42.0}
76 BuildRequires:  libtool >= 2:2.2
77 BuildRequires:  libusb-devel >= 1.0.21
78 BuildRequires:  libxml2-devel >= 1:2.6.31
79 %{?with_doc:BuildRequires:      libxslt-progs}
80 BuildRequires:  meson >= 0.46.0
81 BuildRequires:  ninja
82 BuildRequires;  openssh-clients
83 BuildRequires:  pkgconfig
84 %{?with_admin:BuildRequires:    polkit-devel}
85 BuildRequires:  rpmbuild(macros) >= 1.727
86 %{?with_systemd:BuildRequires:  systemd-devel >= 206}
87 BuildRequires:  tar >= 1:1.22
88 %{?with_udev:BuildRequires:     udev-devel >= 1:138}
89 %{?with_gudev:BuildRequires:    udev-glib-devel >= 1:147}
90 %{?with_udisks2:BuildRequires:  udisks2-devel >= 1.97.0}
91 BuildRequires:  xz
92 Requires(post,postun):  glib2 >= 1:2.52.0
93 Requires:       %{name}-libs = %{version}-%{release}
94 %{?with_avahi:Requires: avahi-glib >= 0.6.22}
95 %{?with_cdda:Requires:  libcdio-paranoia >= 0.78.2}
96 %{?with_nfs:Requires:   libnfs >= 1.9.8}
97 Requires:       libplist >= 0.15
98 Requires:       libsoup >= 2.42.0
99 Requires:       libusb >= 1.0.21
100 Requires:       libxml2 >= 1:2.6.31
101 %{?with_gudev:Requires: udev-glib >= 1:147}
102 %{?with_udev:Requires:  udev-libs >= 1:138}
103 %{?with_udisks2:Requires:       udisks2 >= 1.97.0}
104 %{?with_afc:Suggests:   %{name}-afc}
105 %{?with_afp:Suggests:   %{name}-afp}
106 %{?with_archive:Suggests:       %{name}-archive}
107 %{?with_fuse:Suggests:  %{name}-fuse}
108 %{?with_goa:Suggests:   %{name}-goa}
109 %{?with_google:Suggests:        %{name}-google}
110 %{?with_gphoto2:Suggests:       %{name}-gphoto2}
111 %{?with_mtp:Suggests:   %{name}-mtp}
112 %{?with_samba:Suggests: %{name}-smb}
113 Obsoletes:      bash-completion-gvfs
114 Obsoletes:      gnome-mount <= 0.8
115 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
117 %define         _libexecdir     %{_libdir}/%{name}
118
119 %description
120 gvfs is a userspace virtual filesystem where mount runs as a separate
121 processes which you talk to via D-BUS. It contains a gio module that
122 seamlessly adds gvfs support to all applications using the gio API.
123
124 %description -l pl.UTF-8
125 gvfs to wirtualny system plik w przestrzeni użytkownika. Montowanie w
126 nim działa jako oddzielny proces, z którym komunikacja odbywa się
127 przez D-BUS. Zawiera moduł gio dodający w sposób przezroczysty obsługę
128 gfvs-a do wszystkich aplikacji używających API gio.
129
130 %package libs
131 Summary:        Common GVFS shared libraries
132 Summary(pl.UTF-8):      Wspólne biblioteki współdzielone GVFS
133 Group:          Libraries
134 Requires:       glib2 >= 1:2.52.0
135 Conflicts:      gvfs < 1.22.3-2
136
137 %description libs
138 Common GVFS (private) shared libraries.
139
140 %description libs -l pl.UTF-8
141 Wspólne (prywatne) biblioteki współdzielone GVFS.
142
143 %package devel
144 Summary:        Header files for gvfs library
145 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gvfs
146 Group:          Development/Libraries
147 Requires:       %{name}-libs = %{version}-%{release}
148 Requires:       glib2-devel >= 1:2.52.0
149
150 %description devel
151 Header files for gvfs library.
152
153 %description devel -l pl.UTF-8
154 Pliki nagłówkowe biblioteki gvfs.
155
156 %package afc
157 Summary:        AFC support for gvfs
158 Summary(pl.UTF-8):      Obsługa AFC dla gvfs
159 Group:          Libraries
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       libimobiledevice >= 1.2.0
162 Requires:       usbmuxd
163
164 %description afc
165 This package provides support for reading files on mobile devices
166 including phones and music players to applications using gvfs.
167
168 %description afc -l pl.UTF-8
169 Ten pakiet zapewnia obsługę odczytu plików na urządzeniach
170 przenośnych, w tym telefonach i odtwarzaczach muzyki dla aplikacji
171 wykorzystujących gvfs.
172
173 %package afp
174 Summary:        AFP support for gvfs
175 Summary(pl.UTF-8):      Obsługa AFP dla gvfs
176 Group:          Libraries
177 Requires:       %{name} = %{version}-%{release}
178
179 %description afp
180 This package provides support for reading and writing files on Mac OS
181 X and original Mac OS network shares via Apple Filing Protocol to
182 applications using gvfs.
183
184 %description afp -l pl.UTF-8
185 Ten pakiet zapewnia obsługę odczytu i zapisu plików na udziałach
186 sieciowych Mac OS X oraz oryginalnego Mac OS poprzez Apple Filing
187 Protocol dla aplikacji wykorzystujących gvfs.
188
189 %package archive
190 Summary:        Archiving support for gvfs
191 Summary(pl.UTF-8):      Obsługa archiwów dla gvfs
192 Group:          Libraries
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       libarchive >= 3.0.22
195
196 %description archive
197 This package provides support for accessing files inside Zip and Tar
198 archives, as well as ISO images, to applications using gvfs.
199
200 %description archive -l pl.UTF-8
201 Ten pakiet zapewnia dostęp do plików wewnątrz archiwów Zip i Tar oraz
202 obrazów ISO dla aplikacji wykorzystujących gvfs.
203
204 %package fuse
205 Summary:        FUSE support for gvfs
206 Summary(pl.UTF-8):      Obsługa FUSE dla gvfs
207 Group:          Libraries
208 Requires:       %{name} = %{version}-%{release}
209 Requires:       libfuse >= 2.8.0
210
211 %description fuse
212 This package provides support for applications not using gio to access
213 the gvfs filesystems.
214
215 %description fuse -l pl.UTF-8
216 Ten pakiet zapewnia obsługę aplikacji nie używających gio do dostępu
217 do systemów plików gvfs.
218
219 %package goa
220 Summary:        GOA support for gvfs
221 Summary(pl.UTF-8):      Obsługa GOA dla gvfs
222 Group:          Libraries
223 Requires:       %{name} = %{version}-%{release}
224 Requires:       gnome-online-accounts-libs >= 3.8.0
225
226 %description goa
227 This package provides seamless integration with gnome-online-accounts
228 file services.
229
230 %description goa -l pl.UTF-8
231 Ten pakiet zapewnia przezroczystą integrację z usługami plikowymi
232 gnome-online-accounts.
233
234 %package google
235 Summary:        Google Drive support for gvfs
236 Summary(pl.UTF-8):      Obsługa Google Drive dla gvfs
237 Group:          Libraries
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       gnome-online-accounts-libs >= 3.18.0
240 Requires:       libgdata >= 0.17.7
241
242 %description google
243 This package provides support for Google Drive to applications using
244 gvfs.
245
246 %description google -l pl.UTF-8
247 Ten pakiet zapewnia obsługę Google Drive dla aplikacji
248 wykorzystujących gvfs.
249
250 %package gphoto2
251 Summary:        gphoto2 support for gvfs
252 Summary(pl.UTF-8):      Obsługa gphoto2 dla gvfs
253 Group:          Libraries
254 Requires:       %{name} = %{version}-%{release}
255
256 %description gphoto2
257 This package provides support for reading and writing files on PTP
258 based cameras (Picture Transfer Protocol) and MTP based media players
259 (Media Transfer Protocol) to applications using gvfs.
260
261 %description gphoto2 -l pl.UTF-8
262 Ten pakiet zapewnia obsługę odczytu i zapisu plików na aparatach
263 obsługujących protokół PTP (Picture Transfer Protocol) oraz
264 odtwarzaczach multimedialnych obsługujących protokół MTP (Media
265 Transfer Protocol) dla aplikacji wykorzystujących gvfs.
266
267 %package mtp
268 Summary:        MTP support for gvfs
269 Summary(pl.UTF-8):      Obsługa MTP dla gvfs
270 Group:          Libraries
271 Requires:       %{name} = %{version}-%{release}
272 Requires:       libmtp >= 1.1.12
273
274 %description mtp
275 This package provides support for reading and writing files on MTP
276 based devices (Media Transfer Protocol) to applications using gvfs.
277
278 %description mtp -l pl.UTF-8
279 Ten pakiet zapewnia obsługę odczytu i zapisu plików na urządzeniach
280 obsługujących protokół MTP (Media Transfer Protocol) dla aplikacji
281 wykorzystujących gvfs.
282
283 %package smb
284 Summary:        Windows fileshare support for gvfs
285 Summary(pl.UTF-8):      Obsługa udziałów sieciowych Windows dla gvfs
286 Group:          Libraries
287 Requires:       %{name} = %{version}-%{release}
288
289 %description smb
290 This package provides support for reading and writing files on Windows
291 shares (SMB) to applications using gvfs.
292
293 %description smb -l pl.UTF-8
294 Ten pakiet zapewnia obsługę odczytu i zapisu plików na udziałach
295 sieciowych Windows (SMB) dla aplikacji wykorzystujących gvfs.
296
297 %prep
298 %setup -q
299 #%%patch0 -p1
300
301 %build
302 %meson build \
303         -Dadmin=%{?with_admin:true}%{!?with_admin:false} \
304         -Dafc=%{?with_afc:true}%{!?with_afc:false} \
305         -Dafp=%{?with_afp:true}%{!?with_afp:false} \
306         -Darchive=%{?with_archive:true}%{!?with_archive:false} \
307         -Davahi=%{?with_avahi:true}%{!?with_avahi:false} \
308         -Dbluray=%{?with_bluray:true}%{!?with_bluray:false} \
309         -Dcdda=%{?with_cdda:true}%{!?with_cdda:false} \
310         -Ddocumentation=%{?with_doc:true}%{!?with_doc:false} \
311         -Dman=%{?with_doc:true}%{!?with_doc:false} \
312         -Dfuse=%{?with_fuse:true}%{!?with_fuse:false} \
313         -Dgdu=%{?with_gdu:true}%{!?with_gdu:false} \
314         -Dgoa=%{?with_goa:true}%{!?with_goa:false} \
315         -Dgoogle=%{?with_google:true}%{!?with_google:false} \
316         -Dgphoto2=%{?with_gphoto2:true}%{!?with_gphoto2:false} \
317         -Dgtk=%{?with_gtk:true}%{!?with_gtk:false} \
318         -Dgudev=%{?with_gudev:true}%{!?with_gudev:false} \
319         -Dhttp=%{?with_http:true}%{!?with_http:false} \
320         -Dkeyring=%{?with_keyring:true}%{!?with_keyring:false} \
321         -Dlibmtp=%{?with_mtp:true}%{!?with_mtp:false} \
322         -Dnfs=%{?with_nfs:true}%{!?with_nfs:false} \
323         -Dsamba=%{?with_samba:true}%{!?with_samba:false} \
324         -Dlogind=%{?with_systemd:true}%{!?with_systemd:false} \
325         -Dudev=%{?with_udev:true}%{!?with_udev:false} \
326         -Dudisks2=%{?with_udisks2:true}%{!?with_udisks2:false}
327
328 %meson_build -C build
329
330 %install
331 rm -rf $RPM_BUILD_ROOT
332
333 install -d $RPM_BUILD_ROOT%{bash_compdir}
334 %meson_install -C build
335
336 %find_lang gvfs
337
338 %clean
339 rm -rf $RPM_BUILD_ROOT
340
341 # Reload .mount files
342 %define reload_mount_files killall -USR1 gvfsd >/dev/null 2>&1 || :;
343
344 %post
345 %glib_compile_schemas
346 umask 022
347 %{_bindir}/gio-querymodules %{_libdir}/gio/modules
348 %reload_mount_files
349
350 %postun
351 if [ "$1" = "0" ]; then
352         %glib_compile_schemas
353 fi
354 umask 022
355 %{_bindir}/gio-querymodules %{_libdir}/gio/modules
356 exit 0
357
358 # Reload .mount files when single subpackage is installed:
359 %post afc
360 %reload_mount_files
361
362 %post archive
363 %reload_mount_files
364
365 %post goa
366 %reload_mount_files
367
368 %post google
369 %reload_mount_files
370
371 %post gphoto2
372 %reload_mount_files
373
374 %post mtp
375 %reload_mount_files
376
377 %post smb
378 %glib_compile_schemas
379 %reload_mount_files
380
381 %postun smb
382 if [ "$1" = "0" ]; then
383         %glib_compile_schemas
384 fi
385
386 %files -f gvfs.lang
387 %defattr(644,root,root,755)
388 %doc CONTRIBUTING.md NEWS README.md
389 %attr(755,root,root) %{_libdir}/gio/modules/libgioremote-volume-monitor.so
390 %attr(755,root,root) %{_libdir}/gio/modules/libgvfsdbus.so
391 #%dir %{_libexecdir}  # equal %{_libdir}/%{name}, packaged in -libs
392 %attr(755,root,root) %{_libexecdir}/gvfsd
393 %attr(755,root,root) %{_libexecdir}/gvfsd-burn
394 %attr(755,root,root) %{_libexecdir}/gvfsd-computer
395 %attr(755,root,root) %{_libexecdir}/gvfsd-ftp
396 %attr(755,root,root) %{_libexecdir}/gvfsd-localtest
397 %attr(755,root,root) %{_libexecdir}/gvfsd-metadata
398 %attr(755,root,root) %{_libexecdir}/gvfsd-network
399 %attr(755,root,root) %{_libexecdir}/gvfsd-sftp
400 %attr(755,root,root) %{_libexecdir}/gvfsd-trash
401 %{_datadir}/dbus-1/services/org.gtk.vfs.Daemon.service
402 %{_datadir}/dbus-1/services/org.gtk.vfs.Metadata.service
403 %dir %{_datadir}/gvfs
404 %dir %{_datadir}/gvfs/mounts
405 %dir %{_datadir}/gvfs/remote-volume-monitors
406 %{_datadir}/gvfs/mounts/burn.mount
407 %{_datadir}/gvfs/mounts/computer.mount
408 %{_datadir}/gvfs/mounts/ftp.mount
409 %{_datadir}/gvfs/mounts/ftps.mount
410 %{_datadir}/gvfs/mounts/localtest.mount
411 %{_datadir}/gvfs/mounts/network.mount
412 %{_datadir}/gvfs/mounts/sftp.mount
413 %{_datadir}/gvfs/mounts/trash.mount
414 %{_datadir}/glib-2.0/schemas/org.gnome.system.gvfs.enums.xml
415 %{systemduserunitdir}/gvfs-daemon.service
416 %{systemduserunitdir}/gvfs-metadata.service
417
418 # admin
419 %if %{with admin}
420 %attr(755,root,root) %{_libexecdir}/gvfsd-admin
421 %{_datadir}/gvfs/mounts/admin.mount
422 %{_datadir}/polkit-1/actions/org.gtk.vfs.file-operations.policy
423 %{_datadir}/polkit-1/rules.d/org.gtk.vfs.file-operations.rules
424 %endif
425
426 # cdda
427 %if %{with cdda}
428 %attr(755,root,root) %{_libexecdir}/gvfsd-cdda
429 %{_datadir}/gvfs/mounts/cdda.mount
430 %endif
431
432 # http
433 %if %{with http}
434 %attr(755,root,root) %{_libexecdir}/gvfsd-dav
435 %attr(755,root,root) %{_libexecdir}/gvfsd-http
436 %{_datadir}/gvfs/mounts/http.mount
437 %{_datadir}/gvfs/mounts/dav.mount
438 %{?with_avahi:%{_datadir}/gvfs/mounts/dav+sd.mount}
439 %endif
440
441 # gtk
442 %if %{with gtk}
443 %attr(755,root,root) %{_libexecdir}/gvfsd-recent
444 %{_datadir}/gvfs/mounts/recent.mount
445 %endif
446
447 # nfs
448 %if %{with nfs}
449 %attr(755,root,root) %{_libexecdir}/gvfsd-nfs
450 %{_datadir}/gvfs/mounts/nfs.mount
451 %endif
452
453 # udisks2
454 %if %{with udisks2}
455 %attr(755,root,root) %{_libexecdir}/gvfs-udisks2-volume-monitor
456 %{_datadir}/dbus-1/services/org.gtk.vfs.UDisks2VolumeMonitor.service
457 %{_datadir}/gvfs/remote-volume-monitors/udisks2.monitor
458 %{systemduserunitdir}/gvfs-udisks2-volume-monitor.service
459 %endif
460
461 # avahi
462 %if %{with avahi}
463 %attr(755,root,root) %{_libexecdir}/gvfsd-dnssd
464 %{_datadir}/gvfs/mounts/dns-sd.mount
465 %{_datadir}/GConf/gsettings/gvfs-dns-sd.convert
466 %{_datadir}/glib-2.0/schemas/org.gnome.system.dns_sd.gschema.xml
467 %endif
468
469 %if %{with doc}
470 %{_mandir}/man1/gvfsd.1*
471 %{_mandir}/man1/gvfsd-metadata.1*
472 %{_mandir}/man7/gvfs.7*
473 %endif
474
475 %files libs
476 %defattr(644,root,root,755)
477 %dir %{_libdir}/%{name}
478 %attr(755,root,root) %{_libdir}/%{name}/libgvfscommon.so
479 %attr(755,root,root) %{_libdir}/%{name}/libgvfsdaemon.so
480
481 %files devel
482 %defattr(644,root,root,755)
483 %{_includedir}/gvfs-client
484
485 %if %{with afc}
486 %files afc
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{_libexecdir}/gvfs-afc-volume-monitor
489 %attr(755,root,root) %{_libexecdir}/gvfsd-afc
490 %{_datadir}/dbus-1/services/org.gtk.vfs.AfcVolumeMonitor.service
491 %{_datadir}/gvfs/mounts/afc.mount
492 %{_datadir}/gvfs/mounts/ftpis.mount
493 %{_datadir}/gvfs/remote-volume-monitors/afc.monitor
494 %{systemduserunitdir}/gvfs-afc-volume-monitor.service
495 %endif
496
497 %if %{with afp}
498 %files afp
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_libexecdir}/gvfsd-afp
501 %attr(755,root,root) %{_libexecdir}/gvfsd-afp-browse
502 %{_datadir}/gvfs/mounts/afp-browse.mount
503 %{_datadir}/gvfs/mounts/afp.mount
504 %endif
505
506 %if %{with archive}
507 %files archive
508 %defattr(644,root,root,755)
509 %attr(755,root,root) %{_libexecdir}/gvfsd-archive
510 %{_datadir}/gvfs/mounts/archive.mount
511 %endif
512
513 %if %{with fuse}
514 %files fuse
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_libexecdir}/gvfsd-fuse
517 %if %{with doc}
518 %{_mandir}/man1/gvfsd-fuse.1*
519 %endif
520 %if %{with systemd}
521 # FIXME: reusing USE_LIBSYSTEMD_LOGIN as systemd has no universal header or pkg-config file
522 %{systemdtmpfilesdir}/gvfsd-fuse-tmpfiles.conf
523 %endif
524 %endif
525
526 %if %{with goa}
527 %files goa
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libexecdir}/gvfs-goa-volume-monitor
530 %{_datadir}/dbus-1/services/org.gtk.vfs.GoaVolumeMonitor.service
531 %{_datadir}/gvfs/remote-volume-monitors/goa.monitor
532 %{systemduserunitdir}/gvfs-goa-volume-monitor.service
533 %endif
534
535 %if %{with google}
536 %files google
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_libexecdir}/gvfsd-google
539 %{_datadir}/gvfs/mounts/google.mount
540 %endif
541
542 %if %{with gphoto2}
543 %files gphoto2
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libexecdir}/gvfs-gphoto2-volume-monitor
546 %attr(755,root,root) %{_libexecdir}/gvfsd-gphoto2
547 %{_datadir}/dbus-1/services/org.gtk.vfs.GPhoto2VolumeMonitor.service
548 %{_datadir}/gvfs/mounts/gphoto2.mount
549 %{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor
550 %{systemduserunitdir}/gvfs-gphoto2-volume-monitor.service
551 %endif
552
553 %if %{with mtp}
554 %files mtp
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_libexecdir}/gvfs-mtp-volume-monitor
557 %attr(755,root,root) %{_libexecdir}/gvfsd-mtp
558 %{_datadir}/dbus-1/services/org.gtk.vfs.MTPVolumeMonitor.service
559 %{_datadir}/gvfs/mounts/mtp.mount
560 %{_datadir}/gvfs/remote-volume-monitors/mtp.monitor
561 %{systemduserunitdir}/gvfs-mtp-volume-monitor.service
562 %endif
563
564 %if %{with samba}
565 %files smb
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_libexecdir}/gvfsd-smb
568 %attr(755,root,root) %{_libexecdir}/gvfsd-smb-browse
569 %{_datadir}/gvfs/mounts/smb-browse.mount
570 %{_datadir}/gvfs/mounts/smb.mount
571 %{_datadir}/glib-2.0/schemas/org.gnome.system.smb.gschema.xml
572 %{_datadir}/GConf/gsettings/gvfs-smb.convert
573 %endif
This page took 0.150368 seconds and 3 git commands to generate.