]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
- updated to 2.27.1, BRs bumped
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - FTL_JIT on !x86_64?
3 # - WEB_RTC+MEDIA_STREAM (BR: openwebrtc)
4 #
5 # Conditional build:
6 %bcond_without  gtk2            # WebKitPluginProcess2 to load GTK+ 2.x based plugins
7 %bcond_without  introspection   # disable introspection
8 %bcond_with     cairogl         # accelerated 2D canvas using cairo-gl
9 %bcond_without  wayland         # Wayland target (requires GTK+ wayland target)
10 #
11 # it's not possible to build this with debuginfo on 32bit archs due to
12 # memory constraints during linking
13 %ifarch %{ix86} x32
14 %define         _enable_debug_packages          0
15 %endif
16 Summary:        Port of WebKit embeddable web component to GTK+ 3
17 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
18 Name:           gtk-webkit4
19 Version:        2.27.1
20 Release:        1
21 License:        BSD-like
22 Group:          X11/Libraries
23 Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
24 # Source0-md5:  6ec70ea8267c3a7462285eaecd35510a
25 Patch0:         x32.patch
26 Patch1:         %{name}-icu59.patch
27 Patch2:         %{name}-gir.patch
28 URL:            https://webkitgtk.org/
29 BuildRequires:  /usr/bin/ld.gold
30 BuildRequires:  EGL-devel
31 BuildRequires:  OpenGL-GLX-devel
32 BuildRequires:  at-spi2-core-devel >= 2.6.0
33 BuildRequires:  atk-devel
34 BuildRequires:  bison >= 2.3
35 BuildRequires:  bubblewrap >= 0.3.1
36 BuildRequires:  cairo-devel >= 1.16.0
37 BuildRequires:  cmake >= 3.10
38 BuildRequires:  docbook-dtd412-xml
39 BuildRequires:  enchant2-devel >= 2
40 BuildRequires:  flex >= 2.5.34
41 BuildRequires:  fontconfig-devel >= 2.13.0
42 BuildRequires:  freetype-devel >= 1:2.9.0
43 BuildRequires:  gcc-c++ >= 6:7.3.0
44 BuildRequires:  geoclue2-devel >= 2.1.5
45 BuildRequires:  gettext-devel
46 BuildRequires:  glib2-devel >= 1:2.44
47 BuildRequires:  glibc-misc
48 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
49 BuildRequires:  gperf >= 3.0.1
50 BuildRequires:  gstreamer-devel >= 1.14
51 BuildRequires:  gstreamer-gl-devel >= 1.8.3
52 # mpegts with -DUSE_GSTREAMER_MPEGTS=ON
53 #BuildRequires: gstreamer-plugins-bad-devel >= 1.8.3
54 # app,audio,fft,pbutils,tag,video
55 BuildRequires:  gstreamer-plugins-base-devel >= 1.8.3
56 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.24.10}
57 BuildRequires:  gtk+3-devel >= 3.22.0
58 BuildRequires:  gtk-doc >= 1.10
59 BuildRequires:  harfbuzz-devel >= 1.4.2
60 BuildRequires:  harfbuzz-icu-devel >= 1.4.2
61 BuildRequires:  hyphen-devel
62 BuildRequires:  libgcrypt-devel >= 1.7.0
63 BuildRequires:  libicu-devel >= 59
64 BuildRequires:  libjpeg-devel
65 BuildRequires:  libnotify-devel
66 BuildRequires:  libpng-devel
67 BuildRequires:  libsecret-devel
68 BuildRequires:  libsoup-devel >= 2.54
69 BuildRequires:  libstdc++-devel >= 6:6.0.0
70 BuildRequires:  libtasn1-devel
71 BuildRequires:  libwebp-devel
72 BuildRequires:  libwpe-devel >= 1.3.0
73 BuildRequires:  libxml2-devel >= 1:2.8.0
74 BuildRequires:  libxslt-devel >= 1.1.7
75 BuildRequires:  openjpeg2-devel >= 2.2.0
76 BuildRequires:  pango-devel >= 1:1.32.0
77 BuildRequires:  perl-base >= 1:5.10.0
78 BuildRequires:  pkgconfig
79 %if %{with cairogl}
80 BuildRequires:  pkgconfig(cairo-egl)
81 BuildRequires:  pkgconfig(cairo-gl)
82 BuildRequires:  pkgconfig(cairo-glx)
83 %endif
84 BuildRequires:  python >= 1:2.7.0
85 BuildRequires:  rpmbuild(macros) >= 1.699
86 BuildRequires:  ruby >= 1:1.9
87 BuildRequires:  ruby-modules >= 1:1.9
88 BuildRequires:  sqlite3-devel >= 3
89 BuildRequires:  tar >= 1:1.22
90 BuildRequires:  wpebackend-fdo-devel >= 1.4.0
91 BuildRequires:  woff2-devel >= 1.0.2
92 BuildRequires:  xdg-dbus-proxy
93 BuildRequires:  xorg-lib-libXcomposite-devel
94 BuildRequires:  xorg-lib-libXdamage-devel
95 BuildRequires:  xorg-lib-libXrender-devel
96 BuildRequires:  xorg-lib-libXt-devel
97 BuildRequires:  xz
98 BuildRequires:  zlib-devel
99 Requires:       cairo >= 1.16.0
100 Requires:       fontconfig-libs >= 2.13.0
101 Requires:       freetype >= 1:2.9.0
102 Requires:       glib2 >= 1:2.40
103 Requires:       gstreamer >= 1.2.3
104 Requires:       gstreamer-plugins-base >= 1.2.3
105 %{?with_gtk2:Requires:  gtk+2 >= 2:2.24.10}
106 Requires:       gtk+3 >= 3.12.0
107 Requires:       harfbuzz >= 1.4.2
108 Requires:       libsoup >= 2.48
109 Requires:       libxml2 >= 1:2.8.0
110 Requires:       libxslt >= 1.1.7
111 Requires:       openjpeg2 >= 2.2.0
112 Requires:       pango >= 1:1.32.0
113 Requires:       woff2 >= 1.0.2
114 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
115 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
116 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 # __once_call, __once_called non-function symbols from libstdc++
120 %define         skip_post_check_so      lib.*gtk-4.0.*
121
122 %description
123 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
124 3.
125
126 %description -l pl.UTF-8
127 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
128
129 %package devel
130 Summary:        Development files for WebKit for GTK+ 3
131 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
132 Group:          X11/Development/Libraries
133 Requires:       %{name} = %{version}-%{release}
134 Requires:       glib2-devel >= 1:2.40
135 Requires:       gtk+3-devel >= 3.12.0
136 Requires:       libsoup-devel >= 2.48
137 Requires:       libstdc++-devel >= 6:4.9
138
139 %description devel
140 Development files for WebKit for GTK+ 3.
141
142 %description devel -l pl.UTF-8
143 Pliki programistyczne komponentu WebKit dla GTK+ 3.
144
145 %package apidocs
146 Summary:        WebKit API documentation
147 Summary(pl.UTF-8):      Dokumentacja API WebKita
148 Group:          Documentation
149 Requires:       gtk-doc-common
150 %if "%{_rpmversion}" >= "5"
151 BuildArch:      noarch
152 %endif
153
154 %description apidocs
155 WebKit API documentation.
156
157 %description apidocs -l pl.UTF-8
158 Dokumentacja API WebKita.
159
160 %prep
161 %setup -q -n webkitgtk-%{version}
162 %patch0 -p1
163 %patch1 -p1
164 %patch2 -p1
165
166 %build
167 install -d build
168 cd build
169 %cmake .. \
170         %{?with_cairogl:-DENABLE_ACCELERATED_2D_CANVAS=ON} \
171         -DENABLE_GEOLOCATION=ON \
172         -DENABLE_GTKDOC=ON \
173         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
174         %{!?with_gtk2:-DENABLE_PLUGIN_PROCESS_GTK2=OFF} \
175         %{!?with_wayland:-DENABLE_WAYLAND_TARGET=OFF} \
176 %ifarch x32
177         -DENABLE_C_LOOP=ON \
178         -DENABLE_JIT=OFF \
179         -DENABLE_SAMPLING_PROFILER=OFF \
180 %endif
181         -DENABLE_VIDEO=ON \
182         -DENABLE_WEB_AUDIO=ON \
183         -DENABLE_WEBGL=ON \
184 %ifarch %{ix86} %{x8664} x32
185         -DHAVE_SSE2_EXTENSIONS=ON \
186 %endif
187         -DPORT=GTK \
188         -DSHOULD_INSTALL_JS_SHELL=ON
189
190 %{__make}
191
192 %install
193 rm -rf $RPM_BUILD_ROOT
194
195 %{__make} -C build install \
196         DESTDIR=$RPM_BUILD_ROOT
197
198 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
199 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
200 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
201 %endif
202
203 %find_lang WebKit2GTK-4.0
204
205 %clean
206 rm -rf $RPM_BUILD_ROOT
207
208 %post   -p /sbin/ldconfig
209 %postun -p /sbin/ldconfig
210
211 %files -f WebKit2GTK-4.0.lang
212 %defattr(644,root,root,755)
213 %doc NEWS
214 %attr(755,root,root) %{_bindir}/WebKitWebDriver
215 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
216 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
217 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
218 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
219 %if %{with introspection}
220 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
221 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
222 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
223 %endif
224 %if "%{_libexecdir}" != "%{_libdir}"
225 %dir %{_libexecdir}/webkit2gtk-4.0
226 %endif
227 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitNetworkProcess
228 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitPluginProcess
229 #%attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitPluginProcess2
230 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitWebProcess
231 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/jsc
232 %dir %{_libdir}/webkit2gtk-4.0
233 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
234 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
235
236 %files devel
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
239 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
240 %if %{with introspection}
241 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
242 %{_datadir}/gir-1.0/WebKit2-4.0.gir
243 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
244 %endif
245 %{_includedir}/webkitgtk-4.0
246 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
247 %{_pkgconfigdir}/webkit2gtk-4.0.pc
248 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
249
250 %files apidocs
251 %defattr(644,root,root,755)
252 %{_gtkdocdir}/jsc-glib-4.0
253 %{_gtkdocdir}/webkit2gtk-4.0
254 %{_gtkdocdir}/webkitdomgtk-4.0
This page took 0.332291 seconds and 3 git commands to generate.