]> git.pld-linux.org Git - packages/gtatool.git/blob - gtatool.spec
- release 4 (by relup.sh)
[packages/gtatool.git] / gtatool.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  qt              # Qt-based GUI
5 %bcond_without  muparser        # compute component module (based on MuParser)
6 %bcond_without  dcmtk           # DCMTK conv module
7 %bcond_without  ffmpeg          # FFmpeg conv module
8 %bcond_without  gdal            # GDAL conv module
9 %bcond_without  jpeg            # JPEG conv module (based on libjpeg)
10 %bcond_without  magick          # Magick conv module (based on ImageMagick's libMagick++)
11 %bcond_without  matio           # MAT conv module (MATLAB import/export, based on [lib]matio)
12 %bcond_without  netcdf          # NetCDF conv module
13 %bcond_without  netpbm          # NetPBM conv module
14 %bcond_without  openexr         # EXR conv module (based on OpenEXR)
15 %bcond_without  pcl             # PCD conv module (based on PCL's libpcl_io)
16 %bcond_without  pfs             # PFS conv module
17 %bcond_without  sndfile         # sndfile conv module
18 %bcond_without  teem            # teem (nrrd) conv module
19 #
20 Summary:        Tools to manipulate Generic Tagged Array (GTA) files
21 Summary(pl.UTF-8):      Narzędzia do obróbki plików GTA (ogólnych tablic etykietowanych)
22 Name:           gtatool
23 Version:        1.5.2
24 Release:        4
25 License:        GPL v3+
26 Group:          Applications/File
27 Source0:        http://download.savannah.gnu.org/releases/gta/%{name}-%{version}.tar.xz
28 # Source0-md5:  1f899e0872d0d706878844bb7f48bc7e
29 Patch0:         ffmpeg2.patch
30 Patch1:         %{name}-pcl.patch
31 URL:            http://gta.nongnu.org/gtatool.html
32 %{?with_magick:BuildRequires:   ImageMagick-c++-devel}
33 %{?with_openexr:BuildRequires:  OpenEXR-devel}
34 %{?with_qt:BuildRequires:       QtGui-devel >= 4.6}
35 BuildRequires:  autoconf >= 2.65
36 BuildRequires:  automake >= 1:1.11.1
37 %{?with_dcmtk:BuildRequires:    dcmtk-devel}
38 %{?with_apidocs:BuildRequires:  doxygen}
39 # libavformat >= 52.110.0 libavdevice libswscale
40 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
41 %{?with_gdal:BuildRequires:     gdal-devel}
42 BuildRequires:  libgta-devel >= 0.9.4
43 %{?with_jpeg:BuildRequires:     libjpeg-devel}
44 %{?with_sndfile:BuildRequires:  libsndfile-devel}
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libtool
47 %{?with_matio:BuildRequires:    matio-devel}
48 %{?with_muparser:BuildRequires: muparser-devel}
49 %{?with_netcdf:BuildRequires:   netcdf-devel}
50 %{?with_netpbm:BuildRequires:   netpbm-devel}
51 %{?with_pcl:BuildRequires:      pcl-devel >= 1.7}
52 %{?with_pfs:BuildRequires:      pfstools-devel}
53 BuildRequires:  pkgconfig
54 %{?with_qt:BuildRequires:       qt4-build >= 4.6}
55 BuildRequires:  tar >= 1:1.22
56 %{?with_teem:BuildRequires:     teem-devel}
57 BuildRequires:  xz
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 Gtatool manipulates Generic Tagged Array (GTA) files.
62
63 It provides a set of commands that manipulate GTAs on various levels,
64 and it can import from and export to many other file formats.
65
66 %description -l pl.UTF-8
67 gtatool pracuje na plikach GTA (Generic Tagged Array - ogólnych
68 tablicach etykietowanych).
69
70 Pakiet zawiera zestaw poleceń obrabiających GTA na różnych poziomach,
71 potrafiących importować i eksportować do wielu innych formatów plików.
72
73 %package component-compute
74 Summary:        gtatool module to compute array element components
75 Summary(pl.UTF-8):      Moduł gtatool do obliczania składowych elementów tablicy
76 Group:          Applications/File
77 Requires:       %{name} = %{version}-%{release}
78
79 %description component-compute
80 gtatool module to compute array element components.
81
82 %description component-compute -l pl.UTF-8
83 Moduł gtatool do obliczania składowych elementów tablicy.
84
85 %package conv-dcmtk
86 Summary:        gtatool module to convert from DICOM format
87 Summary(pl.UTF-8):      Moduł gtatool do konwersji z formatu DICOM
88 Group:          Applications/File
89 Requires:       %{name} = %{version}-%{release}
90
91 %description conv-dcmtk
92 gtatool module to convert from DICOM format.
93
94 %description conv-dcmtk -l pl.UTF-8
95 Moduł gtatool do konwersji z formatu DICOM.
96
97 %package conv-exr
98 Summary:        gtatool module to convert from/to EXR format
99 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu EXR
100 Group:          Applications/File
101 Requires:       %{name} = %{version}-%{release}
102
103 %description conv-exr
104 gtatool module to convert from/to EXR format.
105
106 %description conv-exr -l pl.UTF-8
107 Moduł gtatool do konwersji z/do formatu EXR.
108
109 %package conv-ffmpeg
110 Summary:        gtatool module to convert from FFmpeg formats
111 Summary(pl.UTF-8):      Moduł gtatool do konwersji z formatów FFmpeg
112 Group:          Applications/File
113 Requires:       %{name} = %{version}-%{release}
114
115 %description conv-ffmpeg
116 gtatool module to convert from FFmpeg formats.
117
118 %description conv-ffmpeg -l pl.UTF-8
119 Moduł gtatool do konwersji z formatów FFmpeg.
120
121 %package conv-gdal
122 Summary:        gtatool module to convert from/to GDAL supported formats
123 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez GDAL
124 Group:          Applications/File
125 Requires:       %{name} = %{version}-%{release}
126
127 %description conv-gdal
128 gtatool module to convert from/to GDAL supported formats.
129
130 %description conv-gdal -l pl.UTF-8
131 Moduł gtatool do konwersji z/do formatów obsługiwanych przez GDAL.
132
133 %package conv-jpeg
134 Summary:        gtatool module to convert from/to JPEG formats
135 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu JPEG
136 Group:          Applications/File
137 Requires:       %{name} = %{version}-%{release}
138
139 %description conv-jpeg
140 gtatool module to convert from/to JPEG formats.
141
142 %description conv-jpeg -l pl.UTF-8
143 Moduł gtatool do konwersji z/do formatu JPEG.
144
145 %package conv-magick
146 Summary:        gtatool module to convert from/to ImageMagick supported formats
147 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez ImageMagick
148 Group:          Applications/File
149 Requires:       %{name} = %{version}-%{release}
150
151 %description conv-magick
152 gtatool module to convert from/to ImageMagick supported formats.
153
154 %description conv-magick -l pl.UTF-8
155 Moduł gtatool do konwersji z/do formatów obsługiwanych przez
156 ImageMagick.
157
158 %package conv-mat
159 Summary:        gtatool module to convert from/to MAT format
160 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu MAT
161 Group:          Applications/File
162 Requires:       %{name} = %{version}-%{release}
163
164 %description conv-mat
165 gtatool module to convert from/to MAT (Matlab) format.
166
167 %description conv-mat -l pl.UTF-8
168 Moduł gtatool do konwersji z/do formatu MAT (z programu Matlab).
169
170 %package conv-netcdf
171 Summary:        gtatool module to convert from/to NetCDF format
172 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu NetCDF
173 Group:          Applications/File
174 Requires:       %{name} = %{version}-%{release}
175
176 %description conv-netcdf
177 gtatool module to convert from/to NetCDF format.
178
179 %description conv-netcdf -l pl.UTF-8
180 Moduł gtatool do konwersji z/do formatu NetCDF.
181
182 %package conv-netpbm
183 Summary:        gtatool module to convert from/to NetPBM supported formats
184 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez NetPBM
185 Group:          Applications/File
186 Requires:       %{name} = %{version}-%{release}
187
188 %description conv-netpbm
189 gtatool module to convert from/to NetPBM supported formats.
190
191 %description conv-netpbm -l pl.UTF-8
192 Moduł gtatool do konwersji z/do formatów obsługiwanych przez NetPBM.
193
194 %package conv-pcd
195 Summary:        gtatool module to convert from/to PCD format
196 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu PCD
197 Group:          Applications/File
198 Requires:       %{name} = %{version}-%{release}
199
200 %description conv-pcd
201 gtatool module to convert from/to PCD format.
202
203 %description conv-pcd -l pl.UTF-8
204 Moduł gtatool do konwersji z/do formatu PCD.
205
206 %package conv-pfs
207 Summary:        gtatool module to convert from/to PFS format
208 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu PFS
209 Group:          Applications/File
210 Requires:       %{name} = %{version}-%{release}
211
212 %description conv-pfs
213 gtatool module to convert from/to PFS format.
214
215 %description conv-pfs -l pl.UTF-8
216 Moduł gtatool do konwersji z/do formatu PFS.
217
218 %package conv-sndfile
219 Summary:        gtatool module to convert from/to libsndfile supported formats
220 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez libsndfile
221 Group:          Applications/File
222 Requires:       %{name} = %{version}-%{release}
223
224 %description conv-sndfile
225 gtatool module to convert from/to libsndfile supported formats.
226
227 %description conv-sndfile -l pl.UTF-8
228 Moduł gtatool do konwersji z/do formatów obsługiwanych przez
229 libsndfile.
230
231 %package conv-teem
232 Summary:        gtatool module to convert from/to Teem (NRRD) format
233 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu Teem (NRRD)
234 Group:          Applications/File
235 Requires:       %{name} = %{version}-%{release}
236
237 %description conv-teem
238 gtatool module to convert from/to Teem (NRRD) format.
239
240 %description conv-teem -l pl.UTF-8
241 Moduł gtatool do konwersji z/do formatu Teem (NRRD).
242
243 %package gui
244 Summary:        Qt-based GUI module for gtatool
245 Summary(pl.UTF-8):      Moduł graficznego interfejsu użytkownika opartego na Qt dla narzędzia gtatool
246 Group:          X11/Applications
247 Requires:       %{name} = %{version}-%{release}
248 Requires:       QtGui >= 4.6
249
250 %description gui
251 Qt-based GUI module for gtatool.
252
253 %description gui -l pl.UTF-8
254 Moduł graficznego interfejsu użytkownika opartego na Qt dla narzędzia
255 gtatool.
256
257 %package -n bash-completion-gtatool
258 Summary:        Bash completion for gtatool command
259 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów programu gtatool
260 Group:          Applications/Shells
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       bash-completion
263
264 %description -n bash-completion-gtatool
265 Bash completion for gtatool command.
266
267 %description -n bash-completion-gtatool -l pl.UTF-8
268 Bashowe uzupełnianie parametrów programu gtatool.
269
270 %prep
271 %setup -q
272 %patch0 -p1
273 %patch1 -p1
274
275 %build
276 %{__libtoolize}
277 %{__aclocal} -I m4
278 %{__autoconf}
279 %{__autoheader}
280 %{__automake}
281 %configure \
282         --disable-silent-rules \
283         %{!?with_dcmtk:--without-dcmtk} \
284         %{!?with_ffmpeg:--without-ffmpeg} \
285         %{!?with_gdal:--without-gdal} \
286         %{!?with_jpeg:--without-jpeg} \
287         %{!?with_magick:--without-magick} \
288         %{!?with_matio:--without-matio} \
289         %{!?with_muparser:--without-muparser} \
290         %{!?with_netcdf:--without-netcdf} \
291         %{!?with_netpbm:--without-netpbm} \
292         %{!?with_openexr:--without-openexr} \
293         %{!?with_pcl:--without-pcd} \
294         %{!?with_pfs:--without-pfs} \
295         %{!?with_qt:--without-qt} \
296         %{!?with_sndfile:--without-sndfile} \
297         %{!?with_teem:--without-teem}
298 %{__make}
299
300 %install
301 rm -rf $RPM_BUILD_ROOT
302
303 %{__make} install \
304         DESTDIR=$RPM_BUILD_ROOT
305
306 %clean
307 rm -rf $RPM_BUILD_ROOT
308
309 %post   -p /sbin/postshell
310 -/usr/sbin/fix-info-dir -c %{_infodir}
311
312 %postun -p /sbin/postshell
313 -/usr/sbin/fix-info-dir -c %{_infodir}
314
315 %files
316 %defattr(644,root,root,755)
317 %doc AUTHORS ChangeLog NEWS README
318 %attr(755,root,root) %{_bindir}/gta
319 %dir %{_libdir}/gtatool
320 %attr(755,root,root) %{_libdir}/gtatool/conv-csv.so
321 %attr(755,root,root) %{_libdir}/gtatool/conv-datraw.so
322 %attr(755,root,root) %{_libdir}/gtatool/conv-ply.so
323 %attr(755,root,root) %{_libdir}/gtatool/conv-pvm.so
324 %attr(755,root,root) %{_libdir}/gtatool/conv-rat.so
325 %attr(755,root,root) %{_libdir}/gtatool/conv-raw.so
326 %{_mandir}/man1/gta.1*
327 %{_infodir}/gta.info*
328
329 %if %{with muparser}
330 %files component-compute
331 %defattr(644,root,root,755)
332 %attr(755,root,root) %{_libdir}/gtatool/component-compute.so
333 %endif
334
335 %if %{with dcmtk}
336 %files conv-dcmtk
337 %defattr(644,root,root,755)
338 %attr(755,root,root) %{_libdir}/gtatool/conv-dcmtk.so
339 %endif
340
341 %if %{with openexr}
342 %files conv-exr
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_libdir}/gtatool/conv-exr.so
345 %endif
346
347 %if %{with ffmpeg}
348 %files conv-ffmpeg
349 %defattr(644,root,root,755)
350 %attr(755,root,root) %{_libdir}/gtatool/conv-ffmpeg.so
351 %endif
352
353 %if %{with gdal}
354 %files conv-gdal
355 %defattr(644,root,root,755)
356 %attr(755,root,root) %{_libdir}/gtatool/conv-gdal.so
357 %endif
358
359 %if %{with jpeg}
360 %files conv-jpeg
361 %defattr(644,root,root,755)
362 %attr(755,root,root) %{_libdir}/gtatool/conv-jpeg.so
363 %endif
364
365 %if %{with magick}
366 %files conv-magick
367 %defattr(644,root,root,755)
368 %attr(755,root,root) %{_libdir}/gtatool/conv-magick.so
369 %endif
370
371 %if %{with matio}
372 %files conv-mat
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{_libdir}/gtatool/conv-mat.so
375 %endif
376
377 %if %{with netcdf}
378 %files conv-netcdf
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{_libdir}/gtatool/conv-netcdf.so
381 %endif
382
383 %if %{with netpbm}
384 %files conv-netpbm
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{_libdir}/gtatool/conv-netpbm.so
387 %endif
388
389 %if %{with pcl}
390 %files conv-pcd
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_libdir}/gtatool/conv-pcd.so
393 %endif
394
395 %if %{with pfs}
396 %files conv-pfs
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/gtatool/conv-pfs.so
399 %endif
400
401 %if %{with sndfile}
402 %files conv-sndfile
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_libdir}/gtatool/conv-sndfile.so
405 %endif
406
407 %if %{with teem}
408 %files conv-teem
409 %defattr(644,root,root,755)
410 %attr(755,root,root) %{_libdir}/gtatool/conv-teem.so
411 %endif
412
413 %if %{with qt}
414 %files gui
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_libdir}/gtatool/gui.so
417 %{_desktopdir}/gta_gui.desktop
418 %{_iconsdir}/hicolor/*/apps/gta.png
419 %{_iconsdir}/hicolor/scalable/apps/gta.svg
420 %endif
421
422 %files -n bash-completion-gtatool
423 %defattr(644,root,root,755)
424 /etc/bash_completion.d/gta-completion.bash
This page took 0.099718 seconds and 3 git commands to generate.