]> git.pld-linux.org Git - packages/gstreamer-devtools.git/blob - gstreamer-devtools.spec
- updated to 1.24.0
[packages/gstreamer-devtools.git] / gstreamer-devtools.spec
1 # TODO: package debug-viewer?
2 #
3 # Conditional build:
4 %bcond_without  apidocs # API documentation
5
6 %define         gstmver         1.0
7 %define         gst_ver         1.24.0
8 %define         gstpb_ver       1.24.0
9 %define         gstpd_ver       1.24.0
10 %define         gstrtsp_ver     %{gst_ver}
11 Summary:        GStreamer development and validation tools
12 Summary(pl.UTF-8):      Narzędzia programistyczne i sprawdzające do GStreamera
13 Name:           gstreamer-devtools
14 Version:        1.24.0
15 Release:        1
16 License:        LGPL v2.1+
17 Group:          Libraries
18 Source0:        https://gstreamer.freedesktop.org/src/gst-devtools/gst-devtools-%{version}.tar.xz
19 # Source0-md5:  ac1d4ddf3b905370f5cf43f430b2365b
20 URL:            https://gstreamer.freedesktop.org/
21 BuildRequires:  cairo-devel
22 BuildRequires:  gettext-devel >= 0.17
23 BuildRequires:  glib2-devel >= 1:2.64.0
24 BuildRequires:  gobject-introspection-devel >= 0.6.3
25 BuildRequires:  gstreamer-devel >= %{gst_ver}
26 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_ver}
27 BuildRequires:  gstreamer-rtsp-server-devel >= %{gstrtsp_ver}
28 BuildRequires:  gstreamer-transcoder-devel >= %{gstpd_ver}
29 BuildRequires:  gtk+3-devel >= 3.0
30 %{?with_apidocs:BuildRequires:  hotdoc}
31 BuildRequires:  json-glib-devel >= 1.0
32 BuildRequires:  meson >= 1.1
33 BuildRequires:  ninja >= 1.5
34 BuildRequires:  pkgconfig >= 1:0.9.0
35 BuildRequires:  python3 >= 1:3.4
36 BuildRequires:  rpm-build >= 4.6
37 BuildRequires:  sed >= 4.0
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  xz
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 GStreamer development and validation tools including GstValidate, a
44 testing framework aiming at providing GStreamer developers tools that
45 check the GstElements they write behave the way they are supposed to.
46
47 %description -l pl.UTF-8
48 Narzędzia programistyczne i sprawdzające do GStreamera, w tym
49 GstValidate, szkielet testowy, którego celem jest zapewnienie
50 programistom narzędzi sprawdzających, czy obiekty GstElement zachowują
51 się w pożądany sposób.
52
53 %package apidocs
54 Summary:        API documentation for GstValidate library
55 Summary(pl.UTF-8):      Dokumentacja API biblioteki GstValidate
56 Group:          Documentation
57 Obsoletes:      gstreamer-validate-apidocs < 1.18
58 BuildArch:      noarch
59
60 %description apidocs
61 API documentation for GstValidate library.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API biblioteki GstValidate.
65
66 %package -n gstreamer-validate
67 Summary:        GstValidate - suite of tools to run GStreamer integration tests
68 Summary(pl.UTF-8):      GstValidate - zestaw narzędzi do uruchamiania testów integracyjnych GStreamera
69 Group:          Libraries
70 Requires:       glib2 >= 1:2.64.0
71 Requires:       gstreamer >= %{gst_ver}
72 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
73 Requires:       gstreamer-rtsp-server >= %{gstrtsp_ver}
74 Requires:       gstreamer-transcoder >= %{gstpd_ver}
75 Requires:       json-glib >= 1.0
76 Requires:       python3-modules >= 1:3.4
77
78 %description -n gstreamer-validate
79 The goal of GstValidate is to be able to detect when elements are not
80 behaving as expected and report it to the user so he knows how things
81 are supposed to work inside a GstPipeline. In the end, fixing issues
82 found by the tool will ensure that all elements behave all together in
83 the expected way.
84
85 %description -n gstreamer-validate -l pl.UTF-8
86 Celem GstValidate jest umożliwienie wykrycia sytuacji, kiedy elementy
87 nie zachowują się w sposób oczekiwany i zgłaszanie tego faktu
88 użytkownikowi tak, aby wiedział, jak powinny działać elementy wewnątrz
89 GstPipeline. W efekcie, poprawienie problemów wykrytych przez to
90 narzędzie zapewni, że wszystkie elementy razem będą się zachowywały w
91 sposób zgodny z oczekiwaniami.
92
93 %package -n gstreamer-validate-devel
94 Summary:        Header files for GstValidate library
95 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GstValidate
96 Group:          Development/Libraries
97 Requires:       glib2-devel >= 1:2.64.0
98 Requires:       gstreamer-devel >= %{gst_ver}
99 Requires:       gstreamer-plugins-base-devel >= %{gstpb_ver}
100 Requires:       gstreamer-validate = %{version}-%{release}
101
102 %description -n gstreamer-validate-devel
103 Header files for GstValidate library.
104
105 %description -n gstreamer-validate-devel -l pl.UTF-8
106 Pliki nagłówkowe biblioteki GstValidate.
107
108 %prep
109 %setup -q -n gst-devtools-%{version}
110
111 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' validate/tools/gst-validate-launcher.in
112
113 %build
114 %meson build \
115         --default-library=shared \
116         %{!?with_apidocs:-Ddoc=false}
117
118 %ninja_build -C build
119
120 %if %{with apidocs}
121 cd build/docs
122 LC_ALL=C.UTF-8 hotdoc run --conf-file gst-devtools-doc.json
123 %endif
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %ninja_install -C build
129
130 %if %{with apidocs}
131 install -d $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
132 cp -pr build/docs/gst-devtools-doc $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
133 %endif
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -n gstreamer-validate -p /sbin/ldconfig
139 %postun -n gstreamer-validate -p /sbin/ldconfig
140
141 %if %{with apidocs}
142 %files apidocs
143 %defattr(644,root,root,755)
144 %{_docdir}/gstreamer-%{gstmver}/gst-devtools-doc
145 %endif
146
147 %files -n gstreamer-validate
148 %defattr(644,root,root,755)
149 %doc ChangeLog NEWS RELEASE validate/README
150 %attr(755,root,root) %{_bindir}/gst-validate-1.0
151 %attr(755,root,root) %{_bindir}/gst-validate-images-check-1.0
152 %attr(755,root,root) %{_bindir}/gst-validate-launcher
153 %attr(755,root,root) %{_bindir}/gst-validate-media-check-1.0
154 %attr(755,root,root) %{_bindir}/gst-validate-rtsp-server-1.0
155 %attr(755,root,root) %{_bindir}/gst-validate-transcoding-1.0
156 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-1.0.so.0
158 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-default-overrides-1.0.so.0
160 %{_libdir}/girepository-1.0/GstValidate-1.0.typelib
161 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstvalidatetracer.so
162 %dir %{_libdir}/gstreamer-1.0/validate
163 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidatefaultinjection.so
164 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidategapplication.so
165 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidategtk.so
166 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidatessim.so
167 %{_libdir}/gst-validate-launcher
168 %dir %{_datadir}/gstreamer-1.0
169 %{_datadir}/gstreamer-1.0/validate
170
171 %files -n gstreamer-validate-devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so
174 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so
175 %{_includedir}/gstreamer-1.0/gst/validate
176 %{_pkgconfigdir}/gstreamer-validate-1.0.pc
177 %{_datadir}/gir-1.0/GstValidate-1.0.gir
This page took 0.070733 seconds and 3 git commands to generate.