]> git.pld-linux.org Git - packages/gssdp.git/blob - gssdp.spec
Update to 1.0.1
[packages/gssdp.git] / gssdp.spec
1 #
2 # Conditional build:
3 %bcond_without  vala    # Vala bindings
4
5 Summary:        GObject-based SSDP (Simple Service Discovery Protocol) library
6 Summary(pl.UTF-8):      Biblioteka SSDP (Simple Service Discovery Protocol) oparta na GObject
7 Name:           gssdp
8 # note: 1.0.x is stable, 1.1.x unstable
9 Version:        1.0.1
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gssdp/1.0/%{name}-%{version}.tar.xz
14 # Source0-md5:  5d5cc05b7ab7985ef51f0d3feeca92e1
15 URL:            http://gupnp.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  glib2-devel >= 1:2.32
20 BuildRequires:  gobject-introspection-devel >= 1.36.0
21 BuildRequires:  gtk+3-devel >= 3.0
22 BuildRequires:  gtk-doc >= 1.14
23 BuildRequires:  libsoup-devel >= 2.26.1
24 BuildRequires:  libtool >= 2:2.2
25 BuildRequires:  pkgconfig
26 BuildRequires:  tar >= 1:1.22
27 %{?with_vala:BuildRequires:     vala >= 2:0.20}
28 BuildRequires:  xz
29 Requires:       glib2 >= 1:2.32
30 Requires:       gtk+3 >= 3.0
31 Requires:       libsoup >= 2.26.1
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 GSSDP is a GObject-based API that implements resource discovery and
36 announcement over SSDP (Simple Service Discovery Protocol).
37
38 %description -l pl.UTF-8
39 GSSDP to oparte na bibliotece GObject API implementujące wykrywanie i
40 rozgłaszanie zasobów przy użyciu protokołu SSDP (Simple Service
41 Discovery Protocol).
42
43 %package devel
44 Summary:        Header files for GSSDP
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GSSDP
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 1:2.32
49 Requires:       libsoup-devel >= 2.26.1
50
51 %description devel
52 This package contains header files for GSSDP library.
53
54 %description devel -l pl.UTF-8
55 Ten pakiet zawiera pliki nagłówkowe biblioteki GSSDP.
56
57 %package static
58 Summary:        Static GSSDP library
59 Summary(pl.UTF-8):      Statyczna biblioteka GSSDP
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static GSSDP library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka GSSDP.
68
69 %package apidocs
70 Summary:        GSSDP API documentation
71 Summary(pl.UTF-8):      Dokumentacja API GSSDP
72 Group:          Documentation
73 Requires:       gtk-doc-common
74 %if "%{_rpmversion}" >= "5"
75 BuildArch:      noarch
76 %endif
77
78 %description apidocs
79 GSSDP API documentation.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API GSSDP.
83
84 %package -n vala-gssdp
85 Summary:        Vala binding for GSSDP library
86 Summary(pl.UTF-8):      Wiązanie języka Vala do biblioteki GSSDP
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Requires:       vala >= 2:0.20
90 %if "%{_rpmversion}" >= "5"
91 BuildArch:      noarch
92 %endif
93
94 %description -n vala-gssdp
95 Vala binding for GSSDP library.
96
97 %description -n vala-gssdp -l pl.UTF-8
98 Wiązanie języka Vala do biblioteki GSSDP.
99
100 %prep
101 %setup -q
102
103 %build
104 %{__gtkdocize}
105 %{__libtoolize}
106 %{__aclocal} -I m4
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         --disable-silent-rules \
112         --enable-gtk-doc \
113         --with-html-dir=%{_gtkdocdir}
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS NEWS README
134 %attr(755,root,root) %{_bindir}/gssdp-device-sniffer
135 %attr(755,root,root) %{_libdir}/libgssdp-1.0.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libgssdp-1.0.so.3
137 %{_libdir}/girepository-1.0/GSSDP-1.0.typelib
138 %{_datadir}/gssdp
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libgssdp-1.0.so
143 %{_datadir}/gir-1.0/GSSDP-1.0.gir
144 %{_includedir}/gssdp-1.0
145 %{_pkgconfigdir}/gssdp-1.0.pc
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libgssdp-1.0.a
150
151 %files apidocs
152 %defattr(644,root,root,755)
153 %{_gtkdocdir}/gssdp
154
155 %if %{with vala}
156 %files -n vala-gssdp
157 %defattr(644,root,root,755)
158 %{_datadir}/vala/vapi/gssdp-1.0.deps
159 %{_datadir}/vala/vapi/gssdp-1.0.vapi
160 %endif
This page took 0.073247 seconds and 3 git commands to generate.