]> git.pld-linux.org Git - packages/gnome-code-assistance.git/blob - gnome-code-assistance.spec
afb93dc9ccc63f07dca02384cf6fd1e5dab1539f
[packages/gnome-code-assistance.git] / gnome-code-assistance.spec
1 #
2 # Conditional build:
3 %bcond_without  llvm    # (LLVM based) C backend
4 %bcond_without  golang  # Go backend
5 #
6 %ifarch x32 ppc64
7 %undefine       with_llvm
8 %endif
9 %ifnarch %{ix86} %{x8664} %{arm}
10 %undefine       with_golang
11 %endif
12 Summary:        Common code assistance services for code editors
13 Summary(pl.UTF-8):      Wspólne usługi wspierające pracę z kodem dla edytorów kodu
14 Name:           gnome-code-assistance
15 Version:        3.16.0
16 Release:        3
17 License:        GPL v2+
18 Group:          X11/Applications/Editors
19 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-code-assistance/3.16/%{name}-%{version}.tar.xz
20 # Source0-md5:  356a034dd60271f39f3d5ce658b75f09
21 Patch0:         vala-0.32.patch
22 URL:            https://wiki.gnome.org/Projects/CodeAssistance
23 BuildRequires:  gjs-devel
24 BuildRequires:  glib2 >= 1:2.36
25 BuildRequires:  gobject-introspection
26 # version with just "go" executable
27 %{?with_golang:BuildRequires:   golang >= 1.3}
28 %{?with_llvm:BuildRequires:     llvm-devel}
29 BuildRequires:  pkgconfig
30 BuildRequires:  python3 >= 1:3.2
31 BuildRequires:  python3-dbus
32 BuildRequires:  python3-pygobject3 >= 3.8
33 BuildRequires:  python3-simplejson
34 # with ripper module
35 BuildRequires:  ruby >= 1:1.9.1
36 BuildRequires:  ruby-dbus
37 BuildRequires:  ruby-sass >= 3.3
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  vala >= 2:0.20
40 BuildRequires:  vala-libgee >= 0.8
41 BuildRequires:  xz
42 Requires:       glib2 >= 1:2.36
43 Requires:       gobject-introspection
44 Requires:       libgee >= 0.8
45 Requires:       python3 >= 1:3.2
46 Requires:       python3-dbus
47 Requires:       python3-pygobject3 >= 3.8
48 Requires:       python3-simplejson
49 Requires:       ruby >= 1:1.9.1
50 Requires:       ruby-dbus
51 Requires:       ruby-sass >= 3.3
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %if %{with golang}
55 %define         _enable_debug_packages  0
56 %endif
57
58 %description
59 gnome-code-assistance is a project which aims to provide common code
60 assistance services for code editors (simple editors as well as IDEs).
61 It is an effort to provide a centralized code-assistance as a service
62 for the GNOME platform instead of having every editor implement their
63 own solution.
64
65 %description -l pl.UTF-8
66 gnome-code-assistance to projekt mający na celu dostarczenie wspólnych
67 usług wspierających pracę z kodem dla edytorów kodu (zarówno prostych
68 edytorów, jak i IDE). Jest to próba zapewnienia centralnego wsparcia
69 edycji kodu jako usługi dla platformy GNOME zamiast implementowania
70 własnego rozwiązania w każdym edytorze.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75
76 %build
77 %{__aclocal}
78 %{__autoconf}
79 %{__autoheader}
80 %{__automake}
81 %configure \
82         %{!?with_llvm:--disable-c} \
83         %{!?with_golang:--disable-go} \
84         --disable-silent-rules
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %{__sed} -i -e '1s,/usr/bin/env gjs,/usr/bin/gjs,' $RPM_BUILD_ROOT%{_libexecdir}/gnome-code-assistance/js
95 %if %{with llvm}
96 %{__sed} -i -e '1s,/usr/bin/env python3,/usr/bin/python3,' $RPM_BUILD_ROOT%{_libexecdir}/gnome-code-assistance/c
97 %endif
98 %{__sed} -i -e '1s,/usr/bin/env python3,/usr/bin/python3,' $RPM_BUILD_ROOT%{_libexecdir}/gnome-code-assistance/{json,python,sh,xml}
99 %{__sed} -i -e '1s,/usr/bin/env ruby,/usr/bin/ruby,' $RPM_BUILD_ROOT%{_libexecdir}/gnome-code-assistance/{css,ruby}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(644,root,root,755)
106 %doc AUTHORS ChangeLog NEWS README
107 %dir %{_libexecdir}/gnome-code-assistance
108 %if %{with llvm}
109 # R: python3, llvm
110 %attr(755,root,root) %{_libexecdir}/gnome-code-assistance/c
111 %endif
112 # R: ruby, ruby-sass
113 %attr(755,root,root) %{_libexecdir}/gnome-code-assistance/css
114 %if %{with golang}
115 %attr(755,root,root) %{_libexecdir}/gnome-code-assistance/go
116 %endif
117 # R: gjs
118 %attr(755,root,root) %{_libexecdir}/gnome-code-assistance/js
119 # R: python3, python3-simplejson
120 %attr(755,root,root) %{_libexecdir}/gnome-code-assistance/json
121 # R: python3
122 %attr(755,root,root) %{_libexecdir}/gnome-code-assistance/python
123 # R: ruby
124 %attr(755,root,root) %{_libexecdir}/gnome-code-assistance/ruby
125 # R: python3
126 %attr(755,root,root) %{_libexecdir}/gnome-code-assistance/sh
127 # R: glib2 libgee
128 %attr(755,root,root) %{_libexecdir}/gnome-code-assistance/vala
129 # R: vala (libvala)
130 %attr(755,root,root) %{_libexecdir}/gnome-code-assistance/valahelper
131 # R: python3
132 %attr(755,root,root) %{_libexecdir}/gnome-code-assistance/xml
133 %dir %{_libexecdir}/gnome-code-assistance/backends
134 %{_libexecdir}/gnome-code-assistance/backends/js
135 # R: python3-dbus
136 %{_libexecdir}/gnome-code-assistance/backends/py
137 # R: ruby-dbus
138 %{_libexecdir}/gnome-code-assistance/backends/rb
139 %{_datadir}/dbus-1/services/org.gnome.CodeAssist.v1.*.service
140 %{_datadir}/glib-2.0/schemas/org.gnome.codeassistance.gschema.xml
This page took 0.077997 seconds and 2 git commands to generate.